Kontrol S49 Display Not showing instrument Artwork

Sam Govin
Sam Govin Member Posts: 16 Member

Hi friends,

I have another issue with my new S49 MK3, where when I load instruments, the display on keyboard does not show the artwork that appear on the DAW. Anyone have any advice?


Best Answer

  • apsande
    apsande Member Posts: 8 Member
    Answer ✓

    Hi Sam


    Try this link support.native-instruments.com/hc/en-us/articles/360018591137-Product-Pictures-are-Missing-in-the-Komplete-Kontrol-Maschine-2-Browser. Basically, each image folder needs a file called NKS2_hardware_banner.webp. Following the instructions in the link will force a refresh of the image folder.


    It worked for me.

Answers

  • apsande
    apsande Member Posts: 8 Member
    Answer ✓

    Hi Sam


    Try this link support.native-instruments.com/hc/en-us/articles/360018591137-Product-Pictures-are-Missing-in-the-Komplete-Kontrol-Maschine-2-Browser. Basically, each image folder needs a file called NKS2_hardware_banner.webp. Following the instructions in the link will force a refresh of the image folder.


    It worked for me.

  • Sam Govin
    Sam Govin Member Posts: 16 Member

    Thanks buddy, but the link seems for the browser on Mac, but on Mac it all seems ok only on Kontrol keyboard its not appearing

  • Sam Govin
    Sam Govin Member Posts: 16 Member

    I tried doing the steps, however still the same. I am using Mac OS Sonoma not sure if that is the issue. When I launch Komplete control, the ScanApp3 app crashes.

  • Sam Govin
    Sam Govin Member Posts: 16 Member

    Aspande, wow it worked after my 2nd try. Thanks so much buddy.


  • apsande
    apsande Member Posts: 8 Member


    No problem. Glad it worked.


    Happy New Year 😀

  • Sam Govin
    Sam Govin Member Posts: 16 Member

    Thanks again happy new year to all

  • Patlican
    Patlican Member Posts: 7 Member
    edited January 5

    I tried this "solution" to get my new Kontrol MK3 keys to display the arturia artwork Which did not work at all and it still does not, And I had hoped it also would solve this error with some arturia plugins (which really do have a VST3 certification) I get when selecting a preset from the komplete kontrol preset browser

    The only "workaround" for this is to open an instance of a plugin that does not give this error and then manually swap it for the desired one and then I can use the arturia buit in preset browser (without the preview sound) and it loads fine

  • apsande
    apsande Member Posts: 8 Member

    Hi Patlican,

    Arturia need to update the NI presets to support vst3 in Komplete Kontrol. I notice you are on cs-80 version 3 when the latest is version v. I don’t know if Arturia are updating older versions. They are also only making the latest versions of the plug-in nks2 so the banners you need for the art work may not be available for the older versions.


    However, I have often found some art work for Arturia has a habit of going missing. You can get copies from the Arturia installation files.

Back To Top