Compatibility of Logic saved patches when upgrading Kontakt enquiry

el-bo
el-bo Member Posts: 35 Member

Been thinking of saving instances of Kontakt libraries, favourite presets etc. as Logic saved patches. If I do this with K6 and later upgrade to K7, is there an easy way to update those patches to work in the lates edition?

Thank :)

Best Answer

Answers

  • Milos
    Milos Member Posts: 1,861 Pro

    Hmm...maybe there is a way to open them in K7.

    First, you need the OG Rack view for that.

    Now click on the Files, which is right beside Libraries, and search for the file where you saved your samples.

    Let me know if it helped, sir.

  • el-bo
    el-bo Member Posts: 35 Member

    Many thanks for your answer. However, I don't currently own K7. This is an enquiry abotu possible future upgrade. I'm wondering if I save off a few hundred presets within Logic Pro that reference K6, whether there will be a way to bulk redirect those K6 references to the new K7, K8, K9 etc. or whether the presets would have to be individually re-saved.

    Thanks.

  • Kymeia
    Kymeia Member Posts: 3,489 Expert
    edited December 2023

    tbh it's very confusing how NI sometimes keep the Kontakt name without a number so you can update safely, then they go back to using version numbers and separate plugins so you can't. Perhaps hedge your bets, save a copy with V6 and one with Kontakt Player? At least hopefully the latter will still open (and should open in Kontakt 7 if you go full). A little more work now saves a lot more work later :)

  • el-bo
    el-bo Member Posts: 35 Member

    Interesting! Thanks!

    So, had they left the naming convention un-numbered it would just work as expected?

    Currently straddling the two boats of K6 and K7 Player, so I could save both as a precaution. However, unless I'm missing something, saving duplicates in K7P will still involve the same amount of work as if I would have to re-save the presets in K7, K8 etc. It also would only apply to Player-compatible libraries, so all the 3rd-party stuff could only be done with K6.

    What happens for all those that have large templates with many instances of Kontakt?

    Definitely confusing, as you say. To my layman mind, it seems like it would be a trivially simple thing to allow Kontakt to resolve all instances to the current version. But I'm sure there must be reasons why that can't happen.

    Cheers!

  • Kymeia
    Kymeia Member Posts: 3,489 Expert

    However, unless I'm missing something, saving duplicates in K7P will still involve the same amount of work as if I would have to re-save the presets in K7, K8 etc.

    Yes of course, but since you are doing it anyway saving 2 instead of just 1 as you go along may seem less onerous than suddenly being faced with resaving several hundred if you upgrade. However you are right about the non player stuff, not sure what to do there. I think many users would be very pleased if NI once and for all resolved this constant Kontakt versions issue, it comes up every time a new version comes out.

  • el-bo
    el-bo Member Posts: 35 Member

    Yeah, I see what you're saying. But that's quite a lot of hedging ;)

    I wonder what the reason might be to not get on top of this issue, if it has been so long-standing.

    Also, one other thing I hadn't really considered is version support. Have you any experience to share regarding how long older versions are supported, OS-maintained etc.?

  • el-bo
    el-bo Member Posts: 35 Member

    Would still be interested if anyone can chime in to give an idea how long previous Kontakt versions remain updated.

    I know it's the worst day to be asking, but I thought to at least ask before the thread gets closed.

    Many thanks

  • Kymeia
    Kymeia Member Posts: 3,489 Expert
    edited December 2023

    Yeah sorry that I'm not sure but it looks like 6 and 7 are only the actively maintained versions (6 maybe more for Maschine + users?)

  • el-bo
    el-bo Member Posts: 35 Member

    No need to apologise. You've been very helpful.

    It's a bit of a surprise, really. Given that Kontakt seems to be the backbone of so many media/film composer's templates, I can't believe there's no robust solution to deal with updates. Do these composers have to re-build their 1000+ track templates with every new version?

  • Kymeia
    Kymeia Member Posts: 3,489 Expert
    edited December 2023 Answer ✓

    Actually it does look like they have tried to introduce something in K7 that maybe begins to address this - seems very host dependent though

    https://support.native-instruments.com/hc/fr/articles/12972701353757-Notes-about-Auto-Migration-of-Kontakt-Versions-in-DAW-Projects#:~:text=If%20you%20want%20to%20keep,2.

    Also I'm pretty sure that if any version of Kontakt was used inside Komplete Kontrol, KK does implement auto migration as long as you have the use latest version of NI plugins checked in settings

  • el-bo
    el-bo Member Posts: 35 Member

    Aha! Brilliant! Seems this should solve all of these issues. Presumably, if I wanted all my saved patches to auto-migrate, I'd just have to make a template containing all of them, remove the older Kontakt version, and let the process update it all. I wonder in that case, if I'd need to re-save the patches. I guess that would still be easier than rebuilding them from scratch, which is what would've been need otherwise.

    Good to know I can keep on using K6 for a wile longer.

    Many thanks :)

Back To Top