Multicore Processing increases load meter

I'm using a 2021 Apple M1 Pro with Traktor 3.10.1.

When ever I activate multicore processing, the load meter increases higher than it does when multicore isn't active.

I'm pretty sure this isn't normal, right?

Any help or explanation would be highly appreciated.



  • viper9711
    viper9711 Member Posts: 72 Helper

    This is completely normal because the CPU loads all cores and therefore the system utilization is higher.

    But I wouldn't worry about it at all - my MacBook Pro with M1 gets bored when using the tractor...

  • Kubrak
    Kubrak Member Posts: 2,762 Expert
    edited December 2023

    IMHO, if TP in multicore, and OS places one thread on e-core, instead of all to p-core what would be if using single core.... Higher CPU load may exhibit.... Traktor/DAW CPU meter does not show the load of entire CPU, instead it shows the percentage of safety buffer used. And it generally corelates on percentage of CPU per core use. E-core gives less overall CPU power comparing to P-core and if OS places thread on e-core, it may be well loaded. And so safety buffer must be used more intensively.....

    I do not think it is right and it might lead to dropouts under circumstances, but that is the drawback of big.little architecture.... And insufficient work of OS.

    On Win, user may disable e-cores or use 3rd party App to tell OS what cores should given application prefer...

    AFAIK no such possibilities exist on Mac.... I am not on Mac.

  • Owner
    Owner Member Posts: 280 Pro

    There were always problems on Mac, where it was suggested to deactivate the multicore processor support to get around it. That's why I always ignored it.

    In any case, the Traktor user manual says this:

    If the Enable Multi-Core Processor Support option is activated, the computing load generated by the program can be better distributed for demanding functions such as active keylock on all decks.

    The feature must be disabled if you are running a second real-time application on the same computer.

  • Rajiv Cassie
    Rajiv Cassie Member Posts: 7 Member
    edited December 2023

    So the reason why I mainly brought this up is that I'm an open format DJ who scratches and so forth.

    If I'm mixing music regularly while Multicore Processing and Key Lock is active, it's perfectly fine, the load meter remains low.

    However, when scratching with both active, it immediately boosts to load bar, sometimes tapping in to the red zone causing popping sounds. Activity Monitor shows no sign that heavy processing is taking place, it's just within Traktor where the load meter spikes. It does the same when Multicore isnt active, but it doesnt tap in to the red.

    I assumed these M1 Mac's would have been powerful enough to handle anything Traktor could throw at it.

  • c0nsul
    c0nsul Member Posts: 292 Pro

    Increase your buffer size in preferences.

    "The LOAD indicator in the Traktor header shows how much available audio buffer is currently being used for audio processing. This is not synonymous with the computer's processor usage. The displayed value corresponds to the time required for the entire real-time audio processing. The total bar represents the total size of the audio buffer."

    translated with deepL from

  • Stevan
    Stevan Traktor Mapping Mod Posts: 1,547 mod

    Sorry to hear it... I found that basic M1 (non-pro) works best. I also had similar issues with M1 Pro and M2 Pro.

    The M1 Pro seems to have the most issues with the real time audio processing that I've seen reported online.

  • Owner
    Owner Member Posts: 280 Pro

    Then, as @c0nsul already said: Increase the buffer size in the settings. With a threshold value of around 10ms overall, the load should no longer get into the red area. I always use a sample rate of 48,000 Hz and a buffer size of 512, which usually results in between 10 ms and 13 ms overall, depending on the audio device connected.

Back To Top