Error installing Massive X

tobias Member Posts: 2 Newcomer
edited June 2022 in Massive X & Synths

I recently updated my NI Products and now I can't start Massive X anymore. It seems, that it isn't installed but Native Access shows that it is. I tried to reinstall Massive X without any effect. It's also confusing, that the installed version is 0.0.0 and there is now installed path.



  • Uwe303
    Uwe303 Moderator Posts: 3,046 mod


    C: > Programme > Common Files > Native Instruments > Service Center in this folder should be some XML files, delete the one with massive x in the name and restart native access.


  • tobias
    tobias Member Posts: 2 Newcomer


    thanks for the answer.

    I also checked this folder, but there are not any massive x files. Only some from the massive x factory library, which have been also removed. I've forgot to mention, that I setup another installation path.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 9,670 mod

    Hey @tobias You can follow this article: Fixing Software Update Installation Issues (Windows)

    If you still have the same issue, you might want to have more standard installation paths, you can follow this article: How to Change the Install Locations in Native Access

  • Supernova
    Supernova Member Posts: 1 Newcomer

    I`m having the same issue, all was well now Massive X will not launch in standalone or in Ableton.

    None of the suggested fixes work- I assume this is a known issue with the update and a fix is in the works ?

  • Bo Rumba
    Bo Rumba Member Posts: 2 Member

    I've got an issue trying to update MX to the latest patch via Native Access - when I click update it just says 'Downloading Massive X failed: Uknown error'

    I followed the steps in the links posted above and now NA says that MX is uninstalled but still wouldn't download it, weird thing is that I can still use MX in Ableton Live 11.

    Updates for all other products work just fine, it's only MX's that doesn't.

    I'm on Win10 btw.

    QUALTHEBEAN Member Posts: 7 Member
    edited May 2022

    This happened to me as well. Furthermore, I checked everywhere, and it is just not on my computer at all. This happened with Kontakt a while back for me and I had to go to them and they gave me a file where I could download it directly. Hopefully I don't have to do that for this, though I suspect I may have to do so. Good luck to you all.


    Boys (and girls). I think I fixed it.

    So I noticed that when it installed and failed (after working through it for like 8 years I closed the massive x installer in the task manager) that it actually put a file every time in my downloads that was the installer.

    So I just manually installed it, and I think I found the issue (maybe).

    Cakewalk has been a jerk ever since I quit using it, making itself the default place to store vsts. It had that folder selected; I corrected it and put it in the right spot.


    Here's what you do (hopefully it works for you):

    -Download it in NA

    -Once it is downloaded and while it installs, end the installation in the task manager

    -Extract the downloaded installer and run it putting the vst in the right spot (under the NI vst plugins folder thing)

    -Pray it works

    NOTE: I don't know if this method is correct or proper, but in case it's not, let me say this--I bought Massive X. Do not give out the .exe if this method works for you; I hope for NI's sake they have a way of blocking illegal pirates; otherwise I will GLADLY take this post down. I am not here to promote piracy, but rather the exact opposite. Piracy is WRONG and it WILL come back to bite you someday. Even if you don't have the money for something now, just wait and it will be worth it. Furthermore, do not help someone else pirate something. It is illegal and morally bankrupt; in other words, DON'T PIRATE. Pay your way.

    Hopefully this helps.

  • Uwe303
    Uwe303 Moderator Posts: 3,046 mod

    Have you all tried the reg clean tool?


  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 9,670 mod

    @Bo Rumba When you get this error message, you should check this article: Native Access Error Message: Download Failed: "Unknown error" If that doesn't work, you can get in touch with our Native Access specialists here:

  • Bo Rumba
    Bo Rumba Member Posts: 2 Member

    @Jeremy_NI Thanks, that fixed it - had 'MassiveX.aria' file in the download folder, after deleting it the update worked! Great update btw - shame there are no new 1.4 presets to show off the new Bass Enhancer and new filter.

  • Custom Blue
    Custom Blue Member Posts: 33 Member

    Update failed so I uninstalled Massive X. End result Massive X now fails to install. OK now trying all the above.

  • Chris Cowan
    Chris Cowan Member Posts: 7 Member

    I'm having the problem. I'm running Win 11 now. Cakewalk, Studio One and Reaper on the box.

    Native Access still pointed at the default locations.

    • Tried the Reg Uninstall Tool. Still fails
    • Tried running Native Access as Admin. Getting a severe threat warning. Install does not fail, but does not complete, and stalls.
  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 9,670 mod

    @Chris Cowan It's not really the problem of the OP. I assume you get a message from Windows Defender, then it's this issue, we're aware of it and the Native Access team is trying to find a solution: Known issue: Windows Defender flagging products as Trojans

  • engels1920
    engels1920 Member Posts: 14 Member

    Hi, has this issue been resolved yet (Error installing Massive X)? The documentation file is being downloaded. However, the actual .app file is not being installed.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 9,670 mod

    @engels1920 There is no standalone application for Massive X, you should find it as a plug-in in your DAW or in Komplete Kontrol.

  • Fabbra
    Fabbra Member Posts: 2 Newcomer

    My problem with massive x is a path too long for the wavetables in windows 10. I already allow long path in regedit anf gpedit but nothing works.

    I contact the support but i´ve got no solution for the moment.

Back To Top