Komplete Kontrol 'Advanced Integration' Not Working

NI.User
NI.User Member Posts: 19 Newcomer

The transport controls only work when they feel like it in Cubase and Ableton. It will work today in one project but it won't work in another tomorrow without explanation.

Everything seems set up correctly using the 'Komplete Kontrol Daw - 1' driver but it's hit and miss if it wants to work.

The KK seems to receive information from the DAW, when the metronome is activated/deactivated in Cubase it is reflected on the KK surface, but Cubase will not receive any transport controls from the KK.

It's very frustrating. Has anybody else has this problem?

Thanks.

Answers

  • Kymeia
    Kymeia Member Posts: 3,452 Expert

    Don't have Cubase, in Live I don't get this though. What's your system?

  • Matthew_NI
    Matthew_NI Product Team Posts: 678 mod

    Which version of the keyboard are we referring to?

  • NI.User
    NI.User Member Posts: 19 Newcomer

    Hi Matthew, thanks for the reply. It's a Komplete Kontrol S49 MKII

  • Kymeia
    Kymeia Member Posts: 3,452 Expert

    Ok thanks sorry not sure what to suggest, I am on Mac so don't have relevant recent experience with this on Windows

  • mykejb
    mykejb Moderator Posts: 800 mod

    @NI.User What version of Cubase and Komplete Kontrol are you using?

    -- Mike

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @NI.User Do you have an antivirus active? Have you tried deactivating it?

    Are you using any kind of property cleaning software? Notes on Using Registry or Property List Cleaning Utilities

    Make sure to run Ableton, Cubase and Komplete Kontrol as admin: How to Run a Program as an Administrator

    Can you check the following:

    The NIHardwareAgent or NIHostIntegrationAgent services are not running in the background

    Make sure that the services NIHardwareAgent and NIHostIntegrationAgent are running on your computer. Follow these steps: 

    1. Click on the Start button, type Task Manager, and press the Enter key on your keyboard to open the Windows Task Manager. Choose the Services tab.
    2. Note: If the Services tab is not directly available, expand the view by clicking 'More details' in the lower-left corner of the window.
    3. Search the list and check if the Status of the services NIHostIntegrationAgent and NIHardwareService is set to Running:

    If not, right-click the respective entry and choose Start from the context menu:

    Restart you computer

  • NI.User
    NI.User Member Posts: 19 Newcomer

    Hello Jeremy,

    Thank you for your message.

    I tried disabling the anti-virus (Windows built in) and transport still didn’t work.

    I have a free utility programme called “Glary Utilities” but I don’t use it for cleaning the registry or any ‘automatic cleaning’

    I’ve made sure Cubase, Ableton and Komplete Kontrol are run as administrator. Transport still didn’t work.

    I later noticed that in Ableton Options>Preferences>Link Tempo MIDI>MIDI Ports The ‘In’ “KOMPLETE_KONTROL_S_MKII INPUT (“ driver was in red which apparently means the driver is being used by something else, but what else I do not know, only Ableton was open.

    I reset the computer at this point then transport was working in Cubase, and Ableton. I tried transport in Cubase again later it was working then it stopped in the same session. I noticed that the KK was still receiving messages from Cubase, but the transport was not working.

    I also noticed that when I pressed a note on the KK it plays within Cubase then after the note is released in the Cubase “MIDI Out Activity” meter 20 or 21 ‘flashes’ of information was being transferred over the space of about 3 or 4 seconds, I’m not sure why. I then opened Ableton and transport was working fine.

    I then noticed that NIHostIntegrationAgent was not running, I started it but transport still didn’t work in Cubase. Though in a later Cubase session enabling NIHostIntegrationAgent did restore functionality. Is there a reason why it just stops running?

    After further resets the transport was working for the rest of the day.

    I’ve woke up this morning and it’s stopped working again, with NIHostIntegrationAgent running.

    This is my experience all the time, it works, then it just doesn’t. 

  • NI.User
    NI.User Member Posts: 19 Newcomer
  • NI.User
    NI.User Member Posts: 19 Newcomer

    Is NIHardwareAgent and NIHardwareService the same thing? I have NIHostIntegrationAgent and NIHardwareService in services but no NIHardwareAgent

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @NI.User I've contacted you by email regarding this issue, we'll need to have a deeper look.

  • NI.User
    NI.User Member Posts: 19 Newcomer

    As an update the transport started working again today, then later stopped again. I noticed that the “Metro” button on the KK wasn’t lit up as usual and wasn’t receiving commands from Cubase, so I restarted the NIHostIntegrationAgent and NIHardwareService services again (which were already running) and this corrected that, but still no working transport. 

  • Matthew_NI
    Matthew_NI Product Team Posts: 678 mod

    Try this:

    To fix the Komplete Kontrol “Autofocus” problem in Cubase, proceed as follows:

    Open the VSTI Komplete Kontrol plug-in window, right-click at the top of this window and select “Remote Control Editor”.

    Then in this window, click on the small arrow at the top right to select “Use the default configuration” and “Apply” on the button next to it.

    At this time, “Autofocus” works. Then save the project.

    The cause of this problem is when the Komplete Kontrol reference named “NIKBxx” is no longer assigned to the first “Knob” on page 1 in the “Remote Control Editor”.


    I wonder if this is contributing.

  • NI.User
    NI.User Member Posts: 19 Newcomer

    Hi Matthew,

    Thanks for that. I've already seen this 'fix' on the Cubase website. This does fix the 'autofocus' problem in Cubase, but the KK has to be working in the first place - it doesn't get the transport working or the 'advanced integration'.

Back To Top