How to solve the Traktor s4 driver installation on Macos mountery?

danial90
danial90 Member Posts: 1 Newcomer

I downloaded already the driver, but then the installation is Failed/Error. Has anyone got this problem too? if yes how to fix it :)


Answers

  • lord-carlos
    lord-carlos Member Posts: 2,009 Expert

    It's the mk1?

    https://support.native-instruments.com/hc/en-us/articles/360014900358-Compatibility-of-Native-Instruments-Products-on-macOS

    macOS 10.15 terminated the operability of some NI legacy hardware. The same applies to macOS 11 (Big Sur) and macOS 12 (Monterey). This includes MASCHINE MK1, MASCHINE MIKRO MK1, TRAKTOR AUDIO 2 / 4 / 8 DJ, TRAKTOR AUDIO 2 MK1 and TRAKTOR S2 / S4 / X1 MK1.

    You would need to downgrade your Mac or switch to windows.

  • dedit
    dedit Member Posts: 9 Member

    I too have an old S4. I cannot believe that NI can basically render peoples gear massive paper weights, that they paid a ton of money for obsolete. They basically want you to buy new gear. The S4 is hardly different from the new ones. Shame on you NI! Can't be that hard to provide drivers for newer OS's. Garbage!!

  • zephry
    zephry Member Posts: 545 Pro

    That controller came out 13 years ago. It is very old now.

    Mac added updates that don't work. I agree this seems. Like a simple fix. But an update to Windows anytime could probably make the MK1 and other devices only a midi device as well. Since they are no longer updated or supported.

    I think the key word is support.

    You won't get any more help or firmware fixes or if the software changes or anything with those older devices. For either platform. But for now Window still works.

Back To Top