KK keyboard/maschine plus, strange issue?

dcoty
dcoty Member Posts: 14 Member
edited November 2023 in Komplete Kontrol

So i got a new MK2 KK keyboard ( s47) to replace the borked mk3. I plugged it into the maschine plus and things are working well, but i have an issue.

So, when i load up groups/instruments/sounds, etc on the maschine plus, i can use the keyboard pads just fine, and when i use them the hardware keyboard lights up the corresponding notes. That is expected i think.


BUUUUUT, when i try to play the notes on the hardware keyboard, the machine plus doesn't show to the corresponding notes on the keyboard pads and of course, no sounds come out.

i know there's a key mode, but that looks to only play what's in the "pads" section of the maschine plus. I was hoping there was just a way to play the hardware keyboard and play the keyboard pads.

I'm plugged into the Maschine plus with the USB cable that came with the keyboard. All the hardware firmware is updated. I'm not using a midi cable ( it's my understanding i don't have to use one) and i have midi input set to the USB port.


i could be using it wrong, but are there any other settings i need to check to make the keyboard work in this manner? Is this intended behavior?

Thanks for the help.

Best Answer

  • dcoty
    dcoty Member Posts: 14 Member
    Answer ✓

    okay, i think i fixed the issue. 2 things:

    • i had to update the M+ firmware to 0.9
    • in the M+, under settings, midi, midi default, set to Focus.

    this fixes the issue i was having. just in case anyone else runs into the same issue.

Answers

  • dcoty
    dcoty Member Posts: 14 Member
    Answer ✓

    okay, i think i fixed the issue. 2 things:

    • i had to update the M+ firmware to 0.9
    • in the M+, under settings, midi, midi default, set to Focus.

    this fixes the issue i was having. just in case anyone else runs into the same issue.

  • nightjar
    nightjar Member Posts: 1,238 Guru

    Keyboard Pads?

    Not sure what you mean by this.

  • dcoty
    dcoty Member Posts: 14 Member

    Sorry, when you press the keyboard button and play the pads like a keyboard. Sorry, I don’t know what it’s officially called. But either way, I fixed the issue, it just appeared to be a midi setting in the M+

Back To Top