S49 record button doesn't light up

Dogus
Dogus TurkeyMember Posts: 4 Sine
edited March 24 in Komplete Kontrol

hello, I checked if it was asked before but I couldn't see it, I have a mk2 s49, all keys and buttons work but only the record button does not light up. It shows up in red in the videos I watch. I wonder if it's because I'm not using the power supply. thanks.


Tagged:

Best Answer

  • JesterMgee
    JesterMgee Custom NKS Libraries: freelancesoundlabs.com/nksMember Posts: 401 Saw
    Answer ✓

    Even outside a DAW (with no software running at all) the REC button should have a backlight, even without a P/S attached it should be visible still, just faint and when you press the button it should light up while pressed.

    If you don't see this when Logic is not running (just connected to the system sitting in midi mode) then i'd probably say the LED is faulty.

Answers

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 706 mod

    Hey @Dogus Welcome to our forum. What DAW are you using ? To what videos do you refer to ?

  • Dogus
    Dogus TurkeyMember Posts: 4 Sine

    Thanks for the reply back, I'm using logic pro x 10.4. this is the video too and the power supply is not even plugged in, guess i have a problem :)


    https://www.youtube.com/watch?v=-ECBgxAowig

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 706 mod

    Ok, So, Logic 10.4, what is your operating system then ? Do you have any other issues in Logic ? any issues in Komplete Kontrol in standalone ?

  • Dogus
    Dogus TurkeyMember Posts: 4 Sine

    macos Mojave, no, there is no problem in logic or KK in standalone. everything works fine, just the record button does not light up and i don't understand why.

  • JesterMgee
    JesterMgee Custom NKS Libraries: freelancesoundlabs.com/nksMember Posts: 401 Saw
    Answer ✓

    Even outside a DAW (with no software running at all) the REC button should have a backlight, even without a P/S attached it should be visible still, just faint and when you press the button it should light up while pressed.

    If you don't see this when Logic is not running (just connected to the system sitting in midi mode) then i'd probably say the LED is faulty.

  • Dogus
    Dogus TurkeyMember Posts: 4 Sine

    Thank you so much JesterMgee. 😊

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 706 mod

    Hey @Dogus yes, @JesterMgee is right, that looks like a hardware default, if you got your keyboard from us, please get in touch with my colleagues here: https://bit.ly/NISupport_Hardware

Back To Top