Native Access Download Failed

Fred Aa
Fred Aa Member Posts: 5 Newcomer

Cant download any of my library items. Native Access 2, Windows 10.

I have done extensive trial and error with suggested solutions on this site:

NTKDeamon v.1.14 installed as administrator. Proxy, firewall, antivirus is off. Given NTK full access in security options.

Any help please?


  • reffahcs
    reffahcs Member Posts: 220 Advisor

    I'm on a Mac, but use Windows as well. Under the settings File Management screen, what are the locations for Download and Content?

  • reffahcs
    reffahcs Member Posts: 220 Advisor

    And you're logged in as whoever user xxx is?

  • Fred Aa
    Fred Aa Member Posts: 5 Newcomer
    edited November 12
  • reffahcs
    reffahcs Member Posts: 220 Advisor

    Well I'm not sure what all you tried, but assuming you have plenty of disk space available, you might try this if you haven't already?

    Otherwise I'd say you'll probably just have to end up opening a support ticket with NI.

    I can understand your reluctance though. I had an issue with KK crashing as soon as at was opened a few months back. I submitted a trouble ticket with every detail of my Mac setup, and spent a fair amount of time collecting the info too. When I finally got a response, the solution was for Windows 😪 :facepalm:

  • Fred Aa
    Fred Aa Member Posts: 5 Newcomer

    @reffahcs Thanks for your support on the issue. Unfortunately I have tried it all with no success.

  • PoorFellow
    PoorFellow Member Posts: 1,123 Guru
    edited November 13

    Run Native Access as an administrator if you have problems...

    Make sure that Windows has not any third party app install limitation protection turned on ! In Native Access try setting the paths for Download Location and Content Location to two new directories from drive root , and also make sure that there are plenty of space on the drives , Also make sure that you do not have too little drive space on system drive C: .

    Download Location : MyDrive:\My NEW Directory\If you like My NEW directory 2\

    Content Location : MyDrive:\MY NEW Native instruments Directory\

    Then also make sure when that is set that when you click the three little dots for the application in Native Access that it then says : installation paths , e.g. : C:\Program Files\Native Instruments\Battery 4 and C:\Program Files\Native Instruments\VSTPlugins 64 bit

    If you have the required privileges on the computer then that ought to work. If it does not then I think that it suggests that the Native Access app and the NTK Daemon has still not been installed correctly. Mind you , in the past when people have had problems with the NTKDaemon and Native Access then the problem often was that N.I. didn't clean sufficiently after the old installation prior to installing a new version.

    So if problems persist then I would suggest that you take a full system backup and make a manually made Windows restore point and then uninstall and delete everything Native Access and NTKDaemon from both drive and registry. A tool that might help do that is the N.I. registry tool from the page : Fixing Software Update Installation Issues (Windows) : , some people have reported good results using that , but sometimes in the past it has not been enough so be sure that any trace of the previous installation has been removed from both drive locations and registry. (in particular make sure that no trace of neither Native Access nor the NTKDaemon are running neither as process nor as service after a reboot after the uninstall)

    Then reinstall the Native Access as an admin and try again (separate installation of the NTKDaemon ought not be necessary) . Problem ought not persist but if it does then you ought to get support to assist you ! : Install support : :

Back To Top