Logic 10.8 and note doubling with Kontrol S61 Mk3

Options
Danthesiser
Danthesiser Member Posts: 22 Member
edited November 2023 in Komplete Kontrol

Hi there!

So, I upgraded to Logic Pro 10.8 and found that all the MIDI notes I recorded through my Kontrol S61 mk3 were duplicated in the regions. This seems to be happening with Komplete Kontrol plugin only.

The transport bar on my setup shows MIDI in and out as well and it seems that the MIDI notes from the regions are coming back IN to the DAW as though it were played again during playback.

Also, the keyboard interface with the DAW is a bit janky now; switching between tracks seems to get stuck and only show the light guide and played notes show for one track and won't focus on another when switching between them.

I had a fiddle with the MIDI inputs and outputs, but to no avail. Having gone back to Logic 10.7.9, the issues aren't there any more, so I would recommend holding back for now, until they can sort it out.

I hope this helps and if anyone has any advice, that would be great, too!

[EDIT: Looks as though this is ONLY happening with NI keyboards... So something's awry this end.]

Comments

  • Kymeia
    Kymeia NKS User Library Mod Posts: 4,064 mod
    edited November 2023
    Options

    I upgraded yesterday evening, and just checked a test project I made in Logic 10.7.9 and KK3 with my Mk II keyboard and couldn't see any note doubling.

    However then I hastily recorded a new project and yes there is for the series II as well with new recordings, Logic is recording both notes on top of each other, so I didn't see it at first till I tried dragging one note to a different position then realised it was leaving one behind. For comparison I also recorded a sequence with the same instrument but just in Kontakt 7 and no note doubling. So this is a KK3 issue, not the keyboard itself. How annoying!

  • Kymeia
    Kymeia NKS User Library Mod Posts: 4,064 mod
    edited November 2023
    Options

    I just edited this - I can confirm with new projects, wasn't seeing it at first because the notes appear right on top of each other but when I tried to move one in the piano roll it left one behind. I have sent in a bug report

  • Kymeia
    Kymeia NKS User Library Mod Posts: 4,064 mod
    edited November 2023
    Options

    There may also be a bug on Logic's side too though. When I tried to uncheck one of the Komplete Kontrol midi inputs to see if that was a cause, instead Logic created 2 of them. I tried this again with the Logic virtual input and it created 2 of those too! I'm not sure if that means the 2 issues are necessarily connected, it's a possibility but I would have thought that if MIDI is being doubled at the input stage it would affect all plugins, not just KK3, but so far that doesn't appear to be the case. Nor does unchecking all inputs apart from one resolve the note doubling issue with KK3. However it is to much of a coincidence to rule out the possibility the 2 issues are connected on some level.


  • Danthesiser
    Danthesiser Member Posts: 22 Member
    Options

    I also played around with the inputs and indeed found this to be happening, too, but unsure of its relevance or relation to this bug, I didn't mention it.

    There's me thinking it was a Mk3 thing only, but clearly not.

    I think you're right though; there seems to be some interplay between the keyboards and the Logic 10.8.

    Hey ho, back to 10.7.9 I go!

  • Kymeia
    Kymeia NKS User Library Mod Posts: 4,064 mod
    edited November 2023
    Options

    Just noticed there is a Sonoma bug fix update out so might try that later to see if it has any effect on anything (probably not but we'll see)

    (I'm hoping it will fix an issue where my network drives get dismounted if I have left the Mac in sleep overnight)

  • Onj
    Onj Member Posts: 54 Member
    Options

    This is not an MK3 bug, as you can play with Musical typing and achieve the same midi doubling. It's baffling and annoying.

    I can confirm that it does indeed only happen on KK tracks though, which is strange. I loaded up the sampler plugin and that behaved just fine. Ridiculous.

  • Kymeia
    Kymeia NKS User Library Mod Posts: 4,064 mod
    Options

    Yes as I said it’s specific to KK - I don’t have a mkIII yet

    anyway NI are aware of it now and it’s been replicated so can work on a fix

  • cdion
    cdion Member Posts: 21 Member
    Options

    Thank you for the problem raised here and the comments and attempted way to fix it. Very helpful. I will wait a bit before updating to 10.8. I have an S61 KK keyboard.

Back To Top