How to solve a track freezing problem Kontrol S2 mk3 / MacBook Air 2020 M1

Rufus
Rufus Member Posts: 3 Sine

Fresh out of the box and there is an issue of tracks stuttering/freezing using Traktor Pro 3 software. It seems like it could be an internal problem in the USB connection to the controller. I have changed cable and the problem is the same. Anyone experienced this on a brand new machine? Thanks.

Comments

  • Matt_NI
    Matt_NI BerlinAdministrator Posts: 760 admin
    edited March 22

    Which version of Traktor Pro 3 are you running exactly? You need to make sure you are using Traktor Pro 3.5.2

    Also just the be extra safe, check the tips in this article: https://support.native-instruments.com/hc/en-us/articles/210296445-Mac-Tuning-Tips-for-Audio-Processing

  • Rufus
    Rufus Member Posts: 3 Sine

    Thanks, Matt - That was useful. Pro 3 is the correct version. I sent the last one back to the shop and have bought a replacement (hoping for a refund for the 1st one!) Exactly the same problem. I have a MacBook Air 2020 M1 (not Pro). According to the literature, this should be fine. Is there just an overall compatibility issue with M1 chip laptops? I'm desperate to play! Help!

  • Matt_NI
    Matt_NI BerlinAdministrator Posts: 760 admin

    Hard to say what could be the cause but it should run. I created a support request for you, one of our specialist will be in touch via email.

  • Rufus
    Rufus Member Posts: 3 Sine
    edited March 26

    OK, the specialist got in touch and gave some help but haven't heard anything for a few days now. This is hugely frustrating. I got hold of a power cable, though it was advertised as plug and play - it would be a really good idea to sell controllers with the appropriate power cable. I thought that this was the reason for the unclear/interrupted signal which was freezing my tracks after a few minutes. So, with the power cable, I have had a good few hours play today after a long time trying to solve the problem. Only for the freezing issue to resurface. Someone, somewhere must have had the same problem? I've addressed all the tips that I was sent in the advice article, I've got a power cable, I've turned off my bluetooth/wi-fi/display sleep/computer sleep. I've adjusted the audio settings appropriately in Pro 3. I would really appreciate some pointers on what else I can do. Thanks.

  • Matt_NI
    Matt_NI BerlinAdministrator Posts: 760 admin

    Looking at the exchange with our support, it seems that adjusting the jog wheel sensitivity of your S2 MK3 did the trick. Linking the article from our KB here in case anyone else is interested:

    Troubleshooting Jog Wheel Issues with the TRAKTOR KONTROL S4 / S2 Controller

  • Chivu George
    Chivu George Member Posts: 4 Sine

    Duplicate the frozen deck in deck C or D. Lower the volume on the duplicated decks. Traktor will play a duplicated track. It might not start at first, let the duplicate track play. It will start eventually. This is a known bug, but very hard to replicate. I'm on S4MK3.

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 1,119 admin

    Hi @Chivu George the issue reported by the OP has to do with jog wheels so yours might be a different issue here. Feel free to create a new post instead!

This discussion has been closed.
Back To Top