Xone 96 with X1 effects routing issue

Wintermute
Wintermute Member Posts: 8 Sine
Hello,

I have a Xone 96 mixer connected to a Macbook Air M1 with two Traktor X1 mk2s and Traktor 3.

My question is about routing the effects to the Return A channel of the mixer.

I managed to get the send/return loop working on through channels. Pre and post fader both work

However, no matter what I do, the original track is always coming through Return A. Whether I have the effect on/off on the original track is coming through. When I have the dry/wet knob at the dry or middle positions, the original track is coming through. When it's set to full wet position, I only hear the effect.
I can't keep the effect turned on and in the full wet position all the time, because I need the effects on/off button for creative usage. But whenever the original track is coming though, there is a bit of latency and it sounds bad.

Is there a routing solution to fix this?

Here are my settings attached:


Tagged:

Best Answer

  • Wyley
    Wyley CanadaMember Posts: 236 Saw
    edited January 14 Answer ✓

    This, believe it or not, is normal behaviour.

    You can try to turning down the send knob for that channel when not using it. That should stop the sound leaking.

    As for latency that’s what is expected in analog mixers when you have the original signal mixed with the signal that had to go back through Traktor and back through the mixer again. The round trip latency is around 50ms I believe for your mixer.

    The mixer I use for send and return through Traktor’s ext effector is digital and the issue was addressed though a firmware update to add latency to the mixer to compensate for the time it takes to go through the fx loop.

    Hope this helps

Answers

  • Wyley
    Wyley CanadaMember Posts: 236 Saw
    edited January 14 Answer ✓

    This, believe it or not, is normal behaviour.

    You can try to turning down the send knob for that channel when not using it. That should stop the sound leaking.

    As for latency that’s what is expected in analog mixers when you have the original signal mixed with the signal that had to go back through Traktor and back through the mixer again. The round trip latency is around 50ms I believe for your mixer.

    The mixer I use for send and return through Traktor’s ext effector is digital and the issue was addressed though a firmware update to add latency to the mixer to compensate for the time it takes to go through the fx loop.

    Hope this helps

  • Wintermute
    Wintermute Member Posts: 8 Sine
    edited January 14

    Yes, that all makes sense, thanks for your answer!

    I guess I'll have the dry/wet knob at full wet and use the Return A fader to insert the effects.

  • Wyley
    Wyley CanadaMember Posts: 236 Saw
    edited January 14

    I too have to leave the dry/wet knob at full before I hit the button because two signals running at the same time bumps up the volume a bit.

    If you play a track and instant double it you’ll know what I mean.

  • Wintermute
    Wintermute Member Posts: 8 Sine

    Yeah, I noticed the same and was worried about that too.

    I played around with using it in the max wet setting and inserting with the Return A fader. The latency is a non-issue, because there are no parallel highs that highlight it.

    However, I can't turn the effect off to let the effect naturally fade out, because it drops the original signal right back onto itself. It is literally unusable this way. I'd like to turn off the effect and control the length of the effect with the feedback knob.

    Unless there is a workaround of fix, it's back to good old insert. Womp.

  • Wintermute
    Wintermute Member Posts: 8 Sine

    Ok, I got it. To have the effect tail out, I used to turn the effect off in 'insert' mode. Now I have to cut send to achieve the same thing.

    Thank you for your answers!

Back To Top