Is this "normal" behavior for a S61 Mk2? powering on/off requires KK app, goes offline if idle.

Options
randyrandy
randyrandy Member Posts: 11 Member

Hi, I posted this once today, saw it, tried to edit the question, then read it needed to get approved. It's disappeared. Trying again

My System: HP Z4 G4, Windows 11

I just picked up an NI refurbished S61 Mk2. I really love it but it has some quirks that concern me. Specifically, is my refurbished S61 behaving normally or perhaps it wasn't "refurbished" completely and is defective.

My scenario is: a project using Nuendo 12, Kontakt and Opus Orchestra instances.

I have gone through the online troubleshooting steps and swapped usb cable for one I know is stable and works flawlessly with my Roland TR8s.

My understanding is I need to run Komplete Kontrol (KK) once after starting machine to communicate with S61. Then I can use S61 with Nuendo.


1) If I boot machine with S61 plugged in to workstation with usb cable and turned on, I run KK to connect with S61, stop it, then run Nuendo. Nuendo sees it (I have set it up according to instructions) and it seems to be working correctly. However, if I turn the S61 off then on again, Nuendo does see it even after restarting it. I have to start KK again to connect with the S61, then start Nuendo and it usually sees it. However, occasionally it doesn't and I have to reboot.

2) If I leave Nuendo running with project opened and S61 connected for over an hour or so (maybe less), the S61 becomes unresponsive. It seems to go offline. I have to exit Nuendo, run KK, then start up Nuendo, similar scenario to 1).

This makes using the S61 somewhat of a pita.

My Question:

Is this behavior considered normal, or does it indicate the S61 is unstable and still with some defect that wasn't fixed when it was refurbished?

I really enjoy the S61 and I guess I can live with the quirks as long as I am confidently it is operating "normally".

Thanks

Randy

Answers

  • LostInFoundation
    LostInFoundation Member Posts: 4,320 Expert
    Options

    Doesn’t seem “normal” to me.

    And you should not have to open KK in order for Nuendo to see the kb

  • randyrandy
    randyrandy Member Posts: 11 Member
    Options

    Thank you for your reply. I'm worried....

  • JesterMgee
    JesterMgee Member Posts: 2,758 Expert
    Options

    Sounds like a possible service driver issue.

    Just to clarify:

    If you plug in the keyboard and switch it on (no software running at all) does it display anything on the screen of the keyboard (such as a welcome message or MIDI icon)?

    If you are opening either KK or Maschine (standalone) does then keyboard appear to function fine with these programs?

    When you open Nuendo without opening KK software first, if the keyboard does not appear to be connecting, open Task Manager and check for the NI services. Do you see the NIHardware service running?

    My guess is you have some kind of permission issue on your system that is preventing the service from running or closing it. Also, check you are using the actual original cable for the keyboard (should have an NI logo on one end)

  • PoorFellow
    PoorFellow Moderator Posts: 3,796 mod
    Options

    To me it sounds as it could be a USB problem or a driver problem, unit or PC related. Possibly with a power management problem on top..

    When looking up the HP Z4 G4 it says "Intel Xeon", and mention more places that it is a workstation built for data science.

    I have no idea or experience with how such type of PC hardware behave or how compatible it is with Windows 11 and NI basic hardware interface drivers and I am not even saying that there necessarily is a problem that way. But what remains is that in the case of problems such as here then procedure is to try another USB port and if that doesn't help then try the USB port on another computer.

    To me the possibility of a Midi related problem is remote but still present, In any case then I found this tool for debugging you could try if that is your wish ! : MidiView is a simple MIDI Monitor app to that shows bi-directional MIDI packages : https://hautetechnique.com/midi/midiview/

    Here my immediate 'guess' is a USB problem of some kind !

  • randyrandy
    randyrandy Member Posts: 11 Member
    Options

    Thanks to JeterMgee and PoorFellow for replying.

    @JeterMgee

    >>My guess is you have some kind of permission issue on your system that is preventing the service from >>running or closing it. Also, check you are using the actual original cable for the keyboard (should have an >>NI logo on one end)

    You got me thinking about my usb cable. I checked the NI cable requirements page. Unclear whether it satisfies the specs, but certainly is longer than recommended (3 meters). I have a recommended power adapter, so I plugged it in. I'd say it generally worked better and allowed me to turnoff/on S61 without having to run KK or reboot, working more often correctly.

    It still has the transient errors of starting it and the window Just showing the initial display of KOMPLETE KONTROL in left window and Smart Keyboard Controller in right window, without it transitioning to showing the "post initialized" window with midi controller info.

    It also will become unresponsive if I let the Nuendo project stay open without doing anything, for 10 minutes or so.

    I will plug in the usb cable that came with it and has NI stamped on it and try to repro. That cable is 4.5 ft and too short for practical work (really, NI, cutting a few euros off price point instead of providing a 6 foot cable?) but I can try to repro with it.

    With adapter plugged in, and even with a non-compliant cable (that is rock solid with my roland TR8s including using it as asio device and recording channels. good work on the drive, roland) I shouldn't be having this quirky behavior.


    @PoorFellow

    >>When looking up the HP Z4 G4 it says "Intel Xeon", and mention more places that it is a workstation built for >>data science.

    It has the specs of an Avid certified workstation, specifically to be a media composer and protools workstation so I'm good in this area. The machine is robust and solid.

    General criticism of NI. It's too delicate, but a great product when working correctly.

    Still troubleshooting.

  • randyrandy
    randyrandy Member Posts: 11 Member
    Options

    @PoorFellow. Regarding a midi issue. I can still use the keyboard to play notes and they show up in Nuendo when nothing else is working, so I'd say this is not a midi problem but I could be wrong.

    I enjoy the Nuendo daw integration and use it even when not using it as a keyboard.

  • randyrandy
    randyrandy Member Posts: 11 Member
    Options

    I just checked application logs in event viewer see some NIHostIntegrationAgent.exe crashes. If I believe the exception code it has to do with not being to access files or settings. I'll pursue this

    Faulting application name: NIHostIntegrationAgent.exe, version: 1.12.0.0, time stamp: 0x62eccc44

    Faulting module name: NIHostIntegrationAgent.exe, version: 1.12.0.0, time stamp: 0x62eccc44

    Exception code: 0xc0000005

    Fault offset: 0x00000000000cb90c

    Faulting process id: 0x0x15A0

    Faulting application start time: 0x0x1D9F592A6E369F6

    Faulting application path: C:\Program Files\Common Files\Native Instruments\Hardware\NIHostIntegrationAgent.exe

    Faulting module path: C:\Program Files\Common Files\Native Instruments\Hardware\NIHostIntegrationAgent.exe

    Report Id: 4b0b0c6d-0531-4fee-8fad-69b30c480486

    Faulting package full name: 

    Faulting package-relative application ID: 

  • randyrandy
    randyrandy Member Posts: 11 Member
    Options

    reinstalled KK, mk2 driver, restarted, using NI usb cable.

    Still have same problems.

  • PoorFellow
    PoorFellow Moderator Posts: 3,796 mod
    edited October 2023
    Options

    .....procedure is to try another USB port and if that doesn't help then try the USB port on another computer.....

  • randyrandy
    randyrandy Member Posts: 11 Member
    Options

    Thanks for the ideas. Much appreciated.

    I tried different usb port. I'm at the point of letting tech support deal with this as it's consuming too much of my time. I'm not a hobbyist.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,717 mod
    Options

    @randyrandy It looks like the NIHostIntegrationAgent.exe crashes, that's the source of the issue. Please check point 2 and 5 of this article: My KOMPLETE KONTROL Keyboard Does Not Start

    Are you using an antivirus? If so, try to whiltelist Komplete Kontrol, as well as the NIHardwareAgent and NIHostIntegrationAgent, or you could try to disable it as a test.

    So you use any kind of registry cleaners, they can interfere and break things: Notes on Using Registry or Property List Cleaning Utilities

    If none of the above helped, get in touch with our support here: http://bit.ly/NIsupport_KKontrol

  • randyrandy
    randyrandy Member Posts: 11 Member
    Options

    Hi Jeremy. Thanks for the reply.

    >>Please check point 2 and 5 of this article:

    The KK shortcut wasn't being run as admin. I enabled it. Don't use that feature but followed troubleshooting guide.

    All services running.

    >>Are you using an antivirus? If so, try to whiltelist Komplete Kontrol, as well as the NIHardwareAgent and >>NIHostIntegrationAgent, or you could try to disable it as a test.

    I only use Windows security, have no software restriction policies, and don't want to add one just to whitelist the NI services. Everything else on my system works (services, drivers, etc. from other vendors) and not keen on introducing possible side effects.

    >>So you use any kind of registry cleaners, they can interfere and break things:

    none.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,717 mod
    Options

    @randyrandy I see that you are already in contact with our support, that would have been the next step.

  • randyrandy
    randyrandy Member Posts: 11 Member
    Options

    Hi Jeremy. I did reach out while this thread progressed. Took a few days to get response. No resolution yet. For future generations of KK users, I'll update solution once I get it.

Back To Top