S61mk2 keyboard is recognized, but keys not sending MIDI

jg::
jg:: Member Posts: 5 Member

Hi people. My S61mk2 is not functioning correctly with my new Win11 system, after having worked perfectly for many years with my old Win7 system.

I boot Komplete Kontrol stand-alone, which recognizes the keyboard. Under Controller it correctly says KK S61 mk2. In Preferences>MIDI, the KK DAW-1 boxes are ticked for Input and Output, along with my other MIDI devices.

I load up a sound from the software, and it appears on the display of the S61. But playing the keyboard produces no sound. I play my other keyboard, and I'm hearing sound, AND, the blue LEDs light up on the S61 ! And also, the knobs on the S61 are changing the sound as expected. But the keys and wheels of the S61 aren't sending anything.

This is repeated when I boot up Cubase. I can use Play/Stop to control Cubase, and the rotary dial to move tracks up/down, mute/solo tracks with those buttons, etc, but there is no MIDI input from the keys.

I've tried reinstalling the KK MIDI driver several times. I tried downloading the Firmware Updater, but it doesn't recognize that the keyboard is connected.

I'm using the same USB cable that I used on my old system for several years. I read that sometimes a USB2 port works better than USB3, so I changed to that, and the behaviour is exactly the same.

Many thanks for any ideas to try from here....

Best Answer

  • jg::
    jg:: Member Posts: 5 Member
    Answer ✓

    Thanks @JesterMgee

    It's fixed! I downloaded the driver for the fourth time and reinstalled, but this time, I first deleted the previous install from my system. It seems this was the crucial step to "reset" everything, and checking Device Manager also made this easy. So all appears to be working as normal now.

    Thanks to my "helpers". :-)

Answers

  • LostInFoundation
    LostInFoundation Member Posts: 3,998 Expert
    edited September 2023

    Are also Komplete Kontrol - 1 boxes ticked in Preferences - MIDI?

  • jg::
    jg:: Member Posts: 5 Member

    No, that option is not there. Only Komplete Kontrol DAW - 1.

    @LostInFoundation

    John.

  • jg::
    jg:: Member Posts: 5 Member

    Thanks, @LostInFoundation. However, I've reinstalled the drivers multiple times over several days.

  • jg::
    jg:: Member Posts: 5 Member

    On the support page titled: "I Hear No Sound When Playing the Keys of my KOMPLETE KONTROL S-Series Keyboard"

    ... at the bottom, it says: "To make sure that the keyboard driver is correctly installed, follow the instructions in chapter 2 and 3 in this article." But the link to the article is broken.

    Does someone know the correct link, or the info there?

  • JesterMgee
    JesterMgee Member Posts: 2,462 Expert

    If you check in Device Manager does it show the USB device for the keyboard, is there anything that is showing as an issue? You should be able to see at least the keyboard is connected in the USB device list even if the drivers are not working. That will at least suggest the USB side is fine.

    Also, are/have you tested using just the KK standalone software when not in a DAW?

  • jg::
    jg:: Member Posts: 5 Member
    Answer ✓

    Thanks @JesterMgee

    It's fixed! I downloaded the driver for the fourth time and reinstalled, but this time, I first deleted the previous install from my system. It seems this was the crucial step to "reset" everything, and checking Device Manager also made this easy. So all appears to be working as normal now.

    Thanks to my "helpers". :-)

  • JesterMgee
    JesterMgee Member Posts: 2,462 Expert

    Good to hear.

Back To Top