Komplete Kontrol M32 issue

Options
djadidai
djadidai Member Posts: 399 Pro

Hello dear community!

I have a problem with my M32 keyboard. It’s like it has a ghost living inside of it. It makes super small volume changes back and forth, very quick and small changes of 0,2dB constantly. I can’t see why. This happens both in Logic Pro and Live, both daws are updated to latest version. Sometimes these glitchy micro movements stop after I have twisted all the macros back and forth for a while. Does anyone know why this is happening? I have a decksaver on the keyboard when it’s not used and I’ve vacuumed it a few times to see if it’s dust that’s bothering it.

MacBook Pro M1, not ventura but the OS before it.

Best Answer

Answers

  • JesterMgee
    JesterMgee Member Posts: 2,757 Expert
    Options

    When you say it makes volume changes, what parameter exactly is causing the issue? Can you visually see any values moving and what are they? Are they things in your DAW or within the Komplete Kontrol plugin?

    Are you using the original supplied USB cable? Is it direct connected or via a HUB/Adapter?

  • djadidai
    djadidai Member Posts: 399 Pro
    Options

    I can visually see changes of channel volume faders moving up and down rapidly, in most cases one macro controls several volume faders, not within komplete/kontakt but on any channel.

    i don’t think I am using the original cable.

    I have an M1, so I have a usb c hub connected to it, and the M32 keyboard connected to a usb2 port.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,705 mod
    edited August 2023
    Options

    Is it also doing that in Komplete Kontrol in standalone? Do you have a pedal connected to the M32? Try to connect the keyboard without any musical software open and check the MIDI output of the device like this: How to Monitor the Input of a MIDI Controller

    Do you see any activity, even when not touching the keyboard?

  • djadidai
    djadidai Member Posts: 399 Pro
    Answer ✓
    Options

    I will follow all these steps this evening and report back!

  • Ponus
    Ponus Member Posts: 1 Newcomer
    Options

    Having the same issue..anyone solved it?

  • djadidai
    djadidai Member Posts: 399 Pro
    Options

    It seems to be working correctly when it is directly plugged in to my main usb hub. I have a usb hub for my M1 MacBook pro since it only has 2 usb c inputs. However I had an old usb hub connected to the hub bcs I needed more usb connections. The problem didn’t remain when I connected it to the main hub.

Back To Top