Traktor crashes while opening

c0nsul Member Posts: 198 Pro

Traktor crashes multiple times before it opens normally.

I´m running into this issue for weeks. Sometimes Traktor opens as intended, but often the starting process crashes multiple time (3-5 times in a row) before opening normally.

This issue happens with my controllers and sound interface connected and also without any gear connected. Also, I experience crashes in the middle of a set, but not that often.

There are no crash logs generated. I only noticed, when Traktor finally managed to start, some of my FX settings are switched..

I already re-newed my settings-file and collection-file. macOS and Traktor are up to date.

Made a video of the problem.



  • Stevan
    Stevan Member Posts: 1,157 Expert

    Maybe check Privacy and Security tab for any notifications abour Traktor restrictions.

  • c0nsul
    c0nsul Member Posts: 198 Pro

    Already checked Privacy and volume permissions.. 🤷‍♂️

    Will make a clean install and check if this behaviour still persists. Will report.

    Traktor 3.9 felt pretty solid on my system until this issue occured. 🫤

  • Quade
    Quade Member Posts: 176 Advisor

    Story behind this

    With this past week, I had planned to reload my work Computer, I had not used any of the software (Both Serato & Traktor) in a while & decided to do some work. Regards to Serato, I cannot tell you why Serato refused consistently not opening at all. Could not figure it out.

    Traktor, on the other hand, dialog box appears with the error message, every single time & I could not understand why.

    Yesterday I decided to reload my work computer, a few tho at activation did not occur but was informed by our senior Support specialist that the KMS server was being attended to.

    I then Managed to reload my machine & configured with the work's recommend software, all updates installed successfully.

    I then decided to install a very early version 3.4.2 I think I have that installs completely. I then ran that version 1st & it worked, I then install the most recent version of Native Access & updated to 3.9 I then tested again & immediately Traktor crashed again. I had then uninstalled Traktor, tested again with the above-mentioned, 3.4 working but 3.9 crashes. I uninstalled again but then went to download the RC version instead from native access & Guess What, to my surprise the RC version works. I cannot tell you what the actual issue is but I can confirm that the recent version of Native Access has a corrupt version of 3.9.worth a try.

    Regards Serato on the other hand, I had downloaded the latest 3.1.10 & successfully installed. Serato had taken me at least 4 tries before it eventually opened up.

    To some it up, both software now works. I cannot provide you with any more details besides what I have mentioned here.

    Keep me posted if this method helps you(exclude reloading your machine) but uninstalling your current version & download the RC version from the beta page.

    Should you have trouble please Private message me & we can talk.

    Happy testing

    Warm Regards

  • c0nsul
    c0nsul Member Posts: 198 Pro

    Hey @Quade , interesting observation. But, I did not install 3.9 by NativeAccess. I kept the 3.9 RC installation from beta testing.

    I think, I found my problem: the settings file.

    As Traktor always crashed while showing "updating settings file" during start up and because of inconsistent loaded FX slots (in cases when Traktor booted up), I assumed my settings file got corrupted. Formerly I tried to renew "Traktor Settings.tsi" by deleting that file while Traktor was running. So by closing Traktor it generates a "fresh" settings file of my current settings. Unfortunately, this didn't work.

    So, I build a complete new settings file by removing the "old" one from its folder while Traktor was closed. By starting Traktor, it generates a blank settings file and the settings wizard showed up. I tried a re-start and Traktor booted like a charm. After the restart, I hit the big import button in preferences to load only the important parts of my old settings file: my mappings, my FX settings and my GUI (both related to my mappings). Worked perfectly and the problem seems to be solved. Within the last hours I re-started Traktor several times and no crashed occurred since then.

Back To Top