Please be advised that due to scheduled infrastructure maintenance, we anticipate downtimes for the Native Instruments websites and Native Access on February 28, 2024 starting at 06:00 CET. For more details, click here.

big black box in the menu of Kontakt

System
System Posts: 28 admin
«1

Comments

  • Pemusic
    Pemusic Member Posts: 17 Member

    Having a similar problem. Load any module and click the upper menu and it yields a long box instead of a menu. From the sidebar I can preview sounds but they don’t load.

    This is happening with every module inside Kontact.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,861 mod

    @Pemusic I created this thread from your comment since it has not much to do with the original thread where the issue was about the Kontakt Factory Library 2.

    What version of Kontakt are you using? What is your operating system? Is this happening in standalone as well? What graphic card are you using?

  • Kymeia
    Kymeia Member Posts: 3,487 Expert
    edited August 2023

    I get that too - the dropdown below it works for snapshots but the one that is meant for switching instruments doesn't - it is supposed to load a dropdown of all instruments but it doesn't anymore and hasn't for a long time, I think that is the same for everyone now - use the arrows instead where there are multiple instruments (In Noire there are only 2 anyway). I suspect it's a holdover in the gui from before snapshots which most instruments use now.

  • Pemusic
    Pemusic Member Posts: 17 Member

    Hello,

    Hi, Jeremy,

    I’m using Kontact 7. Window 11, newest i7, 35 GB RAM, GForce Graphics, Scarlett 18i20, new PC

    Troubleshooting steps so far; I’ve tried uninstalling completely, reinstalling, deleting and rebuilding the DB. No change.

    I’ve also tried changing out my monitor on the off-chance that it had something to do with how the GUI was being displayed.

    In my search for an answer I found others on another forum saying they are experience same menu glitch and not just on Windows; Mac too.

    I don’t know if the problem began when Kontact switched to version 7 or when I upgraded to a Windows 11 machine. (Which I did recently just so I could get Massive x to run.) Another strange menu glitch example; in Playboc, I can click the preset browser and click on preset names to hear the sound sample, but none will load. Only the preset that loaded when the module loaded okays. No other. My gut tells me this has something to do with the menu glitch.

    Thanks

  • Pemusic
    Pemusic Member Posts: 17 Member

    Jeremy,


    I just typed a lengthy response but it didn’t seem to post. I hope this isn’t a duplicate response. If the previous somehow appears; apologies.

    Windows 11, newest i7 processor, GForce 3060, 32 GB ram, new pc, Scarlett 18i20.

    Troubleshooting steps so far; I completely uninstalled everything reinstalled everything, deleted the database rebuild the database. No change.

    The other glitch is a problem choosing presets from the alternative method where I can see all presets and click on each to hear the sample. Clicking lets me hear each sample, but none will load to replace the default preset that loads with the module.

    The problematic modules are the ones that require Kontact7 to run. Ie; Irish Harp, Noire, Playbobox.

    I ran the Standalone version of Kontact 7 with the same results.

    When trying to run these same modules in Komplete Kontrol, the upper module menu, as seen in the image, is missing completely. I have to choose presets from the KK left side menu. Ie, there is no menu option to switch Noire from Felt to Pure.

    Additional note; in my search for an answer, I found people on another NI forum who are experiencing exactly the same thing, but not just in windows 11, they are experiencing it on Mac.

    Thanks for your help.

  • Kymeia
    Kymeia Member Posts: 3,487 Expert

    Additional note; in my search for an answer, I found people on another NI forum who are experiencing exactly the same thing, but not just in windows 11, they are experiencing it on Mac.

    As I said I think it's there for everyone. The dropdown triangle used to allow browsing through instruments but after NI switched to favouring snapshots at some point it stopped working, I did bring it up at the time but nothing happened. It's possible it's non functional now by design and the triangle is just a relic, as more instruments use snapshots?

  • Pemusic
    Pemusic Member Posts: 17 Member

    I can’t imagine it’s by design. Why would they display it? Here’s a button you can click and nothing happens? No… can’t be. Also, it’s impacted the loading of menus. I can’t get my categories to load or the presets to load because of it.

    ie; playbox. Even if I choose a preset from the global list of presets, and after previewing a sample, nothing loads to replace the default preset. Something got bugged up in the last month.

    I really hope they fix this.

  • Kymeia
    Kymeia Member Posts: 3,487 Expert
    edited August 2023

    I think the Playbox issue is another matter - definitely a bug. But that black box has been there for a long time and I know my setup is flawless - also I had it on my previous system. I’m not saying the black box is by design, only the removal of the underlying functionality as a consequence of changing how Kontakt handles snapshots, but the black box itself and remaining gui element that does nothing is probably an oversight so that could certainly be classed as a bug. This is of course just an educated guess - I hope that now it is getting more attention it will get addressed finally.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,861 mod

    @Pemusic I'm really sorry that I didn't realise what the actual issue was. I can confirm that, just like @Kymeia said, this is the normal behaviour. It is a little akward, I agree, but you kind of forget about it to the point I thought it was a different issue. My apologies.

    Regarding the Playbox issue, I think I've seen enother user mentioning that. Could you give a few more details? Is this happening in Kontakt in standalone, in a DAW? Both?

  • Kymeia
    Kymeia Member Posts: 3,487 Expert

    Thanks for confirming that - if that is the case though NI really need to finally remove the gui elements that suggest it does something.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,861 mod

    @Kymeia Actually, I got more info from the Kontakt team. This is actually the quickload menu. If there's nothing in quickload it will be an empty dropdown. The Kontakt team said they could could add an empty menu entry saying "Quick-Load is empty". Not sure when this will happen though.

    @Pemusic Mystery solved!

  • Kymeia
    Kymeia Member Posts: 3,487 Expert

    Cool - something I never use and thought was being deprecated

  • Pemusic
    Pemusic Member Posts: 17 Member

    Jeremy,

    I appreciate your looking into this but it just doesn’t make sense.

    Why would it be logical to remove the functionality of the upper menu?

    Using Noire as an Example- there WERE two menus with corresponding presets; one for FELT and one for PURE. Clicking that drop-down used to allow switching from one to the other and provide the submenu with the corresponding presets. Now, that’s not possible.

    Using Irish Harp as another example- same situation. That drop down used to allow switching between a VARIETY of Harps and then the user could see the sub menu of presets designed for that particular harp. (It was not an empty menu)

    Finally, Playbox- this is the worst of them all. The drop-down would provide a long list of instruments to choose from, but no more. Now, there is is only a merged menu that allow previews of ALL samples, when the names are clicked on, but they cannot be loaded. In addition, the randomizing feature now only changes the graphics of the cubes but not the preset sounds. This all started when the blacked out box “update” was implemented.

    Updates should make things better, not worse. Wouldn’t you agree?

  • Kymeia
    Kymeia Member Posts: 3,487 Expert
    edited August 2023

    Yes I thought it used to do more than quick load (which I never use) but right now it does map to quick load (I tried) so maybe if you add your instruments to that it will work more as you want it to

  • Pemusic
    Pemusic Member Posts: 17 Member

    Is this issue closed or is NI going to take it seriously enough to fix?

Back To Top