Using S88 Mk1 with SO.6.2

KingKonga
KingKonga Member Posts: 35 Member

For the life of me, I can't figure out how to make the Transport buttons, or any other button to drive the SO6 functions. They don't even light up? I have Native Access, and Komplete Kontrol installed, so I don't know what else to do. In the Ext. Devices. Section I have my S88 Mk1 connected to Komplete Kontrol -1 using all 16 ch.s, and all of the options under that are UNCHECKED. Then, I have Komplete Kontrol DAW - 1 connected as well. I'm not saying anything is wrong with SO6, I just can't figure out where to troubleshoot.

BTW, is there ever a point where I will see actual words replace the CC#s for the 8 knobs? What do I need to do to make that happen?

Tagged:

Best Answer

  • KingKonga
    KingKonga Member Posts: 35 Member
    Answer ✓

    Thanks MySO. Actually, I FINALLY got it working. I'm not even sure what I had done wrong, or what I did to correct it. You have to admit there ARE lots of quirky details in all of their setups.

Answers

  • JesterMgee
    JesterMgee Member Posts: 2,482 Expert

    Have you followed the setup instructions here:

    https://support.native-instruments.com/hc/en-us/articles/4406832231441-How-to-Integrate-KOMPLETE-KONTROL-with-Your-DAW

    Can you post a screenshot of the same settings as pictured in the setup?

  • KingKonga
    KingKonga Member Posts: 35 Member

    Thanks Jester. Sorry for the late reply. I've had more tech. difficulties I've been dealing with. Per those instructions I HAVE followed them, albeit they weren't exactly what was presented to me when I tried but here's the scrnshots you asked for.


  • KingKonga
    KingKonga Member Posts: 35 Member

    I'm trying to work with PreSonus as well to see if I can meet somewhere in the middle. I'm sending the integration instructions they sent to me. Thanks to your rule of not allowing me to send links it took me 45 mins to trick my browser.

    Studio One 6: Komplete Kontrol Integration

    Studio One 4.5.3 introduced integration with Native Instruments’ Komplete series of keyboards, which is a big deal. Although these keyboards are theoretically dedicated to NKS-compatible plug-ins and mixer/transport hands-on control, with Windows systems (Mac fans, there’s more on this later) you can use the keyboard as a general-purpose, hands-on MIDI controller for non-NKS plug-ins, including all bundled PreSonus effects and instruments (as well as plug-ins from other manufacturers). Also, unlike standard NKS, you’ll be able to control effects, regardless of whether or not they’re inserted in an instrument track.

    There’s a lot to cover, and since this is more like a tutorial than a tip, it’s split into three parts: DAW control with Studio One, creating custom templates for plug-ins, and how to apply the templates in your workflow.

          • Part i: https://blog.presonus.com/index.php/2020/01/17/komplete-kontrol-integration-studio-one-part-13

        • Part ii: https://blog.presonus.com/index.php/2020/01/24/komplete-kontrol-integration-studio-one-part-23-general-purpose-midi-control

        • Part iii: https://blog.presonus.com/index.php/2020/01/31/komplete-kontrol-integration-part-3-controlling-non-nks-plug-ins/

  • JesterMgee
    JesterMgee Member Posts: 2,482 Expert

    Hey, I don't work for NI so it's not my rule, it's an anti-spammer rule that new users cannot post links on the forum until they have engaged a bit. Issue with that is usually the first engagement is for help and many need to post a link.

    So not being an S1 user I can't really help much further but from the screenshots it appears you have selected things correct, however the screenshot above shows that the keyboard is not being detected since it is loading the MIDI control editor which only shows when no keyboard is detected.

    If you open Komplete Kontrol using the standalone desktop app does it allow you to use it there. You should see a little symbol of your keyboard model when connected:

    IF this shows MIDI instead, then the keyboard is not detected by the system which may be a driver problem. You can try and manually install the drivers again:

    https://www.native-instruments.com/fileadmin/drivers/audiohardware/Komplete_Kontrol_420_PC_p.zip

    Also be sure to try power down/up your keyboard

  • KingKonga
    KingKonga Member Posts: 35 Member

    So, I uninstalled what I had. I unplugged the USB cable, re-installed it, and it STILL doesn't show any lights. However, I'm POSITIVE that I've seen them working before. I just can't remember what the conditions were.

  • nobadmojo
    nobadmojo Member Posts: 100 Helper

    I;m a little late to the party, but I use a s61 mk1 keyboard with Studio One 6.2. Unfortunately Presonus or NI didnt get around to making our keyboards fully integrated. The mk2 version does they say. I really like my mk1. The best you will be able to get is some transport control. You cant globally assign knobs and such to be permanent. You can assign them temporarily or along w. a saved preset. I also have a Novation launchpad X and have the same problem with that device. Also I had to trick things up for even my sustain pedal and expression pedals to work in Studio One by installing another keyboard setup just for those. My setup now has 4 different keyboards setup for the s61 which is absurd.. KK s1, KK external, KK DAW and one I call 'Pedals'. It's unfortunate.

  • JesterMgee
    JesterMgee Member Posts: 2,482 Expert

    There are plenty of users here with S1 who have things working just fine. No idea what mess you have created but does not sound at all logical to me.

  • MyStudioOne
    MyStudioOne Member Posts: 249 Pro

    Since day one of Native Instruments keyboard integration into Studio One (5 if I recall correctly), it has worked as advertised with my MK2 AND my MK1 and I even use them in unison (typically one in NKS instrument mode and the other with midi template. So if you like Studio One, stick with it and get it sorted out.

    One that note, it looks like Komplete Kontrol is not recognizing your Komplete Keyboard properly. The mid learn screen only appears with non NI keyboards. If you open midi preferences in KK, it should look something like this...

    Note: Your keyboard must first be setup correctly in KK before it can work correctly in Studio One.

    Seems like your aren't fully installed or something.

  • KingKonga
    KingKonga Member Posts: 35 Member
    Answer ✓

    Thanks MySO. Actually, I FINALLY got it working. I'm not even sure what I had done wrong, or what I did to correct it. You have to admit there ARE lots of quirky details in all of their setups.

Back To Top