Retro machines does not play midi notes copied into the track

karsai
karsai Member Posts: 47 Member
edited August 2023 in Kontakt

I can record or add notes to retro machine track and these are played back. Any midi notes I copy /paste from other track is not played. If I copy the same midi notes to another instrument (massive or any others) they are played back. I tried several presets of retro machines and it is always the same. No copied midi is played back only recorded or edited in the piano roll. This is obviously wrong. Could you please help? Many thanks!


Best Answer

  • karsai
    karsai Member Posts: 47 Member
    Answer ✓

    Dear Jeremy,

    There is some progress in this problem. First, I had the same issue with Drumlab. no sounds, but there is an option to turn track into the sequencer as a sequence and when I did the sound was there (but of course it transferred only 4 bars so not a real solution).

    So I decided to run this issue also with the cakewalk community. They tried and had the same results as I had when they used single instrument tracks as I do and most folks do. Further experiments revealed that these Kontakt and Reaktor instruments could work in cakewalk with copied midi, if we separate the midi track and the instrument track and connect them by routing. Nobody so far find how we can work with a simple single instrument track in Cakewalk with these instruments, but there is this workaround.

    So I hope this info will be useful if others have similar problems using these stuff together. Best wishes,

    Istvan

Answers

  • LostInFoundation
    LostInFoundation Member Posts: 4,046 Expert

    Try to transpose the copied midi notes to see if it makes any difference

  • karsai
    karsai Member Posts: 47 Member

    Thanks. I tried transposing and no difference. In the same piano roll I edit record or copy and the copied midi does not play, but the other 2 plays. Velocities are not zero and these copied midis working on other instruments. It is very puzzling.

  • LostInFoundation
    LostInFoundation Member Posts: 4,046 Expert

    Definitely. Midi not playing just because it is copied is nonsense

  • karsai
    karsai Member Posts: 47 Member

    I did some follow-up study. Several NI instruments behave the same way such as Monark, etheral earth and so on. While other instruments such as Massive, Prism or from other companies I tested Synth master player had no problem to play these copied midi notes. I started this project with importing a midi file into cakewalk. Then I was not using the general midi instruments, but opened up new instruments and copied the midi notes into these new tracks giving the old file a new set of instruments while avoiding routing the midi tracks into instrument tracks (by using a single combined track instead). This worked for me before on other projects, but not here.

    It would be interesting to learn, if you had any similar experiences and why this happens at all? It does not make sense to me, but maybe several NI instruments are reading midi notes in a different ways. Anyway if you have any thoughts on this please respond. Thanks!

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod

    Where do you copy these MIDI notes or MIDI clips from? Are these clips or tracks set to specific MIDI channels? Most of Kontakt or Reaktor instruments will only response to MIDI channel 1. The solution is to make sure the track or keyboard is set to MIDI channel 1 or go to Kontakt settings (you can access that with the Edit view of Komplete Kontrol) and set the channel to omni. THis article will probably be helpful: Configuring your MIDI Keyboard / Controller in KONTAKT

  • karsai
    karsai Member Posts: 47 Member

    Dear Jeremy, I tried what you suggested. The midi controller is unplugged when I copied the midi track into the instrument track. I used komplete kontrol but it does not work. I copied the midi notes to Kontakt and it does not work either. I also do not have that option the article mention. See screen shot. As you see the track also set for input as omni. Nothing change if I set them midi channel 1. If I plug the midi controller in it is still the same. I can play with the given instrument with the midi keyboard, I can write note in the piano roll and that is played back, but the notes I copy from the original midi file is not played back by many instruments (but Massive and synthmaster 2 can, for example). I enclose the midifile also. Please help. This is puzzling.



  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod

    @karsai I tried to open your MIDI file in Ableton and load Retro Machines mk2, everything loads as it should. I don't have Cakewalk to check, have you tried with other Kontakt instruments?

  • karsai
    karsai Member Posts: 47 Member


    Dear Jeremy,

     Several NI instruments behave the same way such as Monark, Etheral earth and so on. While other instruments such as Massive, Prism or from other companies I tested Synth master 2 player, had no problem to play these copied midi notes. Thanks. Istvan

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod

    Monark is a Reaktor instrument and will only receive on MIDI channel 1, again, I suspect this has to do with MIDI channels.

    I suspect that when you load the MIDI file in Cakewalk, it creates several MIDI tracks with pre-assigned MIDI channels. Can you check the MIDI channel of these tracks? https://legacy.cakewalk.com/Documentation?product=SONAR&language=3&help=Playback.29.html

    Make sure that the MIDI channel of the track matches the MIDI channel of the instrument. Try to use Kontakt on these tracks instead of Komplete Kontrol.

  • karsai
    karsai Member Posts: 47 Member

    Thanks, but this is not the problem. I do not use those midi channels the daw generates. After I load the midi file, I open a new instrument such as Monark or retro machines and copy the midi notes to that new track. Then I listen and no sound. I open instrument Massive I copy the same midi notes There is a sound.

    I do not use the midi tracks from the midi file and I am not routing those to the instruments. to avoid these issues you mentioned. In all cases the input channel is omni (I also tried to change it specifically to 1). If I use Kontakt instead of KK the result is the same.

    This is the puzzling issue

  • karsai
    karsai Member Posts: 47 Member

    Dear Jeremy, I responded above in the morning and it seems we are stuck. Could you import the midi file I sent you to your DAW. Then Do please what I descried above: Open instrument tracks and copy the midi notes into the track ( do not reroute the midi notes from the original midi tracks). Use retro machine, Monark and Massive as instruments. Delete the original midi tracks. Export this new tracks to midi file and send it to me.

    With this we can exclude few things, Weather this [problem is coming from the original Midi file, it is Daw related or it is instrument related. This might reveal this puzzle. Copying midi notes to new instrument tracks should work, but it does not work for me in this case, while if I add notes with mouse or midi keyboard to the same track, those notes have sounds, Copying the same "silent" midi notes to other instruments such as Massive or synthmaster will sound. Thanks, Istvan

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod
    edited August 2023

    Hey @karsai I'm sorry but I have no time to do this. I'm telling you (with a few years of experience of support at NI) that Reaktor and Kontakt are very sensitive to MIDI channel information. I suspect that Cakewalk is a little bit different when it comes to MIDI. In some DAWs, even virtual instrument tracks have MIDI channels. I would definitely recommend to try a demo for another DAW, Ableton or another one to check how your MIDI file behaves there.

    The only other thing that comes to mind is that issue: KONTAKT's Volume Resets When I Press Play in my DAW but since it seems to also happen with Reaktor instruments, I doubt it but it's worth checking it out.

  • karsai
    karsai Member Posts: 47 Member

    OK thanks for your advise. If I find out what is this issue I will post it here. Best wishes, Istvan

  • karsai
    karsai Member Posts: 47 Member
    Answer ✓

    Dear Jeremy,

    There is some progress in this problem. First, I had the same issue with Drumlab. no sounds, but there is an option to turn track into the sequencer as a sequence and when I did the sound was there (but of course it transferred only 4 bars so not a real solution).

    So I decided to run this issue also with the cakewalk community. They tried and had the same results as I had when they used single instrument tracks as I do and most folks do. Further experiments revealed that these Kontakt and Reaktor instruments could work in cakewalk with copied midi, if we separate the midi track and the instrument track and connect them by routing. Nobody so far find how we can work with a simple single instrument track in Cakewalk with these instruments, but there is this workaround.

    So I hope this info will be useful if others have similar problems using these stuff together. Best wishes,

    Istvan

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod

    @karsai Thank you for the update. Glad you were able to find a workaround.

Back To Top