Studio Display + Scarlet Solo + Yamaha HS5

AlexStark
AlexStark Member Posts: 4 Member

Hello everyone.

I have a scarlet solo with 2 Yamaha HS5 plugged in on my Apple Studio Display and everything is working properly.

I was using Fat Blob Virtual Amp + Garage Band and the world was great.

I take Guitar Rig 6 yesterday and my Scarlet wasn't detected by the software when it was plugged in on the Studio Display (it's detected on every software except Guitar Rig 6)

I directly plugged my scarlet into the Macbook and guitar rig 6 worked BUT, when it's plugged into the macbook directly, the Yamaha speaker start buzzing.

If the studio display is disconnected the buzzing dissapear.

But plugged directly into the studio display there's no buzzing.

It's driving me crazy.

So now if I want to use Guitar Rig 6 I need to have the scarlet plugged in the macbook directly, but I have a buzzing crackling sound coming from the speaker.

Does anyone have this issue ? Except asking for a full refund of Guitar Rig ?

Best Answer

  • AlexStark
    AlexStark Member Posts: 4 Member
    Answer ✓

    Ok, I found a solution that works.

    For those who have that problem, create an aggregated device on macOS that resolve the issue.

    With this Guitar Rig 6 is able to detect the Scarlet Solo plugged into the Studio Display.

Answers

  • AlexStark
    AlexStark Member Posts: 4 Member
    Answer ✓

    Ok, I found a solution that works.

    For those who have that problem, create an aggregated device on macOS that resolve the issue.

    With this Guitar Rig 6 is able to detect the Scarlet Solo plugged into the Studio Display.

Back To Top