Native Access "not really" performing updates or reinstalls of many instruments

BIF
BIF Member Posts: 418 Pro
edited July 2023 in Native Access

The subject says it all. Here are the details:

  • Windows 10
  • NA version 3.4.0
  • Kontakt 7

Example: West Africa. But NA is not handling many different products correctly. West Africa is not the only one.

  1. Kontakt is not running. I open NA and I see West Africa has an update available.
  2. I click on "update". NA does some fancy spinning and status bar jiggery-pokery, and comes back saying update was successful.
  3. But West Africa still shows in NA that it has an update available. This is not correct. Unless #2 above failed and NA lied to me about the successful status.
  4. Next, I "reinstalled" West Africa via NA. Again, Kontakt is not active. But the NA download phase is WAY TOO FAST for it to really be downloading a 1.44 GB file. And West Africa STILL SHOWS UP with an update available.
  5. Next, I tried to just uninstall West Africa via Registry folder deletions and physical folder deletion from my hard drive. First, I shut down NA and I made sure that Kontakt was also not running. Then...
  6. HKEY_CURRENT_USER > Software > Native Instruments - I used Regedit to delete the West Africa folder
  7. HKEY_LOCAL_MACHINE > Software > Native Instruments - Also in Regedit, I deleted the West Africa folder
  8. K:\Native Instruments\West Africa - I deleted the West Africa folder from my hard drive.
  9. I closed Regedit and opened NA.
  10. After all this: West Africa STILL SHOWS UP in NA WITH AN AVAILABLE UPDATE. This is not not not right.
  11. Even with 9 above, I try to do a "reinstall".
  12. NA gives me a failure and says to check my file locations.
  13. I assume that NA is borking on K:\Native Instruments\West Africa no longer existing, so I create it as an empty file.
  14. NA does all the pretty dancing making it look like it was actually installing West Africa. But nope. Again, the download was way too fast to have actually downloaded a gig and a half of content.
  15. NA still shows "West Africa" as needing an update. Furthermore, my folder K:\Native Instruments\West Africa has no contents.

Native Access should just work. But it lies to me on some software products. This behavior happened under Version 2 and Version 1, too. Something is borked.

Is there a way for me to get separate "install exe" files for the products that are not updating?

This happens with Balinese Gamelan, Cuba, and some others. I can provide a full list if somebody thinks it may be pertinent.

Thoughts, ideas?

Tagged:

Answers

  • Uwe303
    Uwe303 Moderator Posts: 2,886 mod

    Hello,

    you can go to the download folder and copy the iso file to another place while it downloads, a few days ago that worked on windows system. Or contact support, they should be able to give you links to the iso files.

  • BIF
    BIF Member Posts: 418 Pro
    edited July 2023

    Thank you, but I knew that already. There is a problem with the installation process within Native Access. Also...get this:

    In Native Access, the file size on the "Library" page is advertised as 1.44 GB, and the file size for the "Update" page is listed as 61 MB.

    But when I perform the "reinstall" and save a copy of the EXE file as you suggest, the resulting zip file is 59.7 MB, while the uncompressed EXE file within is 60.1 MB. This is the correct size for the UPDATE but not for the REINSTALL of a 1.44 GB instrument.

    Also, the zip file for both the INSTALL as well as the UPDATE of West Africa are the SAME SIZE. 59.7 MB.

    So the conclusion here is that for some reason, I am not getting the full 1.4 GB download of the full West Africa Instrument, and something is still wrong with the "reinstall" function in Native Access.

    I'm almost certain that I could fix this if the "reinstall" function would download the West Africa library and NOT just the update.

    I am now using NA 3.5.0 (970ccca / 1.13.0.0), which was installed just moments before I tried all of the above.

  • Uwe303
    Uwe303 Moderator Posts: 2,886 mod

    Have you then also tried the regtool from native, I don't know if west africa is in there but that's maybe worth a try too

  • BIF
    BIF Member Posts: 418 Pro

    I have tried it, and I tried it again just about 30 minutes before making this post. It does not result in Native Access downloading the ORIGINAL INSTALLER. NA continues to download only the UPDATE INSTALLER.

    Same is true for Balinese Gamelan. A "reinstall" only downloads the 199 MB "update" not the original 2.39 GB installer. Same is true for all of the Scarbee instruments.

    I'm thinking now that NA is broken for these products and some others too. It's only downloading the updates, not the full products.

  • BIF
    BIF Member Posts: 418 Pro

    Question: I have located my old Komplete Ultimate 10 USB installer hard drive. Might it be possible for me to run the uninstaller from that, followed by the installer from that same drive? THEN maybe see if Native Access properly updates the instrument(s) in question? I believe most of the instruments I'm having trouble with are on that installer hard drive.

  • BIF
    BIF Member Posts: 418 Pro

    Okay, I have had some success with West Africa. I will show you the steps I took to get it to work, but we should all acknowledge that THIS IS NOT THE SOLUTION. It is just me bypassing the broken function in Native Instruments, and I was ONLY able to do this because I happened to have my old Komplete Ultimate 10 hard drive.

    Here are the steps I took for West Africa:

    Check Current Status:

    • I am now on Windows 11 and everything outside of Native Access seems to be working fine.
    • Native Access is on version 3.5.0 (9780ccca / 1.13.0.0)
    • West Africa did NOT appear in Windows Programs and Features when it was supposedly installed. I always thought this was part of my problem, and it turns out I was right. Please read on...
    • West Africa's library folder had been deleted from my hard drive already. For reference, my NI libraries are on K:/Native Instruments, and specifically for this example, West Africa would (should) ostensibly go to K:/Native Instruments/West Africa Library
    • West Africa was STILL appearing in Native Access 3 for "update". But it wasn't there, it wasn't showing up in Kontakt 7, and it wasn't working.

    Steps:

    1. Verify backups are being done and I have a current one of my main partitions C, F, and K. Done.
    2. Run the standalone Native Instruments "Registry Uninstaller". Select only West Africa for uninstall. Ran fine. But re-opening NA shows West Africa wants an UPDATE.
    3. At this point, I disregard Native Access' lies to me. I plug in my old Komplete Ultimate USB hard drive to a USB 3.0 port on my computer.
    4. I could run the subinstaller for West Africa, but that sometimes gets rejected. So instead, I find the main installer for Komplete 10 Ultimate (that's the EXE file).
    5. The installer opens and warns me that I have more current versions of products such as Komplete, Massive, and some others, and that it has helpfully de-selected those. Fine by me. I click "okay" or "next"...whatever option moves me forward.
    6. The old installation tree opens up and shows a bunch of products with red Xs. But some other products that it wants to install. I scroll up and down the ENTIRE LIST and make sure that ONLY West Africa is selected for installation. Red X's for everything else.
    7. I click Next. The installer comes back with some prompts, which I confirm.
    8. The really IMPORTANT prompt is "where to install West Africa's Library?" The installer wants to put it to the partition I used back in 2014 or whenever I first installed West Africa: I:/something-something-Native-Instruments Likes Cheese".
    9. ==== OBSERVATION: The fact that the old installer remembered the OLD PATH tells me that the registry cleanup tool doesn't know where EVERYTHING is.
    10. So I make a note of "9" above, then I enter the new path "K:/Native Instruments" in the entry box...without quotes. The installer will append "West Africa Library" to the end of that, so the path will be K:/Native Instruments/West Africa Library when all is said and done.
    11. I click next one or more times, and the old installer proceeds with its dance of the dead. It finishes and I get the old prompt dialog "Finished!" I close the old installer.
    12. Now I restart Native Access 3.0. NA opens up and shows "West Africa" ready for INSTALL. Exercising patience, I wait a couple minutes for NA to complete its initialization refresh. "West Africa" now shows "UPDATE". I click Update.
    13. Native Access does it's own dance of the dead, and it comes back and says that the update was successful.

    Final Checks:

    • The West Africa library path is now "K:/Native Instruments/West Africa Library" ... YAY!
    • NA's "Updates" counter went from 21 to 20... YAY!
    • NA no longer lists West Africa as "UPDATE". West Africa ONLY APPEARS NOW AS "INSTALLED"... YAY!
    • West Africa now appears in Kontakt 7 with the following: 1 - Perc Ensemble (12), 2 - Perc Ensemble (16), 3 - Single Perc (12), 4 - Single Perc (16), 5 - Melodic Instruments. This appears full and complete to me. YAY!

    West Africa now shows up in Programs and Features as follows:

    • Native Instruments West Africa - Publisher Native Instruments
    • Installation date today (8/10/2023)
    • Size: 1.32 GB
    • Version: 1.4.1.4.

    This all appears full and correct. And yes, the instruments all play in Kontakt 7! YAY YAY YAY!

    Final Observation:

    I was able to fix West Africa ONLY BECAUSE I HAD AN OLD INSTALLER HARD DRIVE. I will try this with Gamelan and the Scarbee instruments that are all broken for me, and I will post when I have results.

    This fixes my problem, but it does not fix the problems with Native Access. Again, NA didn't download the full installer...it only downloaded the updater.

    More to come....

  • BIF
    BIF Member Posts: 418 Pro
    edited August 2023

    Update 8/10:

    Using the method I outlined above, I have successfully fixed...

    • Vintage Organs
    • Balinese Gamelan
    • Cuba
    • Scarbee Jay Bass
    • Scarbee MM-Bass and MM-Bass Amped
    • Scarbee Pre-Bass and Pre-Bass Amped
    • Scarbee Vintage Keys, which since Komplete 9, contains Mark I, A200, and Clavinet Pianet

    I have more to fix, but the good news is that I am down to "only" 8 broken products.

    Note 1 Regarding Vintage Keys:

    If you originally installed Mark I, A200, and/or Clavinet Pianet BEFORE Komplete 9, then you will need to run through the steps to uninstall each of them individually. If "Vintage Keys" also exists, I would uninstall that too.

    Then, if using a Komplete 10 Ultimate USB drive to install them fresh, you only have to install Vintage Keys, and that will also install Mark I, A200, and Clavinet Pianet.

    Note 2 Regarding Vintage Keys:

    Once you've run the USB installer for Vintage Keys and you're ready to go back into Native Access to get the updates, give NA a couple/few minutes to complete its refresh with the NI mothership. If you're too quick with your trigger finger on the updates, you might get a failure with a note to "check folder names" or something. I got that because I tried to update A200...but I had already de-installed it and re-installed it by installing "Vintage Keys", which in the path notes in my previous post, puts them here:

    • K:/Native Instruments/Vintage Keys Library/Instruments/Mark I
    • K:/Native Instruments/Vintage Keys Library/Instruments/A-200
    • K:/Native Instruments/Vintage Keys Library/Instruments/Clavinet Pianet

    The old "pre K9" paths would have omitted the "Vintage Keys Library/Instruments" nodes, and that's how NA got confused this time around. The fix here was simple. "Be patient!"

    Yep, all I had to do was wait 2 minutes for NA to finish its dance with the NI mothership. Once it did that, Mark I, A200, and Clavinet Pianet disappeared from my NA update screen, and were replaced by a single entry for Vintage Keys.

    Now I'm off to work on the remaining 8 instruments. Not sure all of them are on the K10U USB drive. If one or more is not, then I'll be unable to fix those. More to come...

  • BIF
    BIF Member Posts: 418 Pro

    Update 8/11:

    I have been able to fix all of my products.

    A couple of the products were newer than my Komplete Ultimate 10 USB drive, so I took a shot at letting Native Access do the installs for those. Luckily for me, that worked and NA did not insist on downloading only the "update" when I was asking it to do an "install".

    Here's the list of the final 8 products and any applicable notes:

    • Symphony Essentials String Ensemble
    • Prism - Note that this is also called "Reaktor Prism", in case you are scrolling through any alphabetically-sorted lists of products. Installed by way of Komplete 10 USB drive.
    • Pulswerk
    • Monark
    • Kontakt 7 - Installed via Native Access download.
    • Kontakt Factory Selection - Installed via Komplete 10 USB drive
    • Reaktor Factory Selection 2
    • Session Horns Pro - Installed via Komplete 10 USB drive

    Side Note: If you have a choice of installing an older product by way of your most recent Komplete Ultimate USB hard drive versus doing the download via Native Access, I'll say that the larger products, such as Session Horns Pro, are MUCH FASTER to install from the USB drive. And I have 22 MBPS fiberl service here, which is no slouch! /End Side Note

    In each of these cases, the process was the same:

    1. Confirm that the product wasn't showing up in Windows Programs and Features. This was key. I did not have any issues with ANY products that showed up correctly in Programs and Features.
    2. Use the NI Registry uninstaller tool to uninstall the old product that kept showing up as "Update Needed" in NA but would not actually update.
    3. Delete the library folder at K:/Native Instruments/something-something Library (note: I would actually just rename it to "~ - Old" just in case).
    4. If the installer was available on my old K10U USB disk,, then I used that to reinstall the product. If the product wasn't on that disk, then I would just use Native Access.
    5. Refresh Native Access and perform the update from NA.
    6. Confirm successful install update in NA and confirm that the product no longer kept reappearing as "update needed".
    7. Confirm that the product now shows up in Programs and Features.
    8. Confirm that the newly reinstalled library shows up in Kontakt (or wherever it's SUPPOSED to appear).

    That's pretty much it and this closes my issue.

    As mentioned in my posts above, I still believe that NA has some problems with some products, because NA would only perform an "update" even when asked to do an "Install".

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @BIF If you still have issues, feel free to contact my colleagues here: http://bit.ly/NIsupport_install

  • BIF
    BIF Member Posts: 418 Pro

    Thanks Jeremy. For now, my issues have all been resolved, but that was ONLY because, armed with only determination and some basic knowledge, I took the time to self-diagnose. This should never be the responsibility of the customer, especially since it continues to be apparent that Native Access has some issues of its own that can, will, and have been causing pain and anguish for others.

    Thanks again, and I'll try to keep NA out of trouble the next time...

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @BIF I hear you. You could have contacted my colleagues from support and you should definitely do so in case you have other issues. We try to help users on the forum but it's not a substitute for support.

  • Ken Thompson
    Ken Thompson Member Posts: 1 Newcomer

    @BIF I'm having the exact same issue with Damage 2 and Symphonic Destruction. They seem to "update" but then the installation fails and takes you back to the Update buttons.

  • elphinstone
    elphinstone Member Posts: 1 Member

    Hello all,

    I had the same problem with 5 libraries that needed an update and just wouldn't update...

    I noticed that in my case those programs had a wrong installation path.

    In my case the installation path for example for "Maschine 2 Factory Library"is located at: N:\NI\Maschine 2 Factory Library

    But when I check the installation path in NA it is: N:/NI/Maschine 2 Factory Library\

    Notice the forward slashes? Those should be back slashes.


    So I looked them up in the regeditor at: HKEY_LOCAL_MACHINE\SOFTWARE\Native Instruments\Maschine 2 Factory Library

    and changed the forward slashes in the ContentDir key to back slashes (for every library that had this problem)


    After that I restarted Native Access and I was able to update the libraries

    Hope this helps someone else.

    Cheers.

    Jim

Back To Top