Stuck on version 2.8.1

ham2065
ham2065 Member Posts: 13 Member
edited July 2023 in Komplete Kontrol

Komplete Kontrol will not update to the latest version 2.9.4.

I run Native Access and no update is found.

I have tried uninstalling and reinstalling and it always comes back to version 2.8.1.

Does anyone have a fix for this.

I have recently bought an s61 and I am getting some issues running KK in DAW (Pro Tools) so wanted to try the latest version to see if the issue is resolved.

Best Answer

  • PoorFellow
    PoorFellow Moderator Posts: 1,694 mod
    edited July 2023 Answer ✓

    Make sure that you are running latest version of Native Access (3.4.0)

    And then try running Native Access as an Admin !

Answers

  • PoorFellow
    PoorFellow Moderator Posts: 1,694 mod
    edited July 2023

    Please supply platform and OS version info !


    Try un-installing Native Access and then reboot and then try re-install Native Access :

    Native Access 2 / 3 :    

    https://www.native-instruments.com/en/specials/native-access-2/   

    OR

    https://www.native-instruments.com/en/support/downloads/


    If latest version will not install then it is a problem that N.I. un-install and install do not properly clean after old version !

  • PoorFellow
    PoorFellow Moderator Posts: 1,694 mod
    edited July 2023 Answer ✓

    Make sure that you are running latest version of Native Access (3.4.0)

    And then try running Native Access as an Admin !

  • ham2065
    ham2065 Member Posts: 13 Member

    Thanks PoorFellow for the info on Native Access reinstall.

    Running Windows 10 with the latest patches.

    I have Komplete 14 and everything else except Komplete Kontrol seems to be updated to the latest version.

    I will try the Native Access reinstall and see how it goes

  • ham2065
    ham2065 Member Posts: 13 Member

    Yes that fixed it. Native Access was on version 2.x.

    After uninstall and reinstall it is now on version 3.4 and there were 5 updates listed (including the KK 2.9.4 update) that were not showing up under version 2.x

    Thanks

  • PoorFellow
    PoorFellow Moderator Posts: 1,694 mod
    edited July 2023

    Thank you and I am very sorry for my confusion , but yes after making sure that you are running latest version of Native Access (3.4.0) then try running Native Access as an Admin !

    You can also try using the NI Uninstall RegTool_64bit to remove the Komplete Kontrol app to see if that makes any difference :  https://support.native-instruments.com/hc/en-us/articles/115003509269-Fixing-Software-Update-Installation-Issues-Windows-

    If it does not I think that we need to call an Admin from N.I. support who will most likely just ask you to contact support !

  • PoorFellow
    PoorFellow Moderator Posts: 1,694 mod

    You are most welcome and I am glad that my advice were of help ! 🙂

Back To Top