Unable to update all 47 of my NI installed Gear

Options
TheAmpFactory
TheAmpFactory Member Posts: 10 Member

Everytime I try and update, i get the yeah yeah. the Install failed thing, no error just " Download failed" unable to do update.


So, the cat and mouse games begin, so I tried to do various things!. - Tried the fixes that the NI help page advised. - Tried on a few, but sadly this di not work. - Tried to then uninstall. - but now we have taken it away from the reg.. it no lobger exisits. so I cant do that.. so.. the next thing is to, delete everything and start over. (but manually??) I HOPE not. as this is a few days work invloved. and really. NI need to source some better coder team as this is not new.. been happining since OG Native access... (yes been here many times before) - and each time, I say no more!.. and yet.. here I am again wasting yet another entire work day on trying to update and get things to work!.


Anyway!. - any help would really be appreciated! - thankyou so much!

Best Answer

  • TheAmpFactory
    TheAmpFactory Member Posts: 10 Member
    Answer ✓
    Options

    Ok.. all done now!..

    So what did I do.. I had to look up the app I wanted to update. - then use a script to remove it from the reg. then use a windows tool to remove it from the install programs list, - rename the folder for NI (app name) refresh the native access. - and it would send the app to the "Available" section.


    From here I can just install it like it was new. - all good!.

    Delete the old renamed folders..

    Back to work!>

    What a hassle though...

«1

Answers

  • PoorFellow
    PoorFellow Moderator Posts: 3,665 mod
    Options

    You fail to provide even the most basic of information such as platform used PC or MAC and OS type and version..

    Quote : "Tried to then uninstall." , What ?

    Quote : "Tried the fixes that the NI help page advised." and quote : "Tried on a few," , none of this inspires any confidence that you worked through all the suggested things to try and definitely do not tell exactly what you have already tried !

    Prior to getting where you are psychically you ought to have contacted support to have them try to help. At this point in time however please notice that there are rather long wait for support due to the sale that has been going on !

  • TheAmpFactory
    TheAmpFactory Member Posts: 10 Member
    Options

    Yep. good and valid point. - Frustrated typing!


    Windows 10, Latest update as of right now. as updated yesterday on 5th July. - latest version of native access. (not sure what that version number is, but downloaded it earlier) as Im not in front of it right now.


    The fixes I was refering too, are the NI reg removal tool. - as found here :- https://support.native-instruments.com/hc/en-us/articles/115003509269-Fixing-Software-Update-Installation-Issues-Windows-


    Then, as this removes the "instrumet/effect" from the reg. it no longer appears in the "windows/apps", so you cant choose uninstall, nor can you reinstall, as N.access still sees the prorgam. after hitting "update" it simply fails.


    Bit anoying really as I just spent a lot of m,oney on upgrading. to then not be able to do anything. - as the apps I have are out of date that I know some of the things I want to use wont work untill I update. - so its a doubel edged sword. (massiveX for one) among others.

  • PoorFellow
    PoorFellow Moderator Posts: 3,665 mod
    Options

    Thanks , Just to clarify for others , what product version did you own and what did you upgrade to ?

    With respect to the use of the 'reg tool' then unless you are sure that you will not revert then you ought never use such tools without take some registry backup or make a restore point so that you can revert what you have done... When 'tinkering' it's always nice to at least have the option to be able to 'undo' !

    Else , since you claim to have done trouble shooting then this is most likely not going to help , but for what it is worth here is a link to the "Native Access Error Message: Download Failed: Unknown error" trouble-shooter :

    https://support.native-instruments.com/hc/en-us/articles/115005878409-Native-Access-Error-Message-Download-Failed-Unknown-error-

    Else as it say : "The solutions provided below have resolved the issue in most cases. If they do not help, please start our Solution Wizard which offers further information. If you still need help with the issue you can file an email ticket through the Solution Wizard. " :

    https://support.native-instruments.com/hc/en-us/categories/360000053677


    Just make sure that people , including support, understands exactly at what stage your setup is as of now , like e.g. that you have used the NI reg removal tool...

  • TheAmpFactory
    TheAmpFactory Member Posts: 10 Member
    edited July 2023
    Options

    Yeah appreciate your help, sadly already seen and tried those fixes. but currently none apply to my case. -now back at my computer, I was also miffed to see Im still using the light version of the NA.

    Cant upgrade to the Access 2 however, as I get an error with that too!. (Unable to install, please uninstall the previous version) - but cant do that as Windows sees the install in a invalid location (via windows apps) - however, not concerned with this right now, as it sees all I need it too.

    Im upgrading from Ultimate 13 to 14... as I do every year... and also get this same issue....every year! :)

    So I download. (waste weeks doing it) then ABSOULTE walk away! untill a year later! hah!


    I have already put a ticket in with full pics/docs etc, so we are all good there. - just a bit frustrated with it is all!. - just supprised that NI cant fix simple update issues.

  • PoorFellow
    PoorFellow Moderator Posts: 3,665 mod
    edited July 2023
    Options

    Quote : "Cant upgrade to the Access 2 however, as I get an error with that too!. (Unable to install, please uninstall the previous version)"

    You can not be sure that Native Access 1 will work (it's more or less considered as obsolete by N.I.) so you need to upgrade to Native Access 2 /(3.4.0) . As for the N.I. reg-tool then it does not actually do it's job properly as far as I am concerned. Also after an un-install there may be files left on your hard drive. Also , please check in Task Manager to see if you have the NTKDaemon process running despite you having uninstalled the app and then failed to install new..

    Others have used the procedure described on this page : Native Access 3.3.1 won't install, can't remove old NTKDaemon : https://community.native-instruments.com/discussion/12485/native-access-3-3-1-wont-install-cant-remove-old-ntkdaemon/p2

    IMPORTANT : prior to any computer tinkering then please at least make a Restore Point , and prior to tinkering with registry take a back up of the registry. Also generally it's always advisable to backup the whole system drive once in a while or at least if you got something that you do not want to loose if you mess up anything !

    What I did myself were to uninstall Native Access , then kill process NTKDaemon and run the N.I. reg-tool to remove Native Access from registry , then delete all directories named Native Access from drive and all instances of NTKDaemon - including destinations such as (can not remember which exactly but also depends on version I think - 1 or 2) :

    C:\Users\<user name>\AppData\Local\ and C:\Users\<user name>\AppData\Local\Native Instruments

    C:\Users\<user name>\AppData\Roaming\ and C:\Users\<user name>\AppData\Roaming\Native Instruments

    C:\ProgramData\ and C:\ProgramData\Native Instruments

    C:\Program Files\ and C:\Program Files\Native Instruments

    C:\Program Files\Common Files\ and C:\Program Files\Common Files\Native Instruments


    Then I cleaned the registry using the free CCleaner (remember to use the registry backup function first)

    Then I used registry editor to then remove any left traces of 'Native Access' and 'NTKDaemon'

    And then confident that all traces of Native Access and NTKDaemon were removed from from both drive and registry and that the NTKDaemon process were no longer running after startup then I installed Native Access 2 / 3.4.0 (run install as Admin !) : https://www.native-instruments.com/en/specials/native-access-2/   

    OR https://www.native-instruments.com/en/support/downloads/


    Then of course also , prior to trying to install anything then make sure that you have sufficient access privileges to all drives included and that you have enough drive space including *temp space* for download and installation on your system drive !

  • TheAmpFactory
    TheAmpFactory Member Posts: 10 Member
    Options

    Hi, thanks for a detailed asnwer. - looks like I might need to get this NA2 on my PC then before I can update (from what I read).. so this is now the battle. - tried to follow others steps, but I sadly have the issue before NTKDamen.


    I have this in my windows/apps. but cant uninstall it.


    if I do, this is the error I get.....

    Using Microsofts uninstall tool (that was recommended to use on NI site) to fix the unistall errors, does not show the product for Native access NOR NTKDeamon. as shown here.

    Seems though, (and from expereince) that IF the product is showing in the windows/apps list then (even if you deleted it manually) then NI's products will never work/install OR uninstall. - so the trick is to remove it manually then get rid of it via the Reg.

    However. doing this for 47 updates is not a nice thought.


    Anwyay. - is there a easier way to do this. as this seems crazy if you ask me!. - sort of going around in circles a bit...

  • PoorFellow
    PoorFellow Moderator Posts: 3,665 mod
    edited July 2023
    Options

    Please refer to how I did myself : https://community.native-instruments.com/discussion/comment/82995#Comment_82995   

    Read it from where it says "IMPORTANT".....

    If you follow that advice then there ought not be any remnants left of Native Access and NTKDaemon !

    But of course this both requires knowledge of Windows and an effort to do !

    P.S. When using the N.I. tool please notice that some entries does not start with Native Instruments , some just says : e.g. NTKDeamon

  • TheAmpFactory
    TheAmpFactory Member Posts: 10 Member
    Options

    YEah its ok, I know my way around. (Im also a plugin developer) so I know how things work. - however, currently going through the registry. doing iot manually, as I dont trust any other programs for me. (last time I did that I had bigger issues. - so guess I never recoverd from that! :)

    Its a bit of a pain, to do. but so far Ive removed a whole load, and after several reboots.. still in the exact same place. so guess I need to carry on removing..

    To be honest none of this (we) should be doing in the first place. really..

  • PoorFellow
    PoorFellow Moderator Posts: 3,665 mod
    edited July 2023
    Options

    If you shut down things in task manager first and follow my advice in that order and then deleting stuff from hard drive locations and then use the free CCleaner (offers registry backup) , then removing Native Access and NTKDaemon entries remnants manually from registry is not all that of a work.

    But as you already know ,you can always screw up , that is also why it is paramount that you takes the advice concerning backups also rather than ignoring that part because you know your way around.

    Ref.

    IMPORTANT : prior to any computer tinkering then please at least make a Restore Point , and prior to tinkering with registry take a back up of that. Also generally it's always advisable to backup the whole system drive once in a while or at least if you got something that you do not want to loose if you mess up anything !

    P.S.

    but of course , real men don't take back ups , they just cry instead afterwards 😉 😥

  • TheAmpFactory
    TheAmpFactory Member Posts: 10 Member
    Options

    Yeah. I alfready did backups before I did anything.. as Its so easy to incorrectly remove something unjust!. - however, and funny looking at the reg items a lotof them dont actually make sence. - in terms of the ID codes versus the Product Hex. its a bit of a swing and miss. but I think think I know why!. - after anaylising this. it looks like the NI data (its core) sets the dir of the installer to a temp allocated block. - thus offering a unique but not perma producty hex value. - after install, it writes that down in the reg. offers a location point etc. - but. the actuall program when run, sets its own unique ID and hex. - so there is a conflict.. - now, the Temp ones as it gets deleted is the one that stays in the system, as the new one says "oh there is already an entry" thus ignoring. so this is why we cant uninstall.

    I know why they did this, so the install auto removes the files. - but there is however a easier way for the installer (or NA in this case) to do this withut parsing the reg.


    Anwyay. onwards I go. this will take a while.. (and NO i wont be using CCleaner bloatware thanks) :)

  • PoorFellow
    PoorFellow Moderator Posts: 3,665 mod
    edited July 2023
    Options

    Good luck ! , with respect to CCleaner, it might be bloatware , dunno (doesn't appear that bad to me) , but it's free and it appear to be reliable which are usually two things that everybody wants ! But if you got better free software then that's great of course. I myself generally do a lot to keep down invasive or annoying programs but even paid apps these days appear to nag you with all sorts of crp . For example I got rid of my paid Norton AV for exactly that reason. Yes , I know some likes Norton and some hates Norton but let's not start a discussion on that either !

  • TheAmpFactory
    TheAmpFactory Member Posts: 10 Member
    Options

    Ahhhhh

    #Ok so I found a easier way to do this. is to mass rename any NA entry in the reg to something else (with a script I use for dev work)..... anwyay

    Point is it worked!. and it installed no worries.


    But.. haha!. after ALL THAT hassled.. we are back where we started!:) - but this time I get the errors on the new version instead!.. woot



  • Monochrome
    Monochrome Member Posts: 1,170 Expert
    Options

    Never use utility tools such as CCleaner or similar. They can cause more harm than good. Same goes for manually meddling in the registry.

    https://support.native-instruments.com/hc/en-us/articles/209544929-Notes-on-Using-Registry-or-Property-List-Cleaning-Utilities

    As for the "Update failed" issue, NI offers an extra tool for that:

    https://support.native-instruments.com/hc/en-us/articles/115003509269-Fixing-Software-Update-Installation-Issues-Windows-

  • TheAmpFactory
    TheAmpFactory Member Posts: 10 Member
    edited July 2023
    Options

    thankyou monochrome, we already did those steps way earlier in this thread.

    but does not solve the issues.

    AS you can see from this pic, I removed "Dirt" - but it still fails to install.

    EDIT.


    Ah man having a great time!.. - so was trying to sort out a few things. now.. the Nativce access. does this to me randomly!. so need to restart it everytime!



  • Monochrome
    Monochrome Member Posts: 1,170 Expert
    edited July 2023
    Options

    My apologies, my fault! I didn't see that 🙈

    Something really seems borked there... I think I would make a backup of the registry (maybe even a Windows backup first), delete every registry entry that is NI related and try installing those products again. All on my own responsibility. Could be a bit tedious, though...

Back To Top