Can I/Do I want to update version 3.5.2 on my Mac?

Options
Clownbomb
Clownbomb Member Posts: 2 Newcomer

Hi all-

I see that Traktor Pro is up to version 3.9. My Mac Mini (2018 Intel, latest OS) is running version 3.5.2. Native Access says all of my software is up to date. Clicking Buy Now on the Traktor page says I’m not eligible for upgrade pricing.

Did I miss a paid update somewhere or am I supposed to be on 3.5.2?

Thanks in advance.

Tagged:

Answers

  • LostInFoundation
    LostInFoundation Member Posts: 4,311 Expert
    Options

    If you are on 3.5.2 you already have Traktor 3 so no need to buy anything

    It could be another of the many problems of NA

Back To Top