Kontakt 7 Tone Machine Legato Not Working

isaacsecret
isaacsecret Member Posts: 2 Newcomer

Hello!

Inside of Kontakt 7.3.2... when I create a new instrument. Change the mode to Tone Machine. Press the Legato button. Legato doesn't work. (it just keeps re-triggering the sample)

Inside of the Kontakt Player...when I create a new instrument. Change the mode to Tone Machine. Press the Legato button. Legato works!

But I can't keep using Kontakt Player, because "demo" mode is triggered asking me to update to the full Kontakt. Which I already have. But the legato button doesn't work in that.


Any thoughts? Any news of an update to fix this issue?


Appreciate any help. Thanks!


Best Answer

  • EvilDragon
    EvilDragon Moderator Posts: 1,023 mod
    edited June 2023 Answer ✓

    Known issue, will be fixed in Kontakt 7.5.

    @Rotomot

    In Time Machine Pro mode the Legato works in the most simple cases, but when playing a bit more complex notes it fails. For example, play first a three note chord, release the chord, and then right after that play two notes one-by-one legato style. Kontakt 7 plays those last two notes from different position of the sample, not Legato.

    Legato requires notes to be overlapping, so if you "release the chord", you cannot expect the new notes you play to continue from where you left off. That is then not "legato", that is something else.

Answers

  • Paule
    Paule Member Posts: 1,328 Expert
    edited June 2023

    Any thoughts? Any news of an update to fix this issue?

    How do you realized Kontakt and Player works at the same time. This is excluded.

    Either you work with the full version or with the player. But not with both beside.

    From FAQ Kontankt Player

  • Rotomot
    Rotomot Member Posts: 36 Helper

    I can confirm the Legato not working in Kontakt 7.3.2. This is pretty severe bug. I wonder how many Kontakt libraries are affected.

    It's broken in all sample playback modes, where the Legato option is available.

    The Tone Machine, Time Machine 1, and Time Machine 2 are completely broken. The legato does not work at all.

    In Time Machine Pro mode the Legato works in the most simple cases, but when playing a bit more complex notes it fails. For example, play first a three note chord, release the chord, and then right after that play two notes one-by-one legato style. Kontakt 7 plays those last two notes from different position of the sample, not Legato.

    The Legato option works fine in all sample playback modes on Kontakt 6.7.1.

    Tested in Ableton Live 11 on Windows 10.

  • EvilDragon
    EvilDragon Moderator Posts: 1,023 mod
    edited June 2023 Answer ✓

    Known issue, will be fixed in Kontakt 7.5.

    @Rotomot

    In Time Machine Pro mode the Legato works in the most simple cases, but when playing a bit more complex notes it fails. For example, play first a three note chord, release the chord, and then right after that play two notes one-by-one legato style. Kontakt 7 plays those last two notes from different position of the sample, not Legato.

    Legato requires notes to be overlapping, so if you "release the chord", you cannot expect the new notes you play to continue from where you left off. That is then not "legato", that is something else.

  • Rotomot
    Rotomot Member Posts: 36 Helper

    Yes, I know how the legato should work.

    Looks like a bit more notes have to be played to trigger the bug state in Kontakt 7.

    Here is an example that triggers the bug (MIDI file attached):

    First play the whole MIDI file through to trigger the bug.

    Then play the three not chord and release it. This should not affect the following notes, but it does in Kontakt 7. Then, right after releasing the chord, play two notes so that they overlap, i.e. these two overlapping notes should be legato. Kontakt 7 plays the second note from different position than the first one, not legato.

    Exactly same test with exactly same MIDI and nki plays correctly in Kontakt 6.

    The sample used in the test (KSHMR Female Vocal Phrase - Countdown.wav) and TM Pro settings can be seen here:


  • Rotomot
    Rotomot Member Posts: 36 Helper
    edited June 2023

    Here is a NKI with a countdown sample from freesound.org:

    This NKI and the MIDI file in previous post can be used to reproduce the bug.

    You could also use any other sample, but a human voice countdown sample makes it easy to hear the bug.

  • isaacsecret
    isaacsecret Member Posts: 2 Newcomer

    Thanks @EvilDragon for the response & confirmation. You don't happen to know a time frame for when the next update will happen - do you?

    Thanks again for the help!

  • Rotomot
    Rotomot Member Posts: 36 Helper
    edited June 2023

    Has anyone tried to reproduce the Time Machine Pro Legato bug?

    @EvilDragon, is the Time Machine Pro Legato bug also going to be fixed in Kontakt 7.5?

  • EvilDragon
    EvilDragon Moderator Posts: 1,023 mod

    We're only fixing the Legato not working on other machine modes for 7.5.

  • EvilDragon
    EvilDragon Moderator Posts: 1,023 mod
Back To Top