maschine mk3 (play .restart.erase.tap.stop ) out of function

Hui
Hui Member Posts: 6 Sine
edited March 2 in Maschine

hi everyone 😎

everything work functionally in standalone mode .but in logic when i press these button while recording it's only sending cc number (pic1) but nothing else reacts as it should.i have reinstall maschine mk3 from native access and in controller editor nothing look weird to me 🤔

(control surface setup pic2)

not sure how to fix this issue , can anyone helps up would be thankful

😀

Tagged:

Best Answers

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 635 mod
    Answer ✓

    Hello @Hui Do you have a special MIDI set up in Logic ? Did you make changes to any MIDI settings ?

    In Controller Editor, go to Templates, then Edit, choose New. This will set the template to default.

    Then make sure that Logic is closed, and delete this file:

    Macintosh HD/Users/User Name/Library/Preferences/com.apple.logic.pro.cs

    Note: the User Library folder is hidden. To access it, click on Go in the menu bar and press down the Alt key. You'll now find the Library entry in the menu:

    If that doesn't solve the issue, there might be settings in Logic that you accidentally activated. To get rid of these, you would need to reset Logic to default. This means you will loose any custom settings, so better writing them down. To reset Logic to default you simply have to delete it's preference file found here:

    Macintosh HD/Users/User Name/Library/Preferences/com.apple.logic10.plist

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 635 mod
    Answer ✓

    When deleting the cs file, you should ge a prompt next time you open Logic asking if you want to connect the MK3, similar to this one:

    With Maschine MK3 instead of Komplete Kontrol, obviously. Did you get that message ?

    Please also make sure to give Full Disk Access to both Maschine 2 and Logic Pro:

    How to Enable Full Disk Access on macOS

    I should also ask what Operating system you are on ? Big Sur, Monterey, Catalina ? Do you have a M1 compter or is it an Intel Mac ?

Answers

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 635 mod
    Answer ✓

    Hello @Hui Do you have a special MIDI set up in Logic ? Did you make changes to any MIDI settings ?

    In Controller Editor, go to Templates, then Edit, choose New. This will set the template to default.

    Then make sure that Logic is closed, and delete this file:

    Macintosh HD/Users/User Name/Library/Preferences/com.apple.logic.pro.cs

    Note: the User Library folder is hidden. To access it, click on Go in the menu bar and press down the Alt key. You'll now find the Library entry in the menu:

    If that doesn't solve the issue, there might be settings in Logic that you accidentally activated. To get rid of these, you would need to reset Logic to default. This means you will loose any custom settings, so better writing them down. To reset Logic to default you simply have to delete it's preference file found here:

    Macintosh HD/Users/User Name/Library/Preferences/com.apple.logic10.plist

  • Hui
    Hui Member Posts: 6 Sine

    hi @Jeremy_NI

    thanks for your information !! after follow solution ➡️ deleted /com.apple.logic.pro.cs and /com.apple.logic10.plist it does stop showing up CC number while recording,But still no response as it should be (stop . restart .restart.erase ) , are this is normal?or something still not in the right path ,i remember is able to do that at the first couple times , and surely it was me accidentally set the wrong midi setting before .but hey... at least you got me solved some problem. that's for sure💪~ so how do i going through and clear all the issu ,so it can go back what it supposed be 😎


    thanks 😀

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 635 mod
    Answer ✓

    When deleting the cs file, you should ge a prompt next time you open Logic asking if you want to connect the MK3, similar to this one:

    With Maschine MK3 instead of Komplete Kontrol, obviously. Did you get that message ?

    Please also make sure to give Full Disk Access to both Maschine 2 and Logic Pro:

    How to Enable Full Disk Access on macOS

    I should also ask what Operating system you are on ? Big Sur, Monterey, Catalina ? Do you have a M1 compter or is it an Intel Mac ?

  • Hui
    Hui Member Posts: 6 Sine
    edited March 12

    @Jeremy_NI yes ! i got this message and hit ok to connect , the Operating system is Mac os mojave 10.14.6

    i have Access Maschine 2 and Logic Pro to full Disk access ,

    Is it an operating system mismatch?


    thanks 😃

Back To Top