Some instruments don't detect MIDI/don't make sound in Kontrol and Kontakt

Liusenn
Liusenn Member Posts: 2 Newcomer
edited June 2023 in Komplete Kontrol

Hi

I've have a Novation Launchkey Mini MK3. It is detected correctly and does send midi signals to my Mac. But when I'm in Komplete Kontrol most instruments won't make sounds. But a few will, like FM8 for instance. Like I would launch FM8 and I see/hear sound, then I switch to Alicia's Keys and no sound.

I have the feeling that it is all Kontakt instruments and launching Kontakt to play them also doesn't make sound, though the Launchkey is visible and enable in the settings for both.

I have other midi keyboards and they work fine with all instruments... it had been a while since I used my launchkey but it used to work in the past.

I've tried everything (I mean it... down to deleting everything and re-installing ...) but still the same issue.

I'm out of ideas, anyone has one to share?

Cheers,

~L

Best Answer

  • Sunborn
    Sunborn Member Posts: 2,147 Expert
    Answer ✓

    As you describe it, it should be a Novation Launchkey problem, not a Native Instruments one.

    Maybe something with configuration? For example, some virtual instruments make sound only on Midi channel 1. Check this out and try configure your Novation Launchkey to transmit at channel 1 (or "omni", "any" etc) as main midi and assign your instrument channel at this channel too.

    I am not much familiar with Kontakt and its libraries but they should also have a way to change their midi channel.

Answers

  • Sunborn
    Sunborn Member Posts: 2,147 Expert
    Answer ✓

    As you describe it, it should be a Novation Launchkey problem, not a Native Instruments one.

    Maybe something with configuration? For example, some virtual instruments make sound only on Midi channel 1. Check this out and try configure your Novation Launchkey to transmit at channel 1 (or "omni", "any" etc) as main midi and assign your instrument channel at this channel too.

    I am not much familiar with Kontakt and its libraries but they should also have a way to change their midi channel.

  • Liusenn
    Liusenn Member Posts: 2 Newcomer

    @Sunborn Ah! Thanks for this !!! This is it!!!!

    The default is Port A Channel 1 and when I switched to omni in the Kontakt settings it worked.

    So I though, my Launchkey must have been sending to that default channel by default too in the past... and now it obviously doesn't... so reset it to factory settings and now everything works!

    Thanks so much, I was getting hopeless!

  • Sunborn
    Sunborn Member Posts: 2,147 Expert

    Glad to help! :-)

    Please click the "question answered" button so this will consider as solved.

Back To Top