Kontakt 7 not showing in MPC 2.11

eli777
eli777 Member Posts: 7 Member
edited August 2023 in Kontakt

I've been trying to get Kontakt 7 the full version working in MPC 2.11 but it only recognizes kontakt player 6 (which can't play the Kontak 7 libraries). I tried sending an email to get Komplete Start which has Kontakt 7 player but still don't see Komplete Start in my Native Access account to download.

Any reason why its not showing up, its free after all and I have a paid version of Kontakt7. Also why is Kontak 7 not showing up in MPC? MPC works with other vst3 plugins but it will only recognize Kontakt 6 Player...

Tagged:

Best Answer

  • eli777
    eli777 Member Posts: 7 Member
    Answer ✓

    As it turns out I got Kontakt 7 working via kushview element.

Answers

  • LostInFoundation
    LostInFoundation Member Posts: 4,029 Expert
    edited June 2023

    Did you register their serials in Native Access? The ones you find in NI site under your account - “My products and serials”.

    If they appear under “Not registered” you have to add them in NA












  • eli777
    eli777 Member Posts: 7 Member

    I have all serials registered but there is no kontakt 7 player, just kontakt 7. I have a kontakt 6 player that doesn't play my kontakt 7 factory selection in MPC. Does Kontakt 7 player even exist at native instruments?

  • Monochrome
    Monochrome Member Posts: 1,065 Expert

    Kontakt 7 is the full version, whereas Kontakt 7 Player is the feature-limited version. The Player version won't show up if you own the full version since you don't need it anymore. Everything you have in the Player version is also available in the full version.

    Content made for Kontakt 7 won't work in Kontakt 6 - regardless of its variant (Player or full).

  • eli777
    eli777 Member Posts: 7 Member

    Thanks, womp seems like kontakt 7 doesn't work in MPC then. I was hoping I could try the player version of it to see if it would somehow work in MPC.

  • benitol
    benitol Member Posts: 2 Member

    You are right, it doesn't work. I have the full version of Kontakt 7 and only Kontakt 6 shows up in the MPC software. Native Instruments, is there a fix for this? Thanks.

  • eli777
    eli777 Member Posts: 7 Member

    Thanks for confirming Benitol. The only way I can use the kontakt 7 library is via komplete kontrol but that doesn't have the full features of kontakt 7.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,916 mod

    @benitol @eli777 Sorry for jumping in this thread so late after the party. I'm not familiar with the MPC software and I don't have it at hand to test. Does MPC 2.11 support VST3? Kontakt 7 being VST3 only, if the software does not support VST3, that could be the reason, or maybe it handles vst3 differently?

  • eli777
    eli777 Member Posts: 7 Member

    @Jeremy_NI Yes MPC 2.11 and up does support vst 3 and I am running other vst3 plugins but for some reason Kontakt 7 doesn't work.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,916 mod

    @eli777 Ok, so this MPC 2.11 software is for the hardware AKAI MPCs, right? Is it the same as the MPC Beat free software?

  • eli777
    eli777 Member Posts: 7 Member
    edited August 2023

    MPC 2.11+ is more advanced than mpc beats it works with hardware and runs as a standalone daw on windows. MPC beats is a lite version of MPC 2. I'm not sure if the lite version is vst 3 compatible but MPC 2 (the full software is). I'm doing a check on the vst3 plugins that work. I suspect there might be some kind of bridge plugin that can run vst3 plugins that don't work in it. So far Kontakt is the first one I've run into that doesn't work.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,916 mod

    I checked in MPC Beats, only VST is supported, not VST3. As I don't have a MPC Live, One or X (sadly!) I can't check the software. Have you tried contacting Akai on the topic?

  • eli777
    eli777 Member Posts: 7 Member
    Answer ✓

    As it turns out I got Kontakt 7 working via kushview element.

  • LostInFoundation
    LostInFoundation Member Posts: 4,029 Expert
    edited August 2023

    As far as I know, MPC softwares (all of them) don’t support VST3. You need to use a VST wrappers to use them.

    Probably the ones you think were working just have also a VST2 version installed in your computer and that’s what get loaded from MPC.

    In facts, I have Kontakt working on MPC, but if you check the version (clicking on NI banner), you can see that it is the VST2 one

    MPC 2 (not Beats) can be bought, no need to own an HW (even if it comes for free with them). In any case, as I said it is not supporting VST3. Akai doesn’t speak too much about not supporting them

Back To Top