Komplete Kontrol bug M1 Pro Monterey / Logic Pro X ?

PBC
PBC Member Posts: 7 Newcomer

Anyone else experiencing an issue with Komplete Kontrol in Logic Pro X on Mac M1 ? I'm running Logic Pro X in native mode and when I load up a project instruments are greyed out and not playing back in Komplete Kontrol ; I just get a blank interface with no sound. Happens without fail each time and the only way to avoid this is to use Kontakt 7 or go back to running Logic in Rosetta. Komplete Kontrol has been verified as compatible with M1 Apple Silicon but is obviously as buggy as an old bug from a bug store ๐Ÿ˜ฌ


Best Answer

  • Kymeia
    Kymeia Member Posts: 1,317 Guru
    Answer โœ“

    The keyboard issue is a Logic problem - it has no way to stop stealing keyboard focus from the plugin

Answers

  • JesterMgee
    JesterMgee Member Posts: 1,515 Expert
    edited May 5

    Yeah have something similar running some VST3 plugins in Ableton Live. Report it direct to NI, if you are on the Beta test program raise it in there too because it's common with many VST3 plugins making them unusable and at the moment the statement has been "we are not actively working on a solution". Sux for mac users but luckily i'm on Windows and just stay using VST2, tho it is a PITA

  • PBC
    PBC Member Posts: 7 Newcomer

    Thanks for your comments Jester - I'm going through all my projects and switching out Komplete Kontrol for Kontakt 7 so I can run Logic in native mode. The latest version of Komplete ( 2.9.1) on Mac OS only loads VST3 plugins , I never use to have this problem when it loaded AU or VST2 plugs so maybe its an issue with VST3 ?

  • Kymeia
    Kymeia Member Posts: 1,317 Guru
    edited May 5

    I don't think this is the same issue as the one in Live which was on windows. If they work in Rosetta then this is probably a 'migration' issue and I suspect what is happening is the Logic project expects Komplete Kontrol to be loading the VST2 version of Kontakt (were these made with Kontakt 5 or 6 perhaps?) but of course now there is only Kontakt 7 VST3 (which is Apple Silicon native) so you get this half opened project. Have your tried reloading the same instrument in Komplete Kontrol in native mode (which will open in Kontakt 7) then saving that as a Logic project and seeing if it reloads the correct version?

    The 'bug' here is that this is a nested set of things for Logic to recall - you have a host (Logic) opening another host (Komplete Kontrol) opening a plugin (Kontakt) opening specific patch from a library. It might be a lot to expect for Logic to also be able to recognise that Komplete Kontrol now needs to load the VST3 version of Kontakt (7) instead of what it expects to load. It might be 'Logic' but it's not that smart :)

  • Keith Cocker
    Keith Cocker Member Posts: 54 Helper

    I am having the same issue intermittently. Just another to add to the long line of "bugs" that NI introduced with their M1 version of KK. I'm not interested in what is going on "under the hood" - even if I could understand it!!. I just want this fixed so I can use my NI Keyboard, KK and my NKS compatible apps to make music - as a I could before KK 2.8.

  • PBC
    PBC Member Posts: 7 Newcomer

    Hi - thanks for your comments Kymeia .

    Running Logic in native and adding a Komplete instrument to a a new track does not make any difference ; when reloading I still get the blank greyed out window where the instrument interface should be. I also discovered another intermittent bug ; typing a search in the Komplete browser bar (sometimes) sends a keyboard command to Logic Pro . I inadvertently muted all my tracks when typing 'm' in the search bar . Komplete has more bugs than the Stasi ๐Ÿ˜ฌ

  • Kymeia
    Kymeia Member Posts: 1,317 Guru

    So can you use it as before using Rosetta 2?

  • PBC
    PBC Member Posts: 7 Newcomer

    Yes - Komplete works in Rosetta and reloads with the instrument playing back and visible. The problem only occurs in native mode.

  • Kymeia
    Kymeia Member Posts: 1,317 Guru

    Sorry that was a question for the other poster

  • Kymeia
    Kymeia Member Posts: 1,317 Guru
    Answer โœ“

    The keyboard issue is a Logic problem - it has no way to stop stealing keyboard focus from the plugin

  • Kymeia
    Kymeia Member Posts: 1,317 Guru
    edited May 5

    OK I just tried replicating this and can't but I don't have the same libraries so it's not perfect. However I have tried with several Kontakt 7 libraries in Komplete Kontrol in Logic, Native Mode, and it recalls them. Incidentally the image you posted is just what you see when Kontakt 7 is opened but without an instrument loaded (and if you go into Edit View you see the rack) so evidently the problem is about Logic not storing the loaded instrument in Komplete Kontrol for some reason - but it's doing it for me so there must be some other variable at work.

    Just as a test can you load something from one of the standard Kontakt libraries - say Factory library 2, in KK then see the project and see if that recalls as it does for me?

    I did ask if these projects were originally saved with an earlier (non native) version of Kontakt as I still think migration must be an issue if they load fine inRosetta.

  • PBC
    PBC Member Posts: 7 Newcomer

    Hi Kymeia - I created a new project and loaded three instances of Komplete Kontrol with one instrument from the Kontakt library and two other instruments from an NI library and a third party library. When reloading the only visible interface was the instrument from the Kontakt library. I tried this with other third party libraries and the same problem occurred. No midi/audio plugins were loaded in the channel strips or the master output ; so it can't be a lack of processor or RAM resources causing the problem. Interestingly the same bug now occurs in Rosetta as well ๐Ÿคจ. I'm not too phazed by this and will just use Kontakt 7 to load up my instruments until it's fixed.


  • Kymeia
    Kymeia Member Posts: 1,317 Guru
    edited May 6

    Ok thanks - so this is affecting (some) third party libraries but not Kontakt factory? Not surprising I guess

    Which ones? I am not a huge Kontakt user but have libraries by Soniccouture and Output I have been able to load OK - would help to narrow it down - now it is affecting Logic in Rosetta mode too we may be able to rule out this being a migration issue then

  • PBC
    PBC Member Posts: 7 Newcomer

    Hi - I don't have many third party libraries ( Vocalise, some Soundiron libraries and a freebie called Fruit Shaker) so I can't verify this. As for NI libraries, I don't have time to try them all but the same bug occurs after saving, closing and relaunching the project.

  • PBC
    PBC Member Posts: 7 Newcomer

    Hi - The latest version of Komplete 2.9.2 released yesterday seems to have fixed the problem - no more missing interface and audio playback is fine. ๐Ÿ™‚

  • Kymeia
    Kymeia Member Posts: 1,317 Guru

    Awesome!!!

Back To Top