S4Mk3 remix deck record button bug

Options
dankjuggler
dankjuggler Member Posts: 10 Member

When using Remix Decks on a S4MK3, and a sample is on Gate mode. after pressing the record button, the sample refuses to play at all unless i switch it to Latch mode. If i load the same remix deck on another deck, the Gate mode samples will play normally, but it can repeat if i press the record button. The only way to get it back to normal is to reset Traktor, which is not ideal.

Is there a workaround for this?

Tagged:

Best Answers

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,870 mod
    Answer ✓
    Options

    Here is a fix:

    Open the file "\Resources64\qml\CSI\S4MK3\S4MK3Samples.qml" in notepad++.

    Line 92+ says

    WiresGroup
    {
      enabled: !module.shift
    
      Wire { from: "%surface%.record"; to: TogglePropertyAdapter  { path: "app.traktor.decks." + deckIdx + ".remix.sequencer.rec.on" } }
      Wire { from: "%surface%.record"; to: SetPropertyAdapter     { path: "app.traktor.decks." + deckIdx + ".remix.sequencer.on"; value: true; output: false }}
    
      ...
    

    add the following line right above the WiresGroup (line 91)

    Wire { enabled: module.shift; from: "%surface%.record"; to: SetPropertyAdapter    { path: "app.traktor.decks." + deckIdx + ".remix.sequencer.on"; value: false; output: true}}
    


    Pressing Shift+Record will now disable the sequencer and solve your problem. 🦋

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,870 mod
    Answer ✓
    Options

    I just looked.

    Since he didn't put the commands in a seperate wires group, it should be sufficient to change this (line 220):

    Wire { enabled: !module.shift; from: "%surface%.record"; to: TogglePropertyAdapter { path: "app.traktor.decks." + deckIdx + ".remix.sequencer.rec.on" } }
    Wire { enabled: !module.shift; from: "%surface%.record"; to: SetPropertyAdapter    { path: "app.traktor.decks." + deckIdx + ".remix.sequencer.on"; value: true; output: false }}
    

    Into this:

    Wire { enabled: !module.shift; from: "%surface%.record"; to: TogglePropertyAdapter { path: "app.traktor.decks." + deckIdx + ".remix.sequencer.rec.on" } }
    Wire { enabled: !module.shift; from: "%surface%.record"; to: SetPropertyAdapter    { path: "app.traktor.decks." + deckIdx + ".remix.sequencer.on"; value: true; output: false }}
    Wire { enabled: module.shift; from: "%surface%.record"; to: SetPropertyAdapter    { path: "app.traktor.decks." + deckIdx + ".remix.sequencer.on"; value: false; output: true}}
    


    You will have to test, if there is any conflict with the pads modes while using a remix deck.

Answers

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,870 mod
    Answer ✓
    Options

    Here is a fix:

    Open the file "\Resources64\qml\CSI\S4MK3\S4MK3Samples.qml" in notepad++.

    Line 92+ says

    WiresGroup
    {
      enabled: !module.shift
    
      Wire { from: "%surface%.record"; to: TogglePropertyAdapter  { path: "app.traktor.decks." + deckIdx + ".remix.sequencer.rec.on" } }
      Wire { from: "%surface%.record"; to: SetPropertyAdapter     { path: "app.traktor.decks." + deckIdx + ".remix.sequencer.on"; value: true; output: false }}
    
      ...
    

    add the following line right above the WiresGroup (line 91)

    Wire { enabled: module.shift; from: "%surface%.record"; to: SetPropertyAdapter    { path: "app.traktor.decks." + deckIdx + ".remix.sequencer.on"; value: false; output: true}}
    


    Pressing Shift+Record will now disable the sequencer and solve your problem. 🦋

  • dankjuggler
    dankjuggler Member Posts: 10 Member
    Options
  • dankjuggler
    dankjuggler Member Posts: 10 Member
    Options

    Will this affect Joe Easton's mod in any way? @Sûlherokhh

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,870 mod
    Options

    AFAIK, Joe has modified the whole series of buttons around there for the many pad modes. The command would need to be inserted in a different place and probably in a different manner. I'll have a look in the next few days.

  • dankjuggler
    dankjuggler Member Posts: 10 Member
    Options

    I actually just tried your line of code now and it works even with Joe's mod. But im just worried something might break, am not a programmer lol.

    Its on line 220 on the qml file, but pressing Shift+rec also enables his beatjump feature.

    Would love to have your expertise over at the S4Mk3 discord server > https://discord.gg/3v3QCEwf

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,870 mod
    Answer ✓
    Options

    I just looked.

    Since he didn't put the commands in a seperate wires group, it should be sufficient to change this (line 220):

    Wire { enabled: !module.shift; from: "%surface%.record"; to: TogglePropertyAdapter { path: "app.traktor.decks." + deckIdx + ".remix.sequencer.rec.on" } }
    Wire { enabled: !module.shift; from: "%surface%.record"; to: SetPropertyAdapter    { path: "app.traktor.decks." + deckIdx + ".remix.sequencer.on"; value: true; output: false }}
    

    Into this:

    Wire { enabled: !module.shift; from: "%surface%.record"; to: TogglePropertyAdapter { path: "app.traktor.decks." + deckIdx + ".remix.sequencer.rec.on" } }
    Wire { enabled: !module.shift; from: "%surface%.record"; to: SetPropertyAdapter    { path: "app.traktor.decks." + deckIdx + ".remix.sequencer.on"; value: true; output: false }}
    Wire { enabled: module.shift; from: "%surface%.record"; to: SetPropertyAdapter    { path: "app.traktor.decks." + deckIdx + ".remix.sequencer.on"; value: false; output: true}}
    


    You will have to test, if there is any conflict with the pads modes while using a remix deck.

  • dankjuggler
    dankjuggler Member Posts: 10 Member
    Options

    thanks for this! yes there is a conflict cause it enables his beatjump feature, but only appears on the screen, i can just exit it after.

    thanks for doing NI's job

Back To Top