Kontrol is empty when I load a previous session I was working on

joseluisrevelo
joseluisrevelo Member Posts: 22 Member
edited May 2 in Komplete Kontrol

Hi all. Have you seen something like this? Platform is Cubase 12. Mac M1. Monterey.

I have full disk access enabled to everything NI and Cubase.

The sounds are there, I can load them all manually. So it's not that it's losing access to the Komplete libraries.

Any ideas are greatly appreciated!



Best Answer

Answers

  • JesterMgee
    JesterMgee Member Posts: 2,274 Expert
    edited April 29

    That looks similar to an issue I see on Windows where loading some VST3 instruments just does not show the GUI in KK. It is something NI know about, I ahve submitted several tickets as it makes VST3 unusable for much at the moment and rather annoyed for the amount of Beta testing I do basically be told they are not activelly working oon this issue at the moment.

    Issue in my case is the problem affects 3rd party plugins and not NI plugins, so their bean counters would probably say "Meh, not our problem to deal with..." but since I see your Kontakt is loaded, just the interface is not if it is the same related issue would be worth submitting a ticket for a bug and maybe they will take it more serious.

  • Kymeia
    Kymeia Member Posts: 2,731 Expert
    edited April 29

    This is on Mac though and I don't think it has been a problem on Macs - or with Kontakt - or in Cubase (more Live) so I think maybe this one has a different cause? I saw this graphics resource related issue when I tried installing my Kontakt libraries using Native Access 1 on M1Max - they only showed all resources when I used Native Access 2

  • joseluisrevelo
    joseluisrevelo Member Posts: 22 Member

    Hi. No, the issue is not a GUI issue. The instruments all load fine.

    It's just that I save a session and when I re-open it later Kontrol is empty (meaning, it has not loaded the instruments I had saved in the session).

    I have to then load everything again manually.

  • JesterMgee
    JesterMgee Member Posts: 2,274 Expert

    I've had some users report the same issue outside of Live even on mac and I ahve also seen the issue with fome GForce plugins in standalone KK, not in Live but an update to their plugins fixed the issue so seems it is an issue that can affect KK in other cases.

    Guess I am confused by the fact your screenshot shows Kontakt as loaded but there is no GUI displayed so that seems to suggest it is loading the instance, but not correct.

    If it was "empty" on reload then nothing would display in the top ribbon

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,679 mod

    @joseluisrevelo I see you submitted a request a few days ago. One of my colleagues should get back to you soon. They will probably need some private data (support tool, Cubase project,etc...)

  • joseluisrevelo
    joseluisrevelo Member Posts: 22 Member

    Thank you!

  • Nitrovicz
    Nitrovicz Member Posts: 2 Newcomer

    Hello,

    I also had the same problem, but it was with Ableton Live on Mac for me. I was looking for an answer on the forum, and didn't find anything.

    While waiting I tried several things, and I think I've find out. In Komplete Kontrol, I went to the "Edit" and "Preferences". In Plug-Ins sections, "Always Use Latest Version of NI Plug-Ins" was disabled, so I enabled this and Rescan, and it seems the problem is solved now.

    Hope this will help.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,679 mod
    Answer ✓

    @joseluisreveloThis bug has been filed and is being looked into: KT-8031

  • Sufox
    Sufox Member Posts: 6 Newcomer

    Thanks for letting us know ... Does this mean that after you switched ON "Always use latest version of NI-Plugins" you did not resave the project but just recalled the formerly broken project and from then on it loaded just fine with all the content that was missing before ?

    I am asking because this seems not to fix all of the projects for me, which had the same issue. It rather seems like the "Always use latest version of NI-plugins" must be ON before loading any Kontakt Content from the KK browser and save a project with KK and this loaded Kontakt content. Only then a recall of such a project would be fine, even if you would later switch "Always use latest version of NI-plugins" off again.

    Hope you get the point I am making. If someone would want to fix a project, just switching "Always use latest version of NI-plugins" ON might not help, if the project is not resaved after manually reloading all Kontakt Content in the KK instances of that project.

    thanks in advance for clarifying

    cheers

  • Nitrovicz
    Nitrovicz Member Posts: 2 Newcomer

    @Sufox , yeah you're right, if you have save the project with the bug on KK, you won't be able to get your plugin back normally.

    Actually, I don't know if there is a way to recall the plugin saved with a bug.

    On my side, I only had one project with that bug, I've noticed really fast there was a problem, so I was able to enabled "Always use latest version of NI-plugins" and save my project without any bug.

    Hope it clarifies.

  • joseluisrevelo
    joseluisrevelo Member Posts: 22 Member

    Well, "Always Use Latest Version of NI Plug-Ins" did not work for me.

    In fact, after enabling it and trying to load something it crashed Cubase.


    As a matter of fact I remember being advised to disable it last year. It had to do with Rosetta and the M1.


    Thanks!

Back To Top