Kontakt 7 screen flickering in Ableton Live

Toff CM
Toff CM Member Posts: 3 Newcomer

Hi!

My screen is flickering when Kontakt 7 plugin window is in focus.

The flickering happens when an instrument is loaded.

It only affects what's in the background, not the content of the plugin window itself.

I've tried with AUV2 and VST3 but the problem occurs in both instances.

Does anyone have a similar issue? I don't have this issue with other plugins.

Best Answer

  • jcoxy12
    jcoxy12 Member Posts: 6 Member
    Answer ✓

    @Jeremy_NI @Toff CM I just solved it for me by completely disabling g-sync on my monitor. I guess Kontakt 7 doesn't use abletons Nvidia control panel settings when ran as a VST. I have Ableton and Kontakt set to run without G-sync but I guess it doesn't take in ableton as a VST anymore like it used to

«13

Answers

  • LostInFoundation
    LostInFoundation Member Posts: 3,959 Expert

    I have something similar also in standalone NI programs when the WASAPI shared mode is selected in the audio preferences instead of the exclusive mode (probably something to do with audio interface interferences between programs).

    I don’t know if this is the case, but worth a try (in your case in the audio preferences in Ableton, since Kontakt as a plugin uses the settings from the host)

  • Toff CM
    Toff CM Member Posts: 3 Newcomer

    Hi!

    Thanks for your reply. I don't have the WASAPI option.

    I think it's just for Windows and I am using a MacBook Pro.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod
    edited May 2023

    @Toff CM You have a M1 Mac, right? With what graphic card driver? Are you using an external monitor? IS Running running in Rosetta or in Arm mode? Is the behaviour the same in Rosetta and in ARM mode?

  • sh3rw00d99
    sh3rw00d99 Member Posts: 3 Member

    Hi

    , I have the same problem with Kontakt 7 in Ableton on windows 10

    Attached video

  • jcoxy12
    jcoxy12 Member Posts: 6 Member

    Same issue for me as of today just started happening. Makes me think its something with my gpu driver

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod
    edited May 2023

    @sh3rw00d99 @jcoxy12 More details would be helpful. What graphic card do you have? Is the driver up to date? What are your display settings? Is it happening also in Kontakt in standalone?

  • Toff CM
    Toff CM Member Posts: 3 Newcomer

    @Jeremy_NI,

    I have a Mac M1 Pro model 2021 16 inches with built-in Liquid Retina XDR Display. I didn't have this problem when using a monitor.

    I have tried with Rosetta Compatibility turned on and the issue was the same but I don't have this problem today... Not sure why. The version of Ableton is still the same "11.2.11".

    I've boosted the MAC performance to 100% when unplugged so maybe that has something to do with the issue being solved....

  • jcoxy12
    jcoxy12 Member Posts: 6 Member

    @Jeremy_NI Geforce RTX 3060. It started happening after the latest driver update so I rolled back to an earlier one but is still happening. Doesn't happen in standalone mode anymore, although it was when I made the original comment

  • jcoxy12
    jcoxy12 Member Posts: 6 Member
    Answer ✓

    @Jeremy_NI @Toff CM I just solved it for me by completely disabling g-sync on my monitor. I guess Kontakt 7 doesn't use abletons Nvidia control panel settings when ran as a VST. I have Ableton and Kontakt set to run without G-sync but I guess it doesn't take in ableton as a VST anymore like it used to

  • LPKEYS
    LPKEYS Member Posts: 4 Newcomer

    It's happening for me in Logic, too. Any fixes for that? Flickers on my old LG UHD monitor and my Apple 5K display. This is something new as of this week.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @LPKEYS What graphic card do you have? What kind of Mac do you have?

  • pbthrash
    pbthrash Member Posts: 32 Member

    Do not look for problems on users' side. Just fix a bug in Kontakt 7 related to G-Sync.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    The bug has been filed under this refernce: KT-8124. There is no date for a fix yet. In the meantime please either disable G-Sync, you should be able to do this per app.

  • d23
    d23 Member Posts: 15 Newcomer

    +1 Just got NI Ultimate and the screen flicker on kontakt 7 is pretty crazy.

  • d23
    d23 Member Posts: 15 Newcomer
    edited May 2023

    Disabling G-Sync on my DAW makes it better but does not appear to fully solve the problem.

    Edit: actually, I'm not sure it helped much at all. It seems to go back and forth.

Back To Top