Native Access - failed to download latest update

Options
Dr Foo
Dr Foo Member Posts: 2 Newcomer

Hi all, I am on a Mac OS High Sierra and recently had a harddrive replaced so all my NI software is now asking to be re-registered via Native Access. When I try to do so via Native Access, it keeps saying failed to download the latest update, whether it is for Traktor, Kontakt etc. I read that we need to download Native Access 2, but it is not compatible with OS High Sierra.

In order to get my NI software to work again, do I need to upgrade my OS to get Native Access 2, or is there a way to fix this bug with my current Native Access?

Thanks in advance!

Tagged:

Best Answer

  • Dr Foo
    Dr Foo Member Posts: 2 Newcomer
    Answer ✓
    Options

    Thanks for the replies! I found an installer for Native Access 1, and reinstalled it. Now it works. Seems like Mac OS High Sierra can't do Native Access 2 yea, but at time same time I am wary of upgrading my OS as I fear some apps I am using (Traktor etc) will glitch

Answers

  • Sasquai
    Sasquai Member Posts: 9 Member
    Options

    Do you mean Native Access 3?? Cause we're on version 3.2. I'd hope by this point version 2 can run on any OS...

  • tedblight
    tedblight Member Posts: 4 Member
    Options

    Hi, I found a work around on Mac OS.

    I noticed that downloads didn't fail if my computer was active. ie I was doing something on it.

    So I downloaded a free app called Amphetamine from the Mac App Store. This keeps your desktop alive.

    Every single download on Native Access downloaded and install after that.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,619 mod
    edited April 2023
    Options

    @Dr Foo It might be time to update to 10.15, Support was dropped for Native Access 2 on 10.14.

    Native Access 1 is legacy, meaning it's not developed anymore and it can be that new activation mechanisms no longer work on this legacy system. Maybe my colleagues can provide some installers, you can get in touch here: http://bit.ly/NIsupport_install

  • Dr Foo
    Dr Foo Member Posts: 2 Newcomer
    Answer ✓
    Options

    Thanks for the replies! I found an installer for Native Access 1, and reinstalled it. Now it works. Seems like Mac OS High Sierra can't do Native Access 2 yea, but at time same time I am wary of upgrading my OS as I fear some apps I am using (Traktor etc) will glitch

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,619 mod
    Options

    @Dr Foo Thanks for the update. I should have provided the link for the old Native Access installers. I'll share it now, in case other users are faced with the same issue: Native Access Legacy Installers for Older Operating Systems

  • Abel1321
    Abel1321 Member Posts: 1 Newcomer
    Options

    Salve, qualcuno mi sa dire cosa significa che nel mio account manca il prodotto bal per questo seriale? Come posso risolvere. Grazie

  • mykejb
    mykejb Moderator Posts: 1,384 mod
    Options

    It sounds like you have a serial number for a product upgrade like from Komplete 13 to Komplete 14 but you don't own Komplete 13 so the upgrade won't work. What is the serial number for ?

    -- Mike

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,619 mod
    edited December 2023
    Options

    @Abel1321 As you may have noticed when you typed this message and while navigating this forum, it is in English only. It is also mentioned in our code of conduct. Please use DeepL, Google Translate or any other online translator.

    If you bought the wrong update or upgrade please get in touch with my colleagues here: https://bit.ly/NISupport_OP

Back To Top