NTKDaemon.exe constantly crashed in Native Access 3.2.1

Harti Member Posts: 1 Newcomer
edited April 5 in Native Access


I just updated to version 3.2.1. I have three PCs and on two of them NTKDaemon.exe constantly crashed on start of Windows and every time Native Access is installing again the "dependencies" or whatever. A very bad user experience & one can see the "massacre" in the reliability monitor.

I tried everything - from new installation to reinstall/repair runtime stuff etc. Nothing helped. At the end I downgraded to Native Access 1 and deinstalled NTKDaemon.exe and everything works fine. So what is the extremely bad coded NTKDaemon.exe good for? What does it do?🐞 I have no clue.

Btw: I'm only using Massive 1 & Kontakt 6 in my main DAW Reason 12.



  • Gee_Flat
    Gee_Flat Member Posts: 906 Guru
    edited April 1

    3.2.2 was released in the last 48 hrs, so don't know why you didn't get it.

    I run W10 and NA 1.14.1, and downloaded K7 Player no problem, but from what I gather certain product updates won't be available or aren't at present for NA 1.


  • Kaiwan_NI
    Kaiwan_NI Administrator Posts: 2,437 admin

    Hi @Harti glad to hear downgrading to NA1 resolved the issue for the time being. There should be an update that addresses this error in the future.

    As to what NTKDaemon actually does, our product manager explained briefly in his article here:

    Dev Talks: Why We Transformed Native Access

  • Elfzim
    Elfzim Member Posts: 3 Newcomer

    Suddenly my system is BRICKED in the middle of multiple soundtracks.

    using event manager - yep NTKDaemon.exe is the cause.

    I tried installing the old version idk how the above did it as mine IMMEDIATELY without consent updated and my computer turned off.

    try to install the new Native Access and yep trapped in “dependencies taking a long time” so no Kontakt and that means thousands of dollars of libraries I REALLY NEED TO ACCESS are unusable. BBC orchestra pro-AOK.

    anything requiring kontakt (everything) isn’t an option



  • Elfzim
    Elfzim Member Posts: 3 Newcomer
    edited October 27

    And yes I’ve done ALL the obvious

    Things I already tried without any luck:

    - Uninstall and reinstall 

    - Try other versions (incl. v2.12 by r2r and 2.11 by p2p)

    - close any firewalls and antivirus

    - Uninstall only NTKDaemon

    - Investigate on Event Viewer what Windows could tell me and that pointed me in the direction of ucrtbase.dll which is on system32

    - Run the System File Checker


    The legitimate fact is THE UPDATE BY NI HAS BRICKED MY COMPUTER AND I WILL REALLY APPRECIATE A FIX (OR A REFUND ON THE SAMPLE LIBRARIES:software/ work time/NI HAS CUT ME OFF FROM - sorry but, seriously “whoops sorry we unilaterally cut you off from your work station and software by forcing a malformed update on you but we’re just going to sit and watch?!”-

    (&yes event logs show it was an NI update very clearly. Hardware is over specs and 6 months old-the lost libraries hardware software and time could come to many thousands,)

    sooooooo. Pretty please help undo this mistake?

    any USERS who have found a fix PLEASE tell me I’ll try to do something nice for you!

  • Elfzim
    Elfzim Member Posts: 3 Newcomer

    (Just an idea but if you cause work stoppage under deadlines to a customer under no fault of their own, who has given you lots of money- MAYYYYYYYYYYYBE show you have a spec of respect for the artists using your products and paying your salaries.

    you know just a crazy idea of following best practices or at least DOING SOMETHING)


Back To Top