S61 Keyboard controls do not light up or work

Options
nativebonehead
nativebonehead Member Posts: 14 Member

I was wondering if anybody else was experiencing this type of problem. My S61 keyboard controller works fine as a controller but all of the controll switches/ lights are out. It has been doing this on and off and I thought that it may be some type of setting in the DAW. The displays are on fine. Does anybody know what I am doing wrong or is there a way to reset the keyboard. Thanks.

Best Answer

  • Brad Yost
    Brad Yost Member Posts: 354 Pro
    Answer ✓
    Options

    Try to change the Device preference that you have set as "Komplete Kontrol - EXT-1" to the "Komplete Kontrol DAW" setting and then restart the KK GUI in Standalone.

    I think you (and your DAW) are confusing the External MIDI ports (5 pin DIN) for what should be the keyboard internal hardware interface.

«1

Answers

  • Brad Yost
    Brad Yost Member Posts: 354 Pro
    edited March 2023
    Options

    First; use a different USB cable, try a different USB port (not on a hub), make sure that any auxiliary PSU is working correctly.

    Observe in the Komplete Kontrol GUI if making changes to buttons/knobs on the HW reflect changes in the SW.

    Make sure that all three instrument drivers are loading and available [KK-1, KK-Daw, KK-Ext].

    Then, if no change, you may have faulty hardware, and should directly contact support via the NI website.

  • nativebonehead
    nativebonehead Member Posts: 14 Member
    Options

    Oh thank you so much. Yes I have tried a new cable and hooking it up right to the computer but no good so far. I will work on those other suggestions you have given me. Appreciate it.

  • Julesman
    Julesman Member Posts: 6 Member
    Options

    I'm on Windows and I had this exact issue with my S88 MKII.

    Do you see "Komplete Control DAW -1" listed in either your DAW or in Komplete Kontrol software under preferences->Midi?. In Komplete Kontrol you should see the highlighted entry.

    If you don't see this, and you're running on Windows, then you may need to re-install the BOME driver. Head to https://www.bome.com/products/bmidi and download and install the "BMIDI 2.1.0.44 Installer" file listed as a download at the bottom of that page.

  • nativebonehead
    nativebonehead Member Posts: 14 Member
    Options

    Thank you but I don’t see a preferences. I use Studio One and am in Windows. But I don’t see what you are talking about and that may be the problem I am experiencing. Below is what I am seeing. Thanks for y’all’s help.

    I don’t think it sees the controller. And I have the M32 that I plugged in and it does the same thing


  • nativebonehead
    nativebonehead Member Posts: 14 Member
    Options

    So sorry. Yes I found that Edit-preferences-midi and the Komplete Kontrol DAW - 1 is not checked. and this is after the download you recommended. The two boxes that are checked are Komplete Kontrol - 1 and Komplete Kontrol EXT-1.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,619 mod
    Options
  • nativebonehead
    nativebonehead Member Posts: 14 Member
    Options

    Yes I have still the keyboard knobs don’t work or light up. Thank you.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,619 mod
    Options

    @nativebonehead Also in standalone? Can you send screenshots of your MIDI input settings in Komplete Kontrol in standalone?

    The issue also happens when in Komplete Kontrol, right? Can you do a short video, zip it and upload it here?

  • Brad Yost
    Brad Yost Member Posts: 354 Pro
    Answer ✓
    Options

    Try to change the Device preference that you have set as "Komplete Kontrol - EXT-1" to the "Komplete Kontrol DAW" setting and then restart the KK GUI in Standalone.

    I think you (and your DAW) are confusing the External MIDI ports (5 pin DIN) for what should be the keyboard internal hardware interface.

  • nativebonehead
    nativebonehead Member Posts: 14 Member
    edited April 2023
    Options

    Thanks for your help. But this did not work either. The controller works as a keyboard but the lights and opther controls other than the keyboard lights do not. But I think that you must be right in some way as Komplete Kontrol does not appear to see the controller the right way. But as soon as I plug it in it sets up its own midi as KK-1 and it has export to KK-DAW. Also when I set the controller to KK-DAW the keyboard does not work either. Also in stand alone mode it will not let me change input to KK-DAW se pics. Any other ideas.


  • LostInFoundation
    LostInFoundation Member Posts: 4,320 Expert
    Options

    “Also in stand alone mode it will not let me change input to KK-DAW” means you can not select it? Because from your new pictures I see it still is not selected under input

  • nativebonehead
    nativebonehead Member Posts: 14 Member
    Options

    Oh thank you for your patience. Yes the problem is that when I try to check that box it will not let me check it. This happens really no matter what configuration I use for external device setup in studio one. See pics below thanks so much. I think I must be doing something wrong though.


  • LostInFoundation
    LostInFoundation Member Posts: 4,320 Expert
    Options

    These are my settings in Studio One. Do you see any difference?


  • nativebonehead
    nativebonehead Member Posts: 14 Member
    edited April 2023
    Options

    Yes I see. I think I’ve got mine configured correctly now after making a few changes see pic below. But still not working. The DAW box is checked now though in the stand alone mode!. Thanks.


Back To Top