No sound in Kontakt6 Player while stand-alone, chnl output config not working.

Down_the_Rabbit_Hole
Down_the_Rabbit_Hole Member Posts: 9 Member
edited February 2022 in Kontakt

Hi and thanks in advance.

I went through the support article "Configuring the Audio Settings in Kontakt".

In Options/Audio the device is correctly set to my ASIO driver and status: RUNNING.

Instrument output to St.1

When I click on the channel strip to open Channel Output Configuration Menu it indicates physical outputs Digital Audio (s/pdif). Clicking on that, I get the popup window with no other options other than 'not connected'. My ASIO driver is not showing up, despite the audio settings showing 'running'. This where I'm stuck! Thanks if you can help.

Ps... It all works fine within my DAW (Cubase). Problem is stand-alone only.

Midi input is working fine and the instrument channel strip shows sound output.

My ASIO driver points to Speakers, which are making Windows sounds just fine.

Tagged:

Best Answer

  • Down_the_Rabbit_Hole
    Down_the_Rabbit_Hole Member Posts: 9 Member
    Answer ✓

    Resolved! For those who have a similar issue, NI service guided me through running a few utilities to resolve a few file corruption issues (that I didn't know existed), and fully update my Windows OS and drivers (which apparently were not current). Then switching to WASAPI(Exclusive mode) rather than ASIO allowed me to get sound with impressively low latency. Thank to NI Service! (That's real, not sarcastic.)

Answers

  • Blindeddie
    Blindeddie Member Posts: 1,559 Expert

    in the output section did you try clicking "Presets/Batch Configuration" and the selecting "Reset Output Section"? If that does not work you may have to configure the outputs manually, by clicking "+" next to outputs, enter the "Quantity" of outputs you want, whether they are stereo ("Number of channels" = 2) or Mono ("Number of channels" = 1), select the first soundcard output from the "Souncard/Host Output" dropdown. and select "Delete Existing Channels" then click OK. once you get sound, you can save it as default for "Standalone" under "Presets/Batch Configuration"


    See if that works...

  • Down_the_Rabbit_Hole
    Down_the_Rabbit_Hole Member Posts: 9 Member

    Thanks, Blindeddie.

    Unfortunately, no luck.

    In the manual config, the only options in the dropdown for Soundcard/Host remains Digital Audio. It's as if it can't see any other sound output drivers.

    Also, I downloaded and installed a Komplete ASIO driver that I found somewhere on the support pages. It appears on the list on the Cubase Studio Setup screen, but nowhere else is it an option. So that's not it.

    Btw, same problem if I try to run Komplete Kontrol app as a standalone.


  • Down_the_Rabbit_Hole
    Down_the_Rabbit_Hole Member Posts: 9 Member

    More details...

    I just noticed in Kontakt standalone that under options/audio/ it has the ASIO device as "Generic Low Latency ASIO", whereas it should be ASIO DirectX Full Duplex Driver, as is my default in Cubase, and my system in general. On this dropdown, the DirectX driver is not on the list of choices.

    I tried to switch it to the Komplete ASIO driver and got this error message the following error message. This had not happened on previous attempts. Regardless, after closing and restarting Kontact it was selected. But resetting outputs and trying to manually replace existing ones now only gave me options of "output1" and "output2" for the driver/host. Still no sound.

    Yes, my audio is full duplex. 😒

  • Blindeddie
    Blindeddie Member Posts: 1,559 Expert
    edited February 2022

    what is your audio interface?


    Edit: I think the problem might be the "Asio Direct FD driver" is there a specific reason you are using that driver?

    And just an FYI, Kontakt in Standalone you can only assign as many audio outputs as your interface has... so if there are only 2 outs (Like the KA2 which I suspect you might have) that's all you can assign. When Using Kontakt as a VST in a Host (Cubase in your Case), you should be able to create up to 32 stereo channels and those channels will be available to select in Cubase!

  • Kaiwan_NI
    Kaiwan_NI Administrator Posts: 2,525 admin

    Hey @Down_the_Rabbit_Hole did you get it to work with WASAPI in Komplete Kontrol's audio settings?

  • Down_the_Rabbit_Hole
    Down_the_Rabbit_Hole Member Posts: 9 Member

    More details...

    I just noticed in Kontakt standalone that under options/audio/ it has the ASIO device as "Generic Low Latency ASIO", whereas it should be ASIO DirectX Full Duplex Driver, as is my default in Cubase, and my system in general. On this dropdown, the DirectX driver is not on the list of choices.

    I tried to switch it to the Komplete ASIO driver and got this error message the following error message. This had not happened on previous attempts. Regardless, after closing and restarting Kontact it was selected. But resetting outputs and trying to manually replace existing ones now only gave me options of "output1" and "output2" for the driver/host. Still no sound.

    Yes, my audio is full duplex. 😒

  • Down_the_Rabbit_Hole
    Down_the_Rabbit_Hole Member Posts: 9 Member
    Answer ✓

    Resolved! For those who have a similar issue, NI service guided me through running a few utilities to resolve a few file corruption issues (that I didn't know existed), and fully update my Windows OS and drivers (which apparently were not current). Then switching to WASAPI(Exclusive mode) rather than ASIO allowed me to get sound with impressively low latency. Thank to NI Service! (That's real, not sarcastic.)

  • DIGutierrez
    DIGutierrez Member Posts: 1 Newcomer

    I believe I may have a similar issue. Do you recall the utilities that were used?

Back To Top