Sounds Stop With Multiple Instances of Komplete Kontrol in FL Studio

oscarg1520
oscarg1520 Member Posts: 2 Member
edited April 2023 in Komplete Kontrol

DAW: FL 21.0.2

Hardware: Mac Mini (2018) / 3.2GHz 6-Core Intel I7

Hey everyone, so I use the Komplete Kontrol VST to play my Komplete Bundle sounds banks (40s OVO Drums, Glaze, etc). I was missing many missing banks so i finally decided to fix it and did the fix where you delete the komplete.db3 file and the favorite.db3 file. It fixed my issue where I have all my missing banks. Now, when I play one bank, I have no issue. But, when I open up a second instance of Komplete Kontrol, the sounds no longer play for either instance. The sounds for other VSTs continue to play so it is just Komplete Kontrol VST where the sound doesn't play anymore. Any ideas of what it could be?

Best Answer

  • swilch
    swilch Member Posts: 2 Member
    Answer ✓

    Found that turning off 'Allow threaded processing' on Komplete Kontrol solves this issue - Mac M1 with FL

Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod

    Can you open Komplete Kontrol and Kontakt in standalone and choose a coreaudio sound output? Is everything functional here? Then try to reproduce the issue in FL Studio again.

    Also make sure to give Full Disk Access to FL Studio and Komplete Kontrol: How to Enable Full Disk Access on macOS

  • oscarg1520
    oscarg1520 Member Posts: 2 Member

    Standalone, everything is operational. I went back into FL Studio and the issue persists. I have given Full Disk Access as well. I'm recreating the issue on a new project and now when I open up a second instance of Komplete Kontrol, it basically is playing the notes in the piano roll, but it's cutting out very quickly instead of playing the full note. It sounds like a quick blip sound. But, if I open up a different up a different VST like Analog Labs, that VST works normally. It's just the Komplete Kontrol VST being affected by this.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod

    @oscarg1520 SO sorry, I lost track of this thread and did not see your last comment. Have you been able to fix this issue or do you still need help?

  • Mkohut
    Mkohut Member Posts: 2 Newcomer

    I am also having this same exact issue. Has this been solved? I am running MAC OS with the M1 chip and have also added full disk access.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod

    @Mkohut Is it also in FL Studio? Have you checked this setting?


  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod

    @Mkohut DId that help or you still need assistance?

  • swilch
    swilch Member Posts: 2 Member

    Hi @Jeremy_NI , I've got the same issue here and need assistance. Having fixed buffer sizes did not solve the issue.

  • swilch
    swilch Member Posts: 2 Member
    Answer ✓

    Found that turning off 'Allow threaded processing' on Komplete Kontrol solves this issue - Mac M1 with FL

Back To Top