Komplete Kontrol 88 mk2 unusable in Logic Pro x

Mgw
Mgw Member Posts: 8 Newcomer
edited March 7 in Komplete Kontrol

Hi can anyone help. For some reason when I load Komplete kontrol in Logic Pro any midi instruments will not play properly. Notes won’t play and even if you get them recorded they won’t play back properly. I’ve done countless resets within logic and re-download Komplete Kontrol but nothing works, it has now become completely unusable in Logic. The standalone works fine. Help!!!

Cheers

Mark

Tagged:

Best Answer

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,113 mod
    Answer ✓

    Hey @Mgw I was out of office, sorry! I just created a ticket and contacted you by email, we'll need to have a deeper look in your system.

Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,113 mod

    @Mgw Could you give us more details? What instruments are you loading? NI instruments? Which ones exactly? Other plug-ins? What is your operating system? Is your Mac M1 or Intel? Would you be able to make a short video displaying the issue and share it here?

  • Mgw
    Mgw Member Posts: 8 Newcomer

    Hi,

    thanks for your reply. Yes I can get together the information you requested and I’ll make a short video if I can.cheers

    mark

  • Mgw
    Mgw Member Posts: 8 Newcomer

    Hi Jeremy,

    I've been trying to upload a QuickTime recording of what's happening but it won't upload. Basically as you try to play any instruments in Komplete Kontrol third party or NI the notes drop out or won't play, either when recording or playback. I've tried resetting key commands changing recording settings but nothing works. The system I'm using is iMac 3.5 ghz processor quad core intel i5, I have 2 x 4 gb and 1x16 gb memory. All other VSt instruments play just fine. CPU is around half and under when under load.

    I will try and send a clip,

    kind regards

    Mark

  • Mgw
    Mgw Member Posts: 8 Newcomer

    Hi Jeremy,

    here's the what's happening.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,113 mod

    @Mgw Do you have the same issues if you load Kontakt instead of Komplete Kontrol ?

    Make sure that Logic, Komplete Kontrol and Kontakt all have Full DIsk Access: How to Enable Full Disk Access on macOS

    Where are your Kontakt libraries installed? On an external hard drive? What format is that drive? It should be MacOs Journaled or APFS, as explained in this article: Notes on Hard Drive Formats on Mac Computers

    Can you post a screenshot of your audio settings in Logic? Preferences -> Audio -> Devices and Preferences -> Audio -> General

    Waht is the sample frequency chosen for your projects in Logic?

  • Mgw
    Mgw Member Posts: 8 Newcomer

    Hi Jeremy,

    I have no problems with Kontakt. Komplete Kontrol and Kontakt have disk permissions. All Libraries are on the main HD. Sample frequency 44.1 kHz.


  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,113 mod

    @Mgw I'm so sorry, I lost track of this post and did not see your last answer. Are you still struggling with this?

  • Mgw
    Mgw Member Posts: 8 Newcomer

    Hi Jeremy no problem I think it may have been resolved with the recent updates but I haven’t had time to check it out fully. I’ll check it out and let you know. Cheers. Mark

  • Mgw
    Mgw Member Posts: 8 Newcomer

    Hi Jeremy I’ve tried Komplete Kontrol in Logic and it’s exactly the same, nothing has changed since updating to latest updates. What now?

    Cheers

    Mark
  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,113 mod
    Answer ✓

    Hey @Mgw I was out of office, sorry! I just created a ticket and contacted you by email, we'll need to have a deeper look in your system.

  • JMVE
    JMVE Member Posts: 2 Newcomer
    edited May 6

    Hi @Jeremy_NI I am having the exact same issue as @Mgw .

    When I try to play any instrument in Komplete Kontrol using my S49 controller notes do not play correctly at all. Only short jabs maybe a 1/16th note. I am using KK v2.9.2 and Logic Pro X v10.7.7 and Mac OSX 13.3.1

    No instruments play correctly in KK. They work in Kontakt 5 but that is it.

    I've updated everything via Native Access and no improvement.

  • nightjar
    nightjar Member Posts: 849 Guru

    KK is in Kritikal Kondition

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,113 mod

    @JMVE What are your settings for Logic (general & audio)? Is it only happening when there is a certain amount of Komplete Kontrol instances or one is enough?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,113 mod

    @nightjar If you have performance issues with Logic and Komplete Kontrol please get in touch with our support agents. It seems you din't contact them about your issues. http://bit.ly/NIsupport_KKontrol

  • Kymeia
    Kymeia Member Posts: 2,026 Expert

    Is this just limited to Kontakt instruments or the same with plugins?

Back To Top