CPU at MAX with Kontakt 7

Tristan2b
Tristan2b Member Posts: 4 Newcomer
edited February 2023 in Kontakt

Hi all ! Thank you Jedi Master for reading and investigating the MAO mysteries that currently concern me...

 

My kontakt's CPU jumps to 100% for no apparent reason (screenshot)

As you can see, I only use 4 instruments.

 

I purged the samples and minimized all kontakt display and usability features.

 

I have tried all possible settings:

. Change of drivers… Asio or Wasapi… Shared or exclusive…

. Buffers at all sizes… (including kontakt's internal buffer)

. All sample rates… and in 16, 24, 32, 64 bits… (in stress)

. Trying multiple sound cards (in desperation)

 

Nothing moves. Cubase plays jerky because of kontakt's CPU which is at 100% for just a few notes played. All that I find on the web are very practical tutorials but which strangely have no effect on my case.

 

Setup:

Kontakt 7 used by Cubase 12 on Core i7 and win10-64bits. Alesis Multimix 8 sound card.

I specify that my libraries are on an internal hard disk different from the internal hard disk where kontakt and cubase are. Of course, it's SSD.

 

Incidentally, I noticed that kontakt causes huge latency issues when recording audio. Problems I don't have when using audio in cubase without kontakt. Ugly !

 

May the force be with you !



Best Answer

  • Tristan2b
    Tristan2b Member Posts: 4 Newcomer
    edited March 2023 Answer ✓

    Problem solved !

    This is a good part of the solution to the restricted processor problem that concerns me…

    In the ThrottleStop software, the BD PROCHOT box is deactivated and the processor is unlocked from 0.78 to 3.60Ghz. The manipulation is to be repeated each time we reboot the computer until I have found the real solution, but it can already help me out. Once the option was unchecked, my fan started immediately. ThrottleStop with its BD PROCHOT option to uncheck is surely a very useful solution for a person who sees their processor restricted for an unknown reason.

    I will create another topic about this abnormal CPU throttling. Maybe I left my computer running a little too long while it was working, and something went into safe mode somewhere. I think my BIOS will have an explanation with me in the coming days.

Answers

  • Intersolar
    Intersolar Member Posts: 6 Member

    it looks like Kontakt 7 has pretty severe problems with the CPU. I started a similar post a few days ago. For me, one note of a multi from Teletone Audio is enough to bring my Mac M1 Max to its knees! If I take 2 instruments like Pharlight and Straylight I have over 60% CPU usage. Working with Kontakt is not possible. Initially I thought it's my Mac Studio which causes the problems, but after reading your post It's pretty obvious that this is a programming issue in Kontakt 7 and not a DAW or Mac/PC problem.

    My post:

    https://community.native-instruments.com/discussion/10728/kontakt-7-is-causing-high-cpu-usage-on-mac-studio-m1-max#latest

  • Tristan2b
    Tristan2b Member Posts: 4 Newcomer

    Thank you so much for your comment.

    Unfortunaly, it was working perfectly during 2 monthes. So I can tell it works.

  • Tristan2b
    Tristan2b Member Posts: 4 Newcomer
    edited March 2023 Answer ✓

    Problem solved !

    This is a good part of the solution to the restricted processor problem that concerns me…

    In the ThrottleStop software, the BD PROCHOT box is deactivated and the processor is unlocked from 0.78 to 3.60Ghz. The manipulation is to be repeated each time we reboot the computer until I have found the real solution, but it can already help me out. Once the option was unchecked, my fan started immediately. ThrottleStop with its BD PROCHOT option to uncheck is surely a very useful solution for a person who sees their processor restricted for an unknown reason.

    I will create another topic about this abnormal CPU throttling. Maybe I left my computer running a little too long while it was working, and something went into safe mode somewhere. I think my BIOS will have an explanation with me in the coming days.

  • EvilDragon
    EvilDragon Moderator Posts: 1,021 mod

    Another thing you could check out is Kontakt's multicore processing setting in Options->Engine. Try setting it to max cores that you have and see how it goes.

  • Tristan2b
    Tristan2b Member Posts: 4 Newcomer

    Thank you for your comment. Already done.

  • SorooshMHS
    SorooshMHS Member Posts: 1 Newcomer

    Hey I’m having the same issue but only with specific libraries, most of NI and Heavyocity libraries have this issue.

    Did you ever fix the problem? If so how did you do it?

  • Milos
    Milos Member Posts: 1,867 Pro

    You can try reducing the sample rate to 44.1 khz, it can numb the CPU a little bit, as well as deleting duplicate files inside your computer.

    Let me know if it helped you.

Back To Top