Voicing piano in Logic Pro (solved)

Alta
Alta Member Posts: 7 Sine
edited February 18 in Komplete Kontrol

Hi,

Until last week I was able to use The Maverick in logic and split the Piano staff in 2 channels. Right hand would go on the Event Ch1 and Left hand would go on Event Ch2. This is critical for being able to write music in Logic. The automated splitting on C2 is just not working so my workflow depends on this...So, for some reasons I can't do this anymore. I tried to send the left hand to any of the channels available and I can't hear a sound....I tried all the piano plugins that I got with the Komplete 13 Ultimate and none of them work anymore. However, the default electric piano in Logic works and also another piano plugin from AirMusic (MiniGrand...) they all work.

I have the same issue on Big Sur and Monterey latest version.

Is there a specific setting within any of the NI's plugins to be able to hear the events sent on any other channel than channel 1?

Thank you

Best Answer

  • Alta
    Alta Member Posts: 7 Sine
    Answer ✓

    If anyone else has the same issue..I figured that in the Track the section you have to have MIDI Out Channel set to 1. Not to All as default or anything else...just 1. I am not sure why is that but it's working now...

Answers

  • Alta
    Alta Member Posts: 7 Sine
    Answer ✓

    If anyone else has the same issue..I figured that in the Track the section you have to have MIDI Out Channel set to 1. Not to All as default or anything else...just 1. I am not sure why is that but it's working now...

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 660 admin

    Hi @Alta thanks for sharing the solution! It sounds like your keyboard somehow sends MIDI on Channel 1 exclusively. Now sure which keyboard you use, but perhaps it should be set to MIDI Omni so that it sends on all channels as before?

  • Alta
    Alta Member Posts: 7 Sine

    Hi, thank you for your answer!

    I am using Komplete Kontrol s88. Do you know by any chance how can I apply that setting?

    Best

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 660 admin

    Ah if you're using a Komplete Kontrol keyboard then there's no need to set your Kontakt to Omni. 1 should be correct!

  • NeonBlackCat
    NeonBlackCat northern europeMember Posts: 31 Sine

    I’ve just seen this and like to jump this by asking how you were able to make the Air MiniGrand work in Logic?

    It works in standalone, but as a plugin version stayed dead silent (and I have this with other midi stuff like SampleScience as well).

    Also on a S88 mk2 here and I’d like to know the omni-option pls! :)

  • Alta
    Alta Member Posts: 7 Sine

    I don't remember to even had an issue with MiniGrand...it just worked without any effort. But I had issues with other plugins in the past. I was able to solve everything with a logic reinstall. It was kind of painful but it worked for me. Also, check with the vendor..they may have specific answers to specific questions.

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 660 admin

    If you use KONTAKT as a plugin I believe you should configure the MIDI settings in Logic.

    As for omni or channel 1, @Jeremy_NI can you enlighten us? 😀 You might have dealt with similar issues before.

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 668 mod

    Well, if you are using a multi instrument, omni woulodn't be a good idea. By default Kontakt will load the first instrument on channel 1. You can easily change that MIDI channel:

    There's an article in our knowledge base about it:

    Configuring your MIDI Keyboard / Controller in KONTAKT

  • NeonBlackCat
    NeonBlackCat northern europeMember Posts: 31 Sine

    Thx, will check with them and lucky you that everything just worked. I think I’ve upgraded too aggressively to all the newest systems on my Mac and some plugins couldn’t hold pace! ^^

Back To Top