Kontakt 6 - Showing GUI Issues how to resolve?

Gibson845
Gibson845 Member Posts: 39 Member

hi guys, i made presets with the factory library and it seems kontakt now loads the old GUI/not from the current library the GUIs, i had this with Evolve and Evolve Mutations and just had to RE-LOCATE in Native Access the paths and the GUIs were fine then. but here it doesnt show any problems in Native Access. The Sounds are correct but not the GUI :/ anyone any ideas ?


in Native Access the Kontakt Factory Library's path is correct.

in Kontakt 4 it is normal (left) but only in Kontakt 6 when i load the preset it shows like this (right)

but when i load in Kontakt 6 some factory library patches it shows normal. it seems only the presets i created with Kontakt 4 and load in Kontakt 6 show this strange.

Best Answer

  • EvilDragon
    EvilDragon Moderator Posts: 1,019 mod
    edited March 2023 Answer ✓

    @Jeremy_NI That is not the issue here. The issue is that Kontakt 4 library did not use NKR resource container, instead all the graphical assets were installed at

    C:\Program Files\Common Files\Native Instruments\Kontakt 4\Pictures\

    If these K4 patches are attempted to be loaded in K5, K6 or K7, these pictures need to be copied to the related paths for those subsequent versions of Kontakt:

    C:\Program Files\Common Files\Native Instruments\Kontakt 5\Pictures\

    C:\Program Files\Common Files\Native Instruments\Kontakt\Pictures\

    C:\Program Files\Common Files\Native Instruments\Kontakt 7\Pictures\

Answers

  • Uwe303
    Uwe303 Moderator Posts: 2,903 mod

    do you load your presets via kontakt browser\files? The GUI is in the instrument script, and this one is locked as far as i can see if i click on the wrench sign and script editor - options

  • Gibson845
    Gibson845 Member Posts: 39 Member

    thx a lot but now it gets strange, Kontakt 5 right / kontakt 6 left, the patch from Kontakt 5 is a kontakt 4 preset, it shows correctly, but again not in kontakt 6 :ud:


    [img]https://i.imgur.com/dB5FHqh.jpeg[/img]


    Both Kontakt 5 and 6 have the same Factory Library folder


    [img]https://i.imgur.com/0mLRinw.jpeg[/img]

    E:\Vst Files\Native Instruments\Kontakt Factory Library

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @Gibson845 Scrambled GUIs in Kontakt can usually be fixed by opening Kontakt in standalone and select a coreaudio driver on Mac or an ASIO driver on Windows. Does that work for you?

  • EvilDragon
    EvilDragon Moderator Posts: 1,019 mod
    edited March 2023 Answer ✓

    @Jeremy_NI That is not the issue here. The issue is that Kontakt 4 library did not use NKR resource container, instead all the graphical assets were installed at

    C:\Program Files\Common Files\Native Instruments\Kontakt 4\Pictures\

    If these K4 patches are attempted to be loaded in K5, K6 or K7, these pictures need to be copied to the related paths for those subsequent versions of Kontakt:

    C:\Program Files\Common Files\Native Instruments\Kontakt 5\Pictures\

    C:\Program Files\Common Files\Native Instruments\Kontakt\Pictures\

    C:\Program Files\Common Files\Native Instruments\Kontakt 7\Pictures\

  • Gibson845
    Gibson845 Member Posts: 39 Member

    thx so much guys yes EvilDragon solved it! i have to check why i didnt get Mailreplies here and wondered what's up, thx a lot!

  • rssouza
    rssouza Member Posts: 2 Newcomer

    Where are these files on mac? I am having the same problem with Kontakt 7. In Kontakt 6 the instrument GUI is fine but the same files present problems when I open them with Kontakt 7.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,801 mod

    @rssouza This issue was very specific and related to a Kontakt 4 instrument. Do you have this issue with only a few products or for all of them? Open Kontakt 7 in standalone and choose a Core Audio driver. Does it fix the issue?

Back To Top