Komplete Kontrol on Cubase - Instance not selected automatically

Sarbos
Sarbos Member Posts: 6 Newcomer

Hi guys,

I'm having an issue with Komplete Kontrol when used as a plugin and I was wondering if anybody has found the answer to this question. I'm using Cubase, but I'm suspecting that the same issue exists on other DAWs as well.

When selectin an instrument channel that has Komplete Kontrol loaded on it as a as plugin on Cubase, my hardware keyboard (S88 MK2) is displaying the "Midi" screen instead of the "Plug-In" screen and there's nothing I can press on the hardware instrument to change that and start browsing sounds. Instead, I need to open the software plugin on Cubase and click on the little keyboard icon (screenshot below) to make it connect to my hardware S88 properly, show the "Plug-In" screen, and let me browse the library from the hardware keybaord.


Does anybody know how I can configure things so that my hardware keyboard automatically connects to the right instance of Komplete Kontrol when I select the channel that the plugin is loaded on?

I know that this is possible because it used to function exactly that way in the past before it suddenly stopped doing it one day.

Thanks

Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod

    @Sarbos What version of Komplete Kontrol are you using? Are you running Cubase and Komplete Kontrol as admin? How to Run a Program as an Administrator

    If you have an antivirus active, try deactivating it or whitelist the NIHardwareAgent or NIHostIntegrationAgent services.

    Can you check this?

    The NIHardwareAgent or NIHostIntegrationAgent services are not running in the background

    Make sure that the services NIHardwareAgent and NIHostIntegrationAgent are running on your computer. Follow these steps: 

    1. Click on the Start button, type Task Manager, and press the Enter key on your keyboard to open the Windows Task Manager. Choose the Services tab.
    2. Note: If the Services tab is not directly available, expand the view by clicking 'More details' in the lower-left corner of the window.
    3. Search the list and check if the Status of the services NIHostIntegrationAgent and NIHardwareService is set to Running:

    If not, right-click the respective entry and choose Start from the context menu:

    Restart you computer

    If the issue is not fixed, get in touch with our support here: ttp://bit.ly/NIsupport_KKontrol

  • Sarbos
    Sarbos Member Posts: 6 Newcomer

    Thanks a lot for your help @Jeremy_NI - I really appreciate it.

    Just now, I uninstalled the older version of Komplete Kontrol that I was using, and I installed the latest version (3.00). I love the way the new version looks (so much better than the older one), but unfortunately this didn't solve the problem.

    Once I installed the latest version, I followed the instructions to make sure that windows will always run the Komplete Kontrol exe file as an administrator. This didn't fix the problem either.

    Finally, I checked whether the NIHostIntegrationAgent and NIHardwareService services are running, and it looks like both of them are running correctly - so no changes here.

    The only step I didn't try yet is to whitelist Komplete Kontrol on the Eset Internet Security antivirus that I'm using. I'm not sure if this is the problem here given that when I open Komplete Kontrol as a standalone program, it automatically connects to my hardware keyboard correctly, without any issues. However, when I'm using Komplete Kontrol as a plugin on Cubase, my hardware midi keyboard doesn't auto-focus to the Komplete Kontrol instance of the selected channel (until I manually open the plugin and click on the keybaord icon).

    Let me know if you still think I should try the antivirus solution, and I will do it in case that works. In the meantime, I'll also contact Support using the link that you kindly provided.

    Thanks

  • Uwe303
    Uwe303 Moderator Posts: 2,913 mod
    edited October 2023

    Have you installed the keyboard as DAW controller in cubase, I mean that the transport buttons and all that work.

  • Sarbos
    Sarbos Member Posts: 6 Newcomer

    @Uwe303 yes I have set it up as DAW controller on Cubase. All transport controls are working perfectly fine.

    One more thing I noticed just now is that the "Native Instruments" folder in my "Program Files" as well as the "Native Instruments" Folder under my "Documents" folder don't include any Komplete Kontrol files or folders. This is strange because somehow Cubase still discovers Komplete Kontrol and opens it as a plugin with everything working as expected, except for the auto-focus function. Not sure if this means anything, but I thought I'll mention it here since I noticed it.

  • Uwe303
    Uwe303 Moderator Posts: 2,913 mod

    The newest version is vst3 so on windows you should find it under "C:\Program Files\Common Files\VST3"

  • Uwe303
    Uwe303 Moderator Posts: 2,913 mod
    edited October 2023
  • Sarbos
    Sarbos Member Posts: 6 Newcomer

    Thanks @Uwe303. I had a look at the article that you posted and it made me so excited, thinking this must be the solution and running back home to try it. Unfortunately, it didn't fix the problem :-/

    The behaviour that the guys are mentioning on that thread is exactly the same as mine. They seem to be describing the exact same issue. When I'm trying the solution they recommended however, it's not working. I can post some screenshots if you guys are happy to help.

  • Uwe303
    Uwe303 Moderator Posts: 2,913 mod

    Yes absolutely, post some pictures, have you maybe set some midi filters or something. If that all does not help you could also try to reset cubase and try again. You hold "shift - Ctrl/cmd - alt" and start cubase. Then you can select also to temporarily start with defaults as far as I remember. I'm pretty sure it must be a cubase/midi thing, cause you have checked everything jeremy told you.

  • Sarbos
    Sarbos Member Posts: 6 Newcomer
    edited October 2023

    Hm I'm not sure what midi filters are or how to use them - maybe I did this accidentally. Could it also be related to the fact that I'm using multiple midi devices?

    I just tried to start Cubase with "Shift-Ctl-alt", and I'm getting the below message. I clicked on Delete program preferences, and I literally lost all my preferences for good - not just for this one special boot. I guess I'll have to uninstall Cubase now and re-install it as I don't have much to lose at this point


  • Sarbos
    Sarbos Member Posts: 6 Newcomer

    I literally just spent all day reinstalling Cubase, and also updating my OS to Windows 11 from Windows 10. None of these things worked.

    Any other ideas?

  • Uwe303
    Uwe303 Moderator Posts: 2,913 mod

    Have you set midi in and output port for the DAW integration, you can simply test it by pressing play in cubase and the keyboards play button should lit up. Maybe contact support, they can analyze it and help. I will also check out later with my cubase if I can come up with something at least to analyze. Cubase has a midi monitor we can use but I have to do it first so we know what signal should be there if you select a track.

  • Uwe303
    Uwe303 Moderator Posts: 2,913 mod
    edited October 2023

    do you see bome midi under device manager, and have you set daw port in and out?

    you can try to uninstall bome midi via windows apps, then reinstall from here:

    BMIDI Virtual MIDI SDK – Bome Software

    also set it up like here

Back To Top