Guitar Rig 6+M-Audio Solo doesn't work

Soloveyko
Soloveyko Member Posts: 4 Member
edited February 2023 in Tech Talks

Hello everyone!

I've bought audio interface M-Audio Solo and now I'm trying to connect Guitar Rig 6 with it. And have some problem, input signal doesn't exist. Can you help? Do you have ideas how to fix it?

System: MacBook m2, macOS Ventura

Thanx

Tagged:

Best Answer

Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 9,595 mod

    Hey @Soloveyko you might want to check this article? macOS Dialog: “*App Name* would like to access the microphone."

    Did that fix it?

  • Soloveyko
    Soloveyko Member Posts: 4 Member
    edited January 2023

    @Jeremy_NI thanx for your answer. Micro is enabled for Guitar Rig and it works with micro. But doesn't work with USB AUDIO CODEC device

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 9,595 mod

    I don't have a M-Audio Solo at hand. I know it's class compliant and doesn't need a driver, but is this USB AUDIO CODEC supposed to be the driver for this soundcard ? Is this soundcard supported on Ventura ? DOes it support M1/M2 ? Do you mean you have no option to choose from for Guitar Rig 6 in L and in R ?

    Are you able to use it in other applications, like your DAW? Does Guitar Rig also have Full Disk Access? How to Enable Full Disk Access on macOS

  • Soloveyko
    Soloveyko Member Posts: 4 Member

    @Jeremy_NI

    Yes, card with this driver works in another programs as Guitar Rig, AmpilTube etc.

    Guitar Rig has full access for all options that it needs. If I chose Built-in device it works with micro, but if I chose usb audio codec device I can't add input signal at all.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 9,595 mod

    Can you give this a try?

    Delete the User Preference (PLIST) File

    1. Go to the following location of your computer:
    2. Macintosh HD > Users > *Your User Name* > Library > Preferences
    3. Note: The User Library folder is hidden on macOS. See this article for instructions to access this hidden system location.
    4. In the Preferences folder, locate the plist file for your GUITAR RIG version and delete it. In this example, we delete the plist file for GUITAR RIG 6.


    Note: Deleting other plist files could result in unexpected behavior with other applications.

    Reopen GUITAR RIG to check that the issue has been resolved.

  • Soloveyko
    Soloveyko Member Posts: 4 Member

    @Jeremy_NI still not working

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 9,595 mod

    @Soloveyko I've contacted you by email regarding this issue. We need to have a deeper look.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 9,595 mod
    Answer ✓

    @Soloveyko You never replied to our emails regarding this issue. Since you gave no news, I'll close this thread. If you still need assistance, please get in touch here: https://bit.ly/NISupport_GR

This discussion has been closed.
Back To Top