Got a second hand Mashine 2 gen 1, lcd screen lights up. But is blank.

DJ White Dragon
DJ White Dragon Member Posts: 14 Member

Got a second hand Mashine 2 controller including transfer of software licenses. downloaded all software using Native Access. Up-dated drivers and even up-dated the firm-ware. Then connected the controller to usb, all buttons work and light up, even browsing buttons- knobs work with the Maschine 2 software.

But for some reason both the LCD screens do not show any text. The LCD screen lights up with what looks like a background light but no text, can someone help? My question is: are both LCD screens broken or burnt out? and has anyone come across this fault before? I have looked on NI There is no information about Maschine 2 LCD screens not working and how to fix it or information on if it even can be fixed..

Thanks,

Best Answer

Answers

  • Peter Harris
    Peter Harris Member Posts: 470 Pro

    Do you mean the MK2 with the monochrome screen?

    I presume you've tried restarting the computer without (booting the computer first and after the computer has finished startup completely then plugging in the USB) and with (having the computer connected to the controller by USB before powering up the computer)? Is the display any different in those situations?

    You might also try a different USB port on your computer. Some have USB2 ports as well as a newer one.

    And is it not displaying properly a new thing or have you never seen it function properly?

  • DJ White Dragon
    DJ White Dragon Member Posts: 14 Member

    My computer this morning has been booted from start. Both LCD screens now display in mono-chrome MASHINE on the left screen and on the right screen the words, start Mashine software or press shift + control for midi. The initial problem seems to be fixed. I won't know for sure until I launch the Maschine controllers software. but I think this is now fixed.

    Thanks for your advice. :-)

  • Peter Harris
    Peter Harris Member Posts: 470 Pro

    Glad to hear it! You've got lots of fun ahead...

  • DJ White Dragon
    DJ White Dragon Member Posts: 14 Member

    NOPE this same problem has returned. As soon as I try to connect and run my new M32 keyboard on a separate usb-3,0 port that is directly into the computer and activate run as administrator for the komplete kontrol software / the Maschine 2 software and hardware that is connected to a separate 2.0 usb port wont light up the LCD screens like it did before at start up. now the LCD screens are blank again.. This is so frustrating and counterproductive.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,935 mod

    @DJ White Dragon Have you tried other USB ports configurations, like switching the one for the M32 and the one with the Maschine controller? Do you have a self powered USB hub to try to connect the devices with?

  • DJ White Dragon
    DJ White Dragon Member Posts: 14 Member

    M32 key board lights don't light up either.. (separate usb 3.0 port directly into computer). I think that I have to many usb-2.0 ports that need power... atm I have a non-powered 7 port usb hub connected to that is a Traktor S4 Mark 2 DJ controller (Has its own power) then 2 x Traktor Kontrol F1s controlling (Deck C and deck D) these are running of the power supplied by the non-powered usb 2.0 hub and last is the Mashine Mark 2 Groove box controller this requires power from the usb 2.0 hub as well.. The only thing I think will fix the issue is to find an old 8 port usb 2,0 powered hub, I really don't understand why NI has most of its hardware products running on only usb 2.0 with no driver development up-grades to 3.0... Most tower commuters only have 4 usb 2.0 ports and with a laptop your lucky to find 2. Directly into my computer I have 4 2.0 usb ports,, the keyboard and mouse take up 2 then an external sound card takes up 1, that leaves only 1 port left for the usb 2.0 hub.

    As most products from NI only work with usb 2.0, a powered usb 2.0 hub I think is the only solution that will fix the issue,, :-( good luck with finding an old powered usb 2.0 hub as they don't make them anymore..

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,935 mod
    edited January 2023

    @DJ White Dragon A USB 3.0 self powered hub should work as it aslo supports USB 2.0. A little tip (a personal one as it's not endorsed by NI as a company). I use one of these personnally for all my music devices, NI and not NI and it has been working great:


  • DJ White Dragon
    DJ White Dragon Member Posts: 14 Member

    Thanks Jeremy. I think the issue is a USB overbridge one, (connection between the controller and the software) as the Mashine mark 2 controller requires 2 background software programs to work in conjunction with the main software that is displayed on the screen. I will get myself an Overhub and give it a go.. Then later I will let you know if it fixes the issue, If it does... it would be great future advise for anyone else who has come across this same issue with their Mashine controller. Barry.

  • DJ White Dragon
    DJ White Dragon Member Posts: 14 Member

    So got my overbridge 7 port hub. First things first. (Warning) Hub not recognized by computer, using direct usb-3.0 connection... Regardless of this notification and after a re-start. I then opened the Machine mark 2 software before connecting the Mashine mark 2 usb cable to the overbridge hub. It took a number of try's in different hub ports... before it was properly recognized (once recognized) only confirmed by the monochrome lcd panels showing text. This has now fixed the main issue. After I followed by connecting the M32 Komplete Kontrol usb cable, All buttons light up and the browser knob on the M32 works with the Mashine mark 2 software. But I still have no keyboard keys blue led light or sound from the M32 keyboard when opening or trying to use the Komplete Kontrol Software. There is sound if I use my mouse and click on the preset in the software....

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,935 mod

    @DJ White Dragon There are no led lights on the M32, this only comes with S series. If you open Komplete Kontrol in standalone and open the preferences, can you post a screenshot of your MIDI inputs and ouputs? SAme within the Maschine software ?

  • DJ White Dragon
    DJ White Dragon Member Posts: 14 Member

    These are from Komplete Kontrol connected to the M32 keyboard... There is no sound when playing the keys.. For my sound studio monitor speakers (sound output) I use Yamaha Steinburg usb 2.0 external sound card. C12 that is also connected to my Cubase DAW.... Interesting though is the M32 keys work (make a sound) within my DAW. Not sure what boxes need to be ticked to get this whole system up and running properly though.

  • DJ White Dragon
    DJ White Dragon Member Posts: 14 Member

    These screen shots are from The Mashine Mark 2 and this system is working properly... Sound is output from the Yamaha Steinburg C12 usb 2.0 external sound card (note) none of the boxes in midi in or out are ticked but the system still works...

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,935 mod
    Answer ✓

    Hey @DJ White Dragon You need to tick these as MIDI inputs in both Komplete Kontrol and Maschine.


Back To Top