Kontakt 7 - adding 3rd party libraries

Options
kripke
kripke Member Posts: 12 Member
edited January 2023 in Kontakt

I've just upgraded to Kontakt 7 and I'm trying to add my 3rd party libraries so they show up in the new style library display window.

When adding folders via Settings (cog wheel)>Import Content, I'm getting a few "Incompatible File" messages. I'm also getting some where no error message appears, but the folder just doesn't get added to the content display (even though it does show up the list of added folders under Import Content).

NB - All these instruments load perfectly well via the old style browser window.

Any guidance on what's causing these issues? Is there a fix or do I have to go back to using the old browser window.

Tagged:

Comments

  • Kaiwan_NI
    Kaiwan_NI Administrator Posts: 2,628 admin
    Options

    Hi @kripke can you please double-check if you followed the instructions on this page?

    How to Add Non-Player Libraries to KONTAKT 7's Browser

    Also make sure all the libraries are given full-disk access in System Preferences > Security & Privacy > Privacy > Full Disk Access just in case.

  • Massiv3
    Massiv3 Member Posts: 1 Newcomer
    Options
  • Psalmster
    Psalmster Member Posts: 12 Member
    Options

    I have the same issue. Specifically, several of my Embertone Instruments simply do not show up in the Kontakt 7 new browser.

    However, if I click the Cog Wheel and see the Import Content window, I can see them having been imported if I scroll down.

    When I try to re-import them, Kontakt tells me they've already been imported. But they don't show up. Closing and relaunching Kontakt doesn't change anything. Some Emberton Libraries show up (i.e. Walker 1955 Steinway, Joshua Bell, and Mountain Dulcimer) while others do not (i.e. Chapman Trumpet, Canjo, and several free instruments).

  • Flux
    Flux Member Posts: 1 Newcomer
    Options

    I'm having the same issue as the OP. I am getting the "Incompatible Files" message when I import some of my folders (Imperfect Samples Pianos) using the procedures for importing custom libraries. After that, while they show up in the list of imported libraries in the import window, the folders do not show in the library view.

    As anotehr user has mentioned, I can load the patches using the standard drag and drop of the instruments in Kontakt 7 and they play fine, but again the folders won't show up when I add them and I am getting the "incompatible files" error message when I try.

  • RJH_MUSIC
    RJH_MUSIC Member Posts: 6 Member
    Options

    Same issue here. Any response to this problem. I have several 8Dio libraries. Some can be added and some display encompatible files. Checked all the library folders and they are all configured the same


    Rj

  • RJH_MUSIC
    RJH_MUSIC Member Posts: 6 Member
    Options

    I solved one problem. Read the manual on this and for the libraries that display "Incompatible Files" I performed a batch re-save on them and now they appear in the browser after adding them following batch resave. I also successfully created images for all of my libraries and placed them in the NI Resource, Image folder as sub folders for each instrument. Only two issues left to solve. on Adding a library, getting the "Duplicate Path Found" but the library does not show up in the installed library box. an the folder is not displayed in the Browser. There has to be some folder somewhere where the information is stored?? Last thing is that following the instructions for adding pictures to the folders in the Browser for third party libraries sometimes works and sometimes doesn't. I have 8Dio Adagio Strings. Added folders and images for Adagio Basses, Adagio Cellos, Adagio Violas and Adagio Violins. the only folder to show the picture is the Adagio Violas. Do not understand as the exact naming conventions are used for all four?? Any ideas what is wrong. I have found that the Image folder does not pike the word "Library" in the title. For example, Cantus Library won't show the picture, but Cantus does!

  • cmopatrick
    cmopatrick Member Posts: 2 Member
    edited June 2023
    Options

    I'm having this trouble as well. K7 full version, first time trying to import one of my 3rd party non-player libraries; in this case, I'm trying to get Dicky Deegan's Uilleann Pipes to work. The instruments lib has 5 .nki, attempts to import it or the folder above it both get the incompatible files message. I've tried to add the individual .nki with the import subfolders option, but again, that doesn't work. I've even tried the batch resave and it gives me errors for all 5 .nki files.

    I can add the instrument manually by dragging the .nki; that takes me directly into a single instance of the instrument, and it does not show up when I return to the Kontakt folder view.

  • stewart hannah
    stewart hannah Member Posts: 3 Member
    Options

    Whilst I am sure everyone is grateful to NI for finally allowing their customers to import 3rd party unauthorised libraries into Kontakt, this is obviously still "work in progress". For many of us Kontakt is our main default sampler as much as central to our workflow and this additional feature is LONG OVERDUE. However as work in progress there is still clearly much work to do to make it clean and integrate efficiently into the main Kontakt preset/instrument database. Its still clumsy and dirty, awkward and incomplete. AS the owner of the Smk2 the new Mk3 keyboards are obviously an upgrade but its the software, specifically Kontakt/Komplete Kontrol that lets them down, these are not cheap machines but the software is clumsy at best I do hope KK2 is a big improvement?

  • Octavio
    Octavio Member Posts: 8 Newcomer
    Options

    I have the same problem, I tried to import a Third party library and Kontak7 does not recognize the NKI file, did anyone find a solution?

  • mozart999uk
    mozart999uk Member Posts: 19 Member
    Options

    I've got hundred of downloaded kontakt instruments which are non player, spread across 3 SSD drives. NI, you really need to sort this out. Please just bring the database function back....

  • Norik
    Norik Member Posts: 1 Newcomer
    Options

    did you find a solution for this I also have the same problem!

  • TORLEY
    TORLEY Member Posts: 88 Helper
    Options

    I'm having a similar problem like what @cmopatrick said. I have various older .nkis that DO load when I drag-and-drop them into Kontakt 7, they still play fine.

    BUT... I can't seem to batch resave them with standalone, it does nothing.

    AND... when I try to scan the folder, it says they're incompatible. This is clearly NOT correct.

    Is anyone experiencing the same?

  • elxsound
    elxsound Member Posts: 7 Member
    Options

    Same problem.

    1. File→Load→Select NKI
    2. File→Batch Resave
    3. Choose Yes on Pop-Up
    4. Select "Open"
    5. *if multiple subfolders, repeat for all NKIs in separate folders
    6. Select Cog Wheel, and add as instructed. There should be no more incompatibility messages.

Back To Top