Kontakt 7 Factory Library "the instrument belongs to a library that not installed" error message

Buddy Love
Buddy Love Member Posts: 9 Member
edited December 2022 in Native Access

This error message keeps happening for Kontakt Factory 2 .. even though Native Access says it is installed correctly .. BTW I have the current version of NA..

I recently purchased Session Guitar Mint and upgraded to Kontakt 7..

Session Mint did not install properly so I have to do a work around .. which entailed installing it from the downloaded folder of my saved preferences in NA, and then clicking locate and confirm in NA. ( that worked ) When Kontakt 7 failed to install through NA I tried the same procedure but alas it did not work.. I get that wonderful "the instrument belongs to a library that not installed" error message .. even though NA says it installed...


Tagged:

Best Answer

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,949 mod
    edited January 2023 Answer ✓

    Hey all, the issue is finally fixed. For new users the Kontakt Factory Library 2 will insttall and work as expected in Kontakt. For the affected users I will sum up everything that needs to be done here, as it seems that reinstalling in Native Access will not fix the issue, unfortunately.


    For Mac users:

    Solution 1:

    • Delete this file: Macintosh HD > Library > Preferences > com.native-instruments.Kontakt Factory Library 2.plist
    • Restart your computer
    • Reinstall with Native Access

    Solution 2:

    • Please download the attached zip folder, unzip it and move the plist file to the following location: 
    • Macintosh HD > Library > Preference

    Important!

    To navigate to the correct Preferences folder please follow these steps:

     Open the "Go" dropdown menu of the Finder and select "Computer"

    • Navigate to Macintosh HD > Library > Preferences , right-click the "Preferences" folder and paste the downloaded Kontakt Factory Library 2 plist file into it.
    • Alternatively you could also drag and drop the plist file into that Preferences folder
    • If prompted, select "replace". 
    • Restart your computer
    • Open Native Access
    • Press the "Repair" button next to "Kontakt Factory Library 2"
    • Browse to and select your "Kontakt Factory Library 2" folder


    For Windows users:


    The problem seems to be caused by a faulty Registry entry of the Kontakt Factory Library 2:

     [HKEY_LOCAL_MACHINE\Software\Native Instruments\Kontakt Factory Library 2]

    "HU"="EBF1709EED746817037A58398DA78BAD"

    "JDX"="06CD237BDDA24E444D7F7723AAA1C520E947D5C99BB6EDA62880A3A726851252"

     Those values should look like this:

    "HU"="B912447ABDAED32DA2290A518813BB32"

    "JDX"="363F9CF471EB332719F296BD130100E60B72592BF1DA4B869A74DCD650FF5BF5"

     

    We have created this little attached file which will replace the faulty values with the correct ones when carried out.

     

    Simply download and unzip it first.

    On our system it was enough to double-click it and after I agreed to the pop up informing me about the Registry getting edited, they got updated.

     Alternatively, if you are familiar with the Registry you could also replace the faulty HU and JDX values manually.


    If the issue persists,

    Please get in touch here and our support agants will help you out fixing the issue: http://bit.ly/NIsupport_install

    We'd like to apologize once again, sorry it took so long to get this fixed.

«13456

Answers

  • anthony-1979
    anthony-1979 Member Posts: 28 Member

    This is happening to me too. Annoying considering that not even the original factory library is working in Kontakt 7. It works fine in Kontakt 6. So both factory libraries are non existent in the main product they're designed to work in. C'mon NI how can everything else work except the main library designed for the plugin?

  • Kaiwan_NI
    Kaiwan_NI Administrator Posts: 2,525 admin

    Hi @Buddy Love please keep us updated if the workaround provided by the support team helps. 🙏

    @anthony-1979 can you please get in touch with our support team directly so we can have a closer look? https://bit.ly/n1konta

  • richardsun
    richardsun Member Posts: 10 Member

    I get the same error. I uninstalled Kontakt 6 and the old factory library, and installed Kontak7 and the new factory library. But Kontakt 7 cannot load any Kontakt Factory Library 2 instruments. Moreover, the uninstalled Kontakt 6 shows as in need of repair in Native Access. I have requested help from support.


  • lukasz.brzesniowski
    lukasz.brzesniowski Member Posts: 1 Member
    edited December 2022

    Hello. I have the same problem. After installing a fresh copy of macOS Ventura and Kontakt 7 and its library, the same error pops up right away. This is the fault of the last update of Kontakt 7. Additionally, in Komplete Kontrol and Maschine 2, Kontakt 7 libraries and instruments are displayed without icons in the category marked as Other. Please fix this bug quickly

  • OlivierCas
    OlivierCas Member Posts: 2 Member
    edited December 2022

    Hi, I have the same problem...


    Pretty frustrating. Only affects my "Kontakt Factory Library 2", which I just purchased. All other instruments work well.

    NI can we get help? :)

  • Atom71
    Atom71 Member Posts: 1 Newcomer

    Same here. Super frustrating!

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,949 mod

    @lukasz.brzesniowski You seem to have 2 separate issue, we don't have a workaround yet for Mac for the KFL2 not working but for the thumbnails missing, please follow these steps: Thumbnail Picture Icons are Missing in the Komplete Kontrol / Maschine 2 Browser And if the images are also missing in Kontakt 7: Thumbnail Picture Icons are Missing in the KONTAKT 7 Browser

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,949 mod
    edited December 2022

    Hey all, issue is still being investigated but we now have a workaround,

    For Windows user, here is how to fix it:

    Please first reinstall Kontakt 7 via Native Access.

    Next, apply the following steps to KFL2: Fixing Software Update Installation Issues (Windows)

    Next, delete the 91b443f7-08d6-483c-8bd6-e4402e74dd32.jwt file in the following folder: 

    C: > Users > Public > Public Documents > Native Instruments > Native Access > ras3

    Restart computer and open Native Access.

    Press “...” next to KFL2 and select “Locate”

    Point Native Access to the KFL2 folder

    Finally, open Kontakt 7 in standalone as admin.



    For Mac users (also works for Windows); here is an iso installer: Kontakt Factory Library 2

    It's an iso file that works for Windows or Mac.

    How to Mount an ISO Disk Image (Windows)

    How to Mount an ISO Disk Image on macOS

  • SoundMan
    SoundMan Member Posts: 1 Member

    Hello. I have the same problem.

  • KG70
    KG70 Member Posts: 9 Member

    Is anyone else having further problems with this download link failing?

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,949 mod

    @KG70 Yes it seems there is an issue with the download. There might be too many people downloading from our GoogleDrive at the moment, we're trying to find an alternative. Sorry for all that.

  • KG70
    KG70 Member Posts: 9 Member

    Managed one download over night! Other problem is I can only install on to my Mac hard drive not my SSD.

    Can I install and move it later or is that just another rabbit hole?

    And thanks for your time and help!

  • KG70
    KG70 Member Posts: 9 Member
    edited December 2022

    Just had success with the work around suggested by Rich @ NI

    Down grade to Native Access 1 and Re-install Factory Library 2

    How to Downgrade Native Access 2 to Native Access 1

    When I followed the directions there was 2 files I had to remove as it failed the first time; these being:

    'com.native-instruments.Native Access.plist' and 'com.native-instruments.nativeaccess2.plist'

    Give it a whirl it worked for me on my MBP M1 Max, Ventura, Standalone and in Logic X.

  • GraemeW
    GraemeW Member Posts: 1 Newcomer

    Hi all.

    Same problem here! just updated to 14 on M1 Mac. Tried relocating, reinstalling and still same issue. Currently trying the Native 1 route.

    Google link for the Mac download is still down. 😟

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,949 mod

    @GraemeW It seems the fastest way to resolve this is to install it with Native Access 1, as @KG70 posted.

Back To Top