Want to load Traktor Pro for a 1st gen S4 to Mac OS Sierra, where to get download link?

Options

I have an older S4, probably a 1st generation controller (I purchased in 2012), and I want to sell this/gift to a friend who has an older Mac with OS Sierra. How can I get a proper Traktor Pro download for my friend to make sure it will still work with his computer? I know how to transfer a license, but not sure if he will be able to get software that will work on his older Mac.

Answers

  • Ryan_NI
    Ryan_NI Customer Care Posts: 191 mod
    Options

    hey @urbnlgnd - unfortunately, the minimum system requirement for Traktor Pro 3 is macOS 10.14 (Mojave)

    it depends on which version of Traktor you have in your account, that's what would determine if you'd be able to transfer the software and for it to work.

  • urbnlgnd
    urbnlgnd Member Posts: 3 Member
    Options

    But can I still get Traktor Pro 2? That is the only software that works with older S4’s from what I understand.

  • Uwe303
    Uwe303 Moderator Posts: 3,235 mod
    Options

    If it's an older controller that came with traktor 2 then you have to transfer the license to your friend, you should be able to do that under the "my products" page online.

  • urbnlgnd
    urbnlgnd Member Posts: 3 Member
    Options

    Ok thank you, I wasn’t sure that he would be able to still download the Traktor Pro 2 software (and not scratch). We had tried to get Traktor Pro as a download and it was scratch. I will initiate the transfer and hope for the best!

Back To Top