Kontakt Multiple Instruments to output but Pro Tools not seeing additional channels

gstockton
gstockton Member Posts: 5 Newcomer

I am running Pro Tools on Mac Monterey 12.1 with Kontakt. I am having trouble routing more than just one instrument onto its own track in Pro Tools. I load a NOIR Pure piano, set it to Midi Ch 1, by default it assigns output to Stereo Ch 2 and I can hear and record it just fine. I add Synth Pad and set Midi to Ch 2 and the Stereo output to a new St. 3, it says st. 3 [2 ch. routed 5|6]. I can see the output meters moving when the Pad is turned on, indicating the Pad is making sound. However, in Pro Tools I have the two Stereo Audio tracks created, the Piano comes in ok on Kontakt St. 2, but the other Stereo Output I created in Kontact is not seen by Pro Tools. On the Pad Audio track, I go into Kontakt plugin but all I see is Kontakt St. 2 and four Kontakt aux 1, 2,3,4. no additional Stereo Channel to pull in the Pad audio. It seems ProTools is unable to see the audio channel outputs being created in Kontakt.

What am I doing wrong? I have been pulling my hair out trying to get this sofware to work.

Best Answer

Answers

  • Uwe303
    Uwe303 Moderator Posts: 2,910 mod
  • gstockton
    gstockton Member Posts: 5 Newcomer

    I am using Kontakt with Avid Pro Tools, not Logic Pro.

  • Uwe303
    Uwe303 Moderator Posts: 2,910 mod
    edited February 2022

    but the batch setup they show should apply anyway

    Uwe

    https://support.native-instruments.com/hc/en-us/articles/360017601818-How-to-Route-KONTAKT-to-Multiple-Outputs-in-Pro-Tools

  • gstockton
    gstockton Member Posts: 5 Newcomer

    Thank you Uwe303, I will step through this and let you know if it worked for me. I think I must be missing a step somewhere.

  • gstockton
    gstockton Member Posts: 5 Newcomer

    I have stepped through this several times today, but I am still not seeing the new mixer channels 3|4 in plug-in-Kontakt. All I see is the 1|2 channel for Piano. I have NIOR piano assigned to Ch 1 1|2, Hybrid Keys is set to PAD which is 3|4. In Kontakt the mixer responds and I hear sound for the PAD. However, even after restarting session with these sessions, the Stereo Audio track for PAD that I created, the only thing offered is Kontakt PAD and 4 aux channels. Should I not see a PIANO for 1|2. And PAD for 3|4 ?

    If I try to record the chords/notes from Piano and Pad, all I get on both audio tracks are Pads, it should be Piano and Pad separately.

    The MIDI tracks are working just fine. When I record enable Piano, I hear piano, when I record enable PAD, I hear the Hybrid Keys Pads. I am trying to set it up so that it can route the midi I record out to Audio Tracks. It seems as if ProTools is not seeing these additional channels I setup in the Kontakt Mixer. If it did, I would see an option to select Piano on Channel 1|2 and Pads on 3|4, but all I see is PAD on both.

  • Uwe303
    Uwe303 Moderator Posts: 2,910 mod

    The aux tracks are out 3/4 and so on, try to set them and please report back.

    Uwe

  • gstockton
    gstockton Member Posts: 5 Newcomer
    edited February 2022 Answer ✓

    I managed to get it working with the help of this video.


  • BradRushing
    BradRushing Member Posts: 1 Newcomer
    edited October 2023

    Hello -

    I have a similar problem. I am using Heavyocity Damage Drum Kit in Kontakt on ProTools.

    I have managed to create and assign the outputs. But as can be seen in this screenshot the correct OutPut names are NOT showing up in my ProTools Plug In Input routing options.

    Also I recently set up routing more successfully for an Abbey Road Drum kit. But in that instance Output 1 never showed as an option. The options start at 2 ignoring the first channel.

    This is super frustrating. What is going on?


Back To Top