S88 MK2, DAW Control randomly doesn't work, myriad other issues.

jkmlevy Member Posts: 1 Newcomer

Finally got around to installing Native Access 2 and all of my instruments/apps when the news came that most were M1 native--now with dozens of hours both testing and working on existing projects, I have had numerous issues:

-The biggest one; my S88 was identified and installed by Logic correctly, yet the transport/DAW controls fail to load up, seemingly randomly. I'll open Logic just to see the DAW controls aren't on (e.g. the play, stop, mute and solo buttons aren't lighting up in their respective colors), but opening and closing logic will magically force the DAW controls to function on the 3rd or 4th try. Have NOT been able to replicate any kind of distinct pattern (e.g. DAW controls work exactly on the third reboot of Logic, or DAW controls work after opening Komplete Kontrol standalone). It is absolutely random and a massive detriment to my workflow and creativity.

-Arturia V collection instruments won't load from Komplete Kontrol browser window due to an apparent "lack" of vst3 support (Native's own error message), yet when I use the drop-down menu to manually click on a V Collection instrument, it loads in and plays fine. Not sure who needs to fix this one here, but Arturia clearly has the necessary vst3 instruments ready for loading.

-On PC, my Roland DP10 sustain worked perfectly fine in either switch or continuous, yet when I migrated to mac M1 I had a massive multi-day headache trying to set it up. It's fixed now, but that initial frustration and seemingly arbitrary difference between platforms was needlessly frustrating.

-Installing all of the newly-M1 certified Native Apps (Komplete, Komplete Kontrol, Guitar Rig 6, etc.) causes Logic to sometimes give me an error message, even though Logic then loads up fine, and all of the instruments/plugins (save for Guitar Rig 6) play fine. This one hasn't happened since my last reinstall of the Native Apps, but I can pretty much verify it's Native that's causing it (no error messages of any sort until I install or reinstall Native Apps).

-Guitar Rig 6 M1 app is completely busted, as in it won't even load in either plugin or standalone form.

As far as my main issue--the DAW controls not loading when I boot Logic--I've tried doing clean installs in both Rosetta and native, cleaned and reinstalled the logic cs file, reinstalled all of my Native Apps--nothing has fixed it. On top of that, when I do manage to get the DAW controls to load, they work perfectly fine.

It would be great if Native was completely transparent about what's going on on their end--this M1 "update" comes years after the chipset's debut, while smaller plugin boutiques adopted the ARM architecture quickly with zero friction and minimal bugs. I get that Native also manages an entire hardware lineup, but I switched to Mac with the expressed purpose of reaping the M1 benefits in my software and hardware--all of which have transitioned and functioned seamlessly, except for the Native Instruments ones.

Back To Top