Traktor S2 Mk3 fimware update issues

Hi all,

I am having an issue updating the firmware. I have just installed 3.5.3 and a message came up saying firmware update was required. I have downloaded the latest firmware and when I came to install its saying to connect the S2.

I have just been using the S2 so know it is connected.

Clicking rescan dos nothing and I have tried plugging the S2 into different usbs and still the same. When I plug in the usb the S2 lights up.

I have downlaoded the latest audio drivers so they are up to date.


Can anyone help please?

System

Win 7

Acer windows i3 laptop.

Tagged:

Answers

  • Uwe303
    Uwe303 Moderator Posts: 2,903 mod

    Hello,

    have you tried to start the updater as admin, by right click on it and select "run as admin"?

  • helix75
    helix75 Member Posts: 3 Member

    Hi Uwe,

    Just retried it running as admin and still the same.

    I have run a check and all my drivers are up to date but its still saying please connect S2 Mk3 and rescan. My S2 is only powered by my laptop usb rather than mains, would that have anything to do with it? or because i am on win7?

  • Uwe303
    Uwe303 Moderator Posts: 2,903 mod

    Could be the windows version but i don't think so. Power could be an issue too, but i don´t think so. You can go to the device manager and delete all devices that belong to the s2, if you get asked if it should delete the drivers, say yes. After that you install the drivers again, you know where latest ones are, same page as the FWupdater. BUT the S2 must be unplugged while installation. Oh and what devices do you see in device manager?

  • helix75
    helix75 Member Posts: 3 Member

    Worked out the issue. I just had a very old laptop and the drivers werent installing correctly. Installed it on my desktop running Win 10 and all works a treat 👍️

    Thanks

Back To Top